Jump to content
Pais

Are Taglines Read from movie.xml?

Recommended Posts

Pais

I have been trying to get all my taglines in order to take advantage of the recent display change for the server without any luck. It seems that if I add it via the web client it is written to the movie.xml file. However, if I edit the value in the movie.xml file then upon refreshing the movie in the web client the Tagline field is blanked.

 

Does anyone know if this is supported for xml files?

Share this post


Link to post
Share on other sites
ebr

The default for the server is NFO now.  Do you also have nfo files?

Share this post


Link to post
Share on other sites
Pais

There are no NFO files. Do I need to migrate my thousands of movie.xml files to NFO?

Share this post


Link to post
Share on other sites
ebr

No, we should still read the xml fine.

 

Why are you trying to edit the xml directly since the metadata manager works?

Share this post


Link to post
Share on other sites
Pais

My movie.xml files come from a third party program and they already contain the Taglines in the movie.xml format written by Emby via the web client. I identified that they weren't being read while trying to get all the existing metadata to load. I hadn't realized that the data wasn't being read until the blog post highlighting the new display of taglines.

Share this post


Link to post
Share on other sites
ebr

Confirm your other program is writing them the exact same way we are.

Share this post


Link to post
Share on other sites
Pais

Emby writes in this format:

  <Taglines>
    <Tagline>Test.</Tagline>
  </Taglines>

Here's a sample from one of my movie.xml files that's not read:

  <Taglines>
    <Tagline>A simple man. A difficult choice.</Tagline>
  </Taglines>

Share this post


Link to post
Share on other sites
Luke

it is probably just a timing issue between making the change and then refreshing. try just editing your file, and then doing nothing in Emby and letting it discover the change on it's own through the normal library scan.

Share this post


Link to post
Share on other sites
PeteMB

I can confirm having the same problem. Emby is not reading the tagline from my movie.xml files, even worst Ebmy is removing them.

  • Like 1

Share this post


Link to post
Share on other sites
Luke

Tested with all metadata settings in the server dashboard set to default. No problem found.

Share this post


Link to post
Share on other sites
Pais

Tested with all metadata settings in the server dashboard set to default. No problem found.

 

Aren't the default settings now nfo instead of xml files? As a reminder the whole purpose of this thread is that there is an issue with xml files.

Share this post


Link to post
Share on other sites
MndWrp

Same issue here... taglines i added are removed by a library scan... i use xml as well.

  • Like 1

Share this post


Link to post
Share on other sites
Pais

Any chance of getting another look at these issues given the attention taglines have been given in the new Emby Theater? A summary of the issues follows:

  • Emby deletes Tagline added in the web interface and saved to XML when performing a Refresh
  • Emby XML reader does not import the Tagline fields when populated by third party metadata programs
  • Like 1

Share this post


Link to post
Share on other sites
Luke

The deleting is by design when doing a refresh. it will get replaced by internet metadata. there is currently no way to lock the tagline field.

Share this post


Link to post
Share on other sites
MndWrp

sorry to revive an old post but maybe deleting them by design isn't such a good idea ? I mean, fine get them initially from metadata sources, like the rest, but i'd love to be able to edit them, lock and save if the line is too long or simply missing...

Share this post


Link to post
Share on other sites
Luke

It has to be that way, say for example something gets misidentified so you change the tmdb id and then refresh. you don't want data from the previous movie left in there. It's just like any other data. We don't currently have a tagline lock but it's a reasonable suggestion.

 

Anyway to answer the original question of this thread: yes, taglines are read from movie.xml.

Share this post


Link to post
Share on other sites
Happy2Play

Anyway to answer the original question of this thread: yes, taglines are read from movie.xml.

Only movie.xml created by Emby.

Share this post


Link to post
Share on other sites
MndWrp

My problem is that once the movie is identified correctly and the tagline is missing, i find one i like and add it manually and it goes away at the next refresh.

 

So locking this field as well is a very good idea just for this...

Share this post


Link to post
Share on other sites
Luke

Only movie.xml created by Emby.

 

That is not true, they are supported in nfo too.

Share this post


Link to post
Share on other sites
Happy2Play

That is not true, they are supported in nfo too.

 

In keeping with topic Emby will not read Taglines in movie.xml created by MCM.  If no xml is provided to Emby and the server fetches the metadata then the tagline in the movie.xml created by Emby is read properly.

Share this post


Link to post
Share on other sites
Luke

Ah ok, sorry. My mistake.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...