Jump to content

Transcoding results in poor Audio quality


cirkator
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

cirkator

Hi, let me start by how much i like Emby and Emby for Kodi. Although not perfect yet, it makes syncing content on multiple platforms so easy! Thank you for your dedication!

 

Now to my problem. Every video file i play in Kodi via the Emby for Kodi plugin, the sound quality is very poor. By poor I mean it sounds "metalic" as when playing a mp3 with a very low bitrate.

My Emby for Kodi settings are "Play from http instead of SMB" [enabled] and "Video Quality" [2.0Mbps] (I tried changing the quality to a higher value, but it didnt change my problem)

 

What seems to happen is that while transcoding the audio bitrate is lowered significantly resulting in my described poor audio quality.

When I am playing the video locally in Kodi via the Emby for Kodi plugin its sounds great.

 

The Emby mediainfo for the file in question shows a bitrate of 375 kbps while the audio stream in Kodi only shows 130 kbps. (See screenshots attached)

 

When I am playing the same videofile over the WebApp it sounds good. I guess that is because it shows me 384 kbps for the audio (See screenshot) On a sidenote, I dont get how a file has 375kbps and then when i play it on the WebApp it suddenly has 384 kbps...

 

I also have attached a screenshot of the mouse-over menu in the Serversettings while I am playing the file via the WebApp

 

 

I am running Win7 with Kodi 15.0 and Emby for Kodi Stable Repo 1.1.13 and Emby Server Version 3.0.5675.1.

I have attached a kodi.log and a screenshot of my audiosettings in Kodi.

 

 

Any help in fixing that would be highly appreciated.

post-49038-0-68217800-1439454694_thumb.jpg

kodi.log

post-49038-0-05922400-1439454696_thumb.jpg

post-49038-0-33368300-1439454696_thumb.jpg

post-49038-0-56992700-1439454696_thumb.jpg

post-49038-0-84185800-1439454798_thumb.png

Link to comment
Share on other sites

Angelblue05

And if you change from wasapi output to direct sound?

Honestly never looked at the transcoding options. We convert the audio stream to aac or ac3.

 

Sent from my iPhone using Tapatalk

Edited by Angelblue05
Link to comment
Share on other sites

cirkator

I forgot to mention that I am using a Laptop with its built in speakers.

 

These are the available options I can choose from (see screenshot)

I tried all four options, even restarted Kodi after each change, but the problem still persists. Always 130 kbps and it sounds thin and metalic.

post-49038-0-94383300-1439464763_thumb.jpg

Link to comment
Share on other sites

Cirkator01

No, I do not. Since I am just using my laptop speakers and no HDMI to AVR there isn't even the option to enable passthrough.

Link to comment
Share on other sites

Angelblue05

Can you tell me if you see this is happening with all content? I do not have this problem when transcoding.

 

Can you leave your speakers on direct sound? start playback, on the video osd, you'll see a speaking icon or similar. Make sure passthrough is not enabled. I believe the setting is right where you can select the audio and subtitle tracks.

 

When transcoding, there's no choice of the codec used currently. Audio tracks are converted to aac I believe.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

cirkator

So i have tried a variety of movies and tv shows, with 2.0 and 5.1 audio tracks. Different formats, .avi, .mkv. But all the files played in Kodi have the weird metalic sound. You can listen to it, but it just sounds wrong.

I have and had passtrough disabled in Kodi.

 

I then tried to play all the movies and tv shows via the webapp and they sound as they are supposed to.

 

I have found something interesting. Maybe it is supposed to be this way, i dont know.

Look at the first line in the two pics. One shows 127kb/s and the other one 9kb/s. They stay at this value.

But the second line, which i think shows the current audiobitrate is in both pics around 130kb/s.

 

Do you want a log of me playing the different files in Kodi?

 

EDIT: Just to verify that i am not imaging the bad sound, i listened to Kodi and the webapp with headphones, and with headphones the bad sound is even more noticable in Kodi...

post-49038-0-71248000-1439664168_thumb.jpg

post-49038-0-83589400-1439664178_thumb.jpg

Edited by cirkator
Link to comment
Share on other sites

cirkator

I found something interesting. I have tested some more and i am quite confident in saying that the problem seems related to the number of audio channels.

Stereo sounds good and normal. 5.1 sounds thin and metalic.

 

I found 3 tv shows (sure that i could find more) that had one season in 2.0 and the other season in 5.1

Every episode with 5.1 sounded wrong, every one with Stereo sounded right.

 

In the meantime i completely uninstalled Kodi and deleted the Roaming folder.

Reinstalled Kodi 15.1 and tried both the stable and beta repo. That changed nothing, unfortunately.

 

I sent you (AngelBlue05) a PM with the logs and a link to a short YouTube video were you can listen to the difference.

The logs are transcoding logs with debugging enabled and Kodi logs with debugging and Emby for Kodi debugging setting enabled.

Pictures of the mediainfo of the files are included aswell.

 

I hope you can find something in these logs :)

 

Edit: I have uninstalled the Audio Driver and reinstalled a earlier one. But that didnt help and i have changed the audio settings according to this chart: http://kodi.wiki/view/Audio_quickstart_guide

I used the PC Speaker 2.0 setup. But again, changing the settings to e.g. resample quality "high" doesnt change anything with my problem.

Edited by cirkator
  • Like 1
Link to comment
Share on other sites

cirkator

AngelBlue05 in his infinite wisdom changed the transcoding audio codec from aac to ac3 which completely resolved the issue for me.

Finally I can enjoy Emby and Kodi to the fullest.

 

 

Thank you for the quick fix and the friendly and helpful replies AngelBlue!

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...