Jump to content

Video Pauses, Then Silently Fastforwards


Kolmain
 Share

Recommended Posts

I swapped to using Emby + Kodi, and now all of my video playback continuously freezes (without actually pausing) and then fast forwards up to where its supposed to be silently, and continues for a minute before it doesn't again. I found this in the logs:

18:02:02 T:3300  NOTICE: -->Python Interpreter Initialized<--
18:02:02 T:3300  NOTICE: Artwork Downloader: ######## Artwork Downloader: Initializing...............................
18:02:02 T:3300  NOTICE: Artwork Downloader: ## Add-on Name = Artwork Downloader
18:02:02 T:3300  NOTICE: Artwork Downloader: ## Version     = 12.0.29
18:02:10 T:3640  NOTICE: EMBY WebSocketThread -> sendProgressUpdate
18:02:21 T:3300  NOTICE: Previous line repeats 2 times.
18:02:21 T:3300  NOTICE: Artwork Downloader: script stopped
18:02:22 T:3640  NOTICE: EMBY WebSocketThread -> sendProgressUpdate
18:02:26 T:9120 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
18:02:26 T:3640  NOTICE: EMBY WebSocketThread -> sendProgressUpdate
18:02:26 T:8384 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
18:02:30 T:3640  NOTICE: EMBY WebSocketThread -> sendProgressUpdate
18:02:35 T:9120  NOTICE: Previous line repeats 1 times.
18:02:35 T:9120  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 32
18:02:35 T:9120  NOTICE: Previous line repeats 249 times.
18:02:35 T:9120 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
18:02:36 T:9120  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 32
18:02:36 T:9120  NOTICE: Previous line repeats 7 times.
18:02:36 T:9120 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
18:02:36 T:9120  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 32
18:02:36 T:9120  NOTICE: Previous line repeats 7 times.
18:02:36 T:9120 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
18:02:36 T:9120  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 32
18:02:36 T:9120  NOTICE: Previous line repeats 7 times.
18:02:36 T:9120 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
18:02:36 T:9120  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 32
18:02:36 T:9120  NOTICE: Previous line repeats 7 times.
18:02:36 T:9120 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
18:02:36 T:9120  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 32
18:02:36 T:9120  NOTICE: Previous line repeats 7 times.
18:02:36 T:9120 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
18:02:36 T:9120  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 32
18:02:36 T:9120  NOTICE: Previous line repeats 7 times.
18:02:36 T:9120 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
18:02:36 T:9120  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 32
18:02:36 T:9120  NOTICE: Previous line repeats 1 times.
18:02:36 T:9120 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
18:02:38 T:3640  NOTICE: EMBY WebSocketThread -> sendProgressUpdate
18:02:46 T:8384  NOTICE: Previous line repeats 2 times.
18:02:46 T:8384 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
18:02:46 T:9120 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
18:02:50 T:3640  NOTICE: EMBY WebSocketThread -> sendProgressUpdate

Link to comment
Share on other sites

Please post the full log.

 

Looks to me like you are not direct playing from this small snip.

 

(see how to report a problem thread)

Edited by xnappo
Link to comment
Share on other sites

Please post the full log.

 

Looks to me like you are not direct playing from this small snip.

 

(see how to report a problem thread)

  

Sorry, I'm trying to now but my browser just keeps crashing out because the log is too big. Here's a gdrive link: https://drive.google.com/file/d/0B9xyWSCaRGt3UXVfX1RRdk4tQmc/view?usp=sharing

 

The subtitles continue on the screen even though the video is frozen...

Link to comment
Share on other sites

I should also include that I tried it with network username/password set, then removed it and tried it with the sources added in Kodi with credentials. I always had direct play enabled in addon settings.

Link to comment
Share on other sites

Sorry - but that log file is huge.  Can you please set the log level to 'Info' instead of 'Debug' and repost?

Link to comment
Share on other sites

Sure, I'm uploading it now although it was already set to 'Info'. I've tried with/without credentials and with/without "use local paths instead of addon redirect for playback". Still have the same issue, if I play the file back via bypassing Emby, theres no issue. 

 

Log incoming: https://drive.google.com/open?id=0B9xyWSCaRGt3emMxa0c2RjJpZ1E

Edited by Kolmain
Link to comment
Share on other sites

This is all I see that indicates what is happening:

19:37:13 T:9776 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
19:37:13 T:6340 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
Link to comment
Share on other sites

I don't know what is going on, but it is freaking out trying to add things to the library(it shouldn't be doing that, it should only have a handful of changes after the first sync).  There should not be all that traffic going on.  I would reset your DB and try again.

Edited by xnappo
Link to comment
Share on other sites

I don't know what is going on, but it is freaking out trying to add things to the library(it shouldn't be doing that, it should only have a handful of changes after the first sync).  There should not be all that traffic going on.  I would reset your DB and try again.I'

I've done that 3 times now :(

Link to comment
Share on other sites

Okay, well something it going wrong.  Please turn off all logging (set to none) reset the db and post the log after that is finished.  Then exit Kodi, retenter and play a file and post that log.

 

I can't see anything from your current logs as it is going nuts with updates that don't make sense..  We shouldn't bee seeing all this stuff after the initial sync..

19:37:21 T:9144  NOTICE: UPDATE episode to Kodi library -> Id: 8624511808a45f941a8715b023fd1769 - Title: Mors Praematura
19:37:21 T:9144  NOTICE: UPDATE episode to Kodi library -> Id: 052aff1a8e407348972a176f1ea81b19 - Title: Mission Creep
19:37:21 T:9144  NOTICE: UPDATE episode to Kodi library -> Id: be01c21cb824855ba15e3e0432eb8104 - Title: Death Benefit
19:37:21 T:9144  NOTICE: UPDATE episode to Kodi library -> Id: dd5f7520fbcb936b8cf2bad62d58e257 - Title: The Contingency
19:37:21 T:9144  NOTICE: UPDATE episode to Kodi library -> Id: 2796ca2291f6911a19e0ad5ff644d172 - Title: Bury the Lede
19:37:21 T:9144  NOTICE: UPDATE episode to Kodi library -> Id: f123292ed8e8fcd7b6606a13721f6b13 - Title: Proteus
19:37:21 T:9144  NOTICE: UPDATE episode to Kodi library -> Id: 258bb12e8304c6e1aa1c03b8952e5c58 - Title: Flesh and Blood
19:37:21 T:9144  NOTICE: UPDATE episode to Kodi library -> Id: a1d72b31eb08973d32cb89ea8982479d - Title: Super
19:37:21 T:9144  NOTICE: UPDATE episode to Kodi library -> Id: ae56a736389e3fafc0e29cc1708eb39b - Title: The High Road

Thanks!

xnappo

Edited by xnappo
Link to comment
Share on other sites

Angelblue05

@@Kolmain I don't believe it's a problem from our side. See this thread - I know it's centered mostly around FireTV, but there's also report of it happening on non Android devices: http://forum.kodi.tv/showthread.php?tid=225898&page=2

 

The same thing happens to me with my firetv stick over SMB while nothing is happening with the add-on and I'm on RC2. Using Helix, no issues.

03:07:46 T:1512272336  NOTICE: EMBY WebSocketThread -> sendProgressUpdate
03:08:21 T:1530138008  NOTICE: Previous line repeats 8 times.
03:08:21 T:1530138008  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 10
03:08:22 T:1512272336  NOTICE: Previous line repeats 9 times.
03:08:22 T:1512272336  NOTICE: EMBY WebSocketThread -> sendProgressUpdate
03:08:32 T:1530138008  NOTICE: Previous line repeats 2 times.
03:08:32 T:1530138008  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 10
03:08:34 T:1512272336  NOTICE: Previous line repeats 15 times.
03:08:34 T:1512272336  NOTICE: EMBY WebSocketThread -> sendProgressUpdate
03:08:44 T:1530138008  NOTICE: Previous line repeats 2 times.
03:08:44 T:1530138008  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 10
03:08:46 T:1512272336  NOTICE: Previous line repeats 15 times.
03:08:46 T:1512272336  NOTICE: EMBY WebSocketThread -> sendProgressUpdate
03:08:47 T:1530138008  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 10
03:08:50 T:1512272336  NOTICE: Previous line repeats 17 times.
Edited by Angelblue05
Link to comment
Share on other sites

 

@@Kolmain I don't believe it's a problem from our side. See this thread - I know it's centered mostly around FireTV, but there's also report of it happening on non Android devices: http://forum.kodi.tv/showthread.php?tid=225898&page=2

 

The same thing happens to me with my firetv stick over SMB while nothing is happening with the add-on and I'm on RC2. Using Helix, no issues.

03:07:46 T:1512272336  NOTICE: EMBY WebSocketThread -> sendProgressUpdate
03:08:21 T:1530138008  NOTICE: Previous line repeats 8 times.
03:08:21 T:1530138008  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 10
03:08:22 T:1512272336  NOTICE: Previous line repeats 9 times.
03:08:22 T:1512272336  NOTICE: EMBY WebSocketThread -> sendProgressUpdate
03:08:32 T:1530138008  NOTICE: Previous line repeats 2 times.
03:08:32 T:1530138008  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 10
03:08:34 T:1512272336  NOTICE: Previous line repeats 15 times.
03:08:34 T:1512272336  NOTICE: EMBY WebSocketThread -> sendProgressUpdate
03:08:44 T:1530138008  NOTICE: Previous line repeats 2 times.
03:08:44 T:1530138008  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 10
03:08:46 T:1512272336  NOTICE: Previous line repeats 15 times.
03:08:46 T:1512272336  NOTICE: EMBY WebSocketThread -> sendProgressUpdate
03:08:47 T:1530138008  NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 10
03:08:50 T:1512272336  NOTICE: Previous line repeats 17 times.

Interesting, are you implying that its an Isengard issue?

Link to comment
Share on other sites

Angelblue05

I believe it is. There is no reason for skipping packets when Kodi is reading the file directly. You are using direct paths, which is essentially letting Kodi control the playback. The add-on and Emby server are not at all involved in the process. All the add-on is doing during playback is reporting the progress position back to the server. I use both Helix and Isengard and only see this issue with Isengard and we don't seem to be the only ones experiencing this.

 

You can try using Helix 14.2 and seeing if the problem persists or not. (the database are different, so you will need to complete a full resync of your database). Let us know if you try it out and it resolves the issue.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...