Jump to content

8.0.67.1 won't connect to HTTPS


icthusman1
 Share

Recommended Posts

icthusman1

The new client will not connect to my server via HTTPS. I am able to use a web browser (on an external network) and connect via HTTPS. The only way I was able to get the WP client to connect was to turn off the server setting "Report HTTPS as external address" so that it went back to using the HTTP port.

 

The connection info that the WP client showed me was correct, it was the right hostname and port.

 

Please help Scott!

  • Like 1
Link to comment
Share on other sites

ScottIsAFool

How are you connecting to the sever? Are you manually putting in your address? Using Emby Connect?

Link to comment
Share on other sites

icthusman1

How are you connecting to the sever? Are you manually putting in your address? Using Emby Connect?

Emby connect. Connection details shown through Emby Connect are all correct.

Link to comment
Share on other sites

icthusman1

Emby connect. Connection details shown through Emby Connect are all correct.

I also just tried entering them in manually and it still does not work. Just a though, could it be due to the certificate not being trusted? In the browser I need to "continue to site anyways" but I can't do that in the app. Could this by why?

Link to comment
Share on other sites

I also just tried entering them in manually and it still does not work. Just a though, could it be due to the certificate not being trusted? In the browser I need to "continue to site anyways" but I can't do that in the app. Could this by why?

 

yes i'm almost positive

Link to comment
Share on other sites

icthusman1

yes i'm almost positive

Do you read everything posted to the forums every day? It seems like you are everywhere!

 

If that's the case (the cert issue) is there a workaround? I can't believe I am the only one to have run into this. Since I am using Afraid.Org as my DDNS provider, I don't know that I can get a signed and trusted cert. I would like to use HTTPS but would also like to be able to use the WP and Win8/10 apps.

Link to comment
Share on other sites

The new client will not connect to my server via HTTPS. I am able to use a web browser (on an external network) and connect via HTTPS. The only way I was able to get the WP client to connect was to turn off the server setting "Report HTTPS as external address" so that it went back to using the HTTP port.

 

The connection info that the WP client showed me was correct, it was the right hostname and port.

 

Please help Scott!

I just found this too. When i un-ticked https setting it logged in

Link to comment
Share on other sites

fuzzthekingoftrees

If you know your way around openssl you can build a CA, create a cert that matches your ddns name, and then load the CA cert on your phone, that will get it trusted.

 

Alternatively if you own your own domain name, create a subdomain, CNAME that to your ddns then get a cert for your own domain.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...