Jump to content

Feature Requests and bugs


Recommended Posts

Hi All,


@@Happy2Play the server is not very accurate in determining playback in the dashboard for the app, been that way almost forever.


Congrats on the new abode, 7!! packing and unpacking can be a "daunting" (Please insert an adjective of your choice) task... :)


Everything status quo from a regression standpoint.

Live TV doesn't work. A lot of anomalies crept in the dev. server so is difficult to discern what changed.


C:\Users\XXXXX\AppData\Roaming\Emby-Server\ffmpeg\20151111\ffmpeg.exe -fflags +genpts -i "http://XXXXXXX:5004/auto/v544" -map_metadata -1 -threads 0 -sn -codec:v:0 libx264 -pix_fmt yuv420p -preset superfast -crf 23 -b:v 39872000 -maxrate 39872000 -bufsize 79744000 -vsync vfr -profile:v high -level 51 -force_key_frames "expr:gte(t,n_forced*3)" -vf "yadif=0:-1:0" -sc_threshold 0 -codec:a:0 ac3 -ab 128000 -af "adelay=1,aresample=async=1" -hls_time 3 -start_number 0 -hls_list_size 0 -hls_base_url "hls/88cd5daeb48e4ff023ed8b6d2ecdef64/" -y "G:\MB-Temp\transcoding-temp\88cd5daeb48e4ff023ed8b6d2ecdef64.m3u8"


In Red;

-crf 23 at best is redundant (default )

bit rates not sure where they come from. The level/profile will pick the appropriate values (constrain them?)

ie [libx264 @ 0000024c656d0520] VBV buffer (78311) > level limit (78125) .... level 4.1 example


The deinterlace seems to be odd.

Shouldn't it be "-vf yadif=0:-1:1,hqdn3d' ?

I would also guess there is some scale info required ?


The audio well... It is decoding AC3 to AC3

Taking  Stream #0:2[0xec9]: Audio: ac3, 48000 Hz, 5.1(side), fltp, 384 kb/s

to  Stream #0:1: Audio: ac3, 48000 Hz, 5.1(side), fltp, 128 kb/s


AC3 streams are 194k for stereo and 384k for 5.1 so not quite sure where the 128 comes from.


Anyway just my observations




Edit: Should note using Max quality in the app, max setting in the server. app and server connected by iGig Ethernet. Intel quicksync setting enabled. ( somewhere along the way we lost qsv decode of the mpeg2video stream (mpeg2_qsv) worked just fine but went away. The h264_qsv encode was put in but the use case, unless you are dumbing down quality escapes me. 

Edited by Vicpa
Link to comment
Share on other sites

Thanks. I removed my own logic for streamcopy and started relying on the server to determine this. Apparently the server is still not on par with what I used to do. I will reimplement my logic for this.

Link to comment
Share on other sites

Hi 7,


Can you do a quick and dirty direct stream option for live tv for testing purposes? maybe throw an enable/disable in the profile or something?


The reason I ask is I believe the MS folks in 11082 have restored access to mpeg2. It may be like having media center in win 8, you may need the ms "DVD player" but who cares. (It is their in docs)


The use case is for the HDHomerun  Prime. mpeg2video  AC3;


It would get you out from guessing the server "logic" and put me out of the transcoding nightmare.


The homerun dlna stream plays just fine in MS "Movies & TV" as of 11082 :)




Link to comment
Share on other sites

  • 1 month later...

hi 7

Haven't whined about anything for a while. I think I am due. :)


A couple of things.


1) Gotta get the art on the music genre page, been on the list a long time.

2) With the server now supporting multiple artists better, on the screen saver can you account/allow whatever the slash? I think that is the separator that is being displayed. It appears that artists are being truncated at the slash and only the first is being displayed. You see you spoiled us...

3) Don't know if it is possible and probably not a huge use case. On the album detail page when you select multiple items , to add to playlist etc. You can't get to the bottom of the scroll list the command bar pops up (as it should) but then you can select those items. Can the scroll list be shortened when the bar pops up? See screen shot.

(well can seem to post one) will try again.


Couple of I don't knows...... Stop on the remote seems to be more "complete" than a mouse click. If I hit stop on the remote and return to the main hub. The now playing display is gone. (expected behavior). If I use the mouse, off times the Now playing display is there with the content shown that was stopped, can't start it again, you stopped it. Kinda wonky.


an fyi the latest server builds take a long time to display content the first time. Long loading time and sometimes just TV shows up no movies. close and re open and everything is there instantly. Definitely a server thing cause up until the last beta round was fine. Perhaps it is a new "feature".



Edited by Vicpa
Link to comment
Share on other sites

second try on the screen shot





at last. For clarification there is no way to get to Georgia on My Mind for example

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...