Jump to content
manicjonah

Change Emby Server Local Address

Recommended Posts

manicjonah

I'm interested in changing the Local Address used to access my Emby installation from the HTPC's IP address to "localhost" or the computer's name.  I don't see anywhere in the Emby Server settings that I can do this.  Am I missing it?  If not can this be done via a registry edit or the modification of an .ini file, etc.?

 

Current Local Address:  http://192.168.1.115:8096

Proposed Local Address:  http://localhost:8096  or http://htpc:8096

 

How do I do it?

 

Thanks,

 

MJ

Share this post


Link to post
Share on other sites
Happy2Play

What do you mean?  Those are all the same.  Are you wanting to change what appears on the dashboard in local access?

Share this post


Link to post
Share on other sites
ebr

Yeah, that is just a display.  When it comes to entering an address in a client app, you can use any method that will resolve correctly (IP, hostname, dynamic dns...).

Share this post


Link to post
Share on other sites
manicjonah

Ah but my problem is with the Emby server config, not a client app.   Emby refers to itself by IP address (this can be seen on the Dashboard) and this is what I want to change.  

  • On Emby's Dashboard the Local Address link is http://192.168.1.115:8096.  I attempted to launch the web interface from my HTPC at http://192.168.1.115:8096 and the page didn't launch.  
  • MediaBrowser Classic Configurator is set to automatically detect the Emby server but it can't.  I suspect this is because Emby server only knows that it is at 192.168.1.115.
  • Also when we fire up WMC we received an alert that Mediabrowser Server could not be contacted.  I restarted the service, no change.  I stopped the service and started the app, no change.  I rebooted the computer, no change.  I then launched Emby Theater on the Emby server (my HTPC) but it couldn't find the Mediabrowser server either.  Of course this is because MediaBrowser Classic can't find the Emby server.

BUT I can access the Emby Dashboard using http://localhost:8096.  Why?

 

Because my HTPC's IP address changed.  I realize that I can simply set a static IP address for the server which solves my problem BUT I'm looking to learn a little something about Emby here.  The IP address change on my computer is temporary, a result of having to disconnect the network cable and Windows assigning network responsibilities to another LAN connection that isn't properly configured (I'll elaborate if you're interested.)  My HTPC shouldn't need to be connected to the network for me to watch it locally on the TV that I have connected to it.

 

I realize that simply assigning 192.168.1.115 to the LAN connection that is being used solves my problem but a better solution to the problem is for Emby to recognize itself as "localhost" instead of by its IP address.  

I'm also aware that specifying an address for the Emby server in MediaBrowser Classic Configurator solves my problem.

 

BUT I'm more interested in learning how to change Emby's configuration so that it doesn't look for itself on 192.168.1.115 but instead looks for itself on "localhost".  

 

Can it be done?  If so, how?

 

Thanks,

 

MJ

Share this post


Link to post
Share on other sites
Luke

localhost can be used just fine. the address you see on the server dashboard is only what it reports to clients as it's internal network address. you can manually connect from a client using localhost though

Share this post


Link to post
Share on other sites
ebr

And, if you are going to allow your server's IP address to change (although, I really recommend a static one for a server - especially if you want to configure external access) then just configure EMC to find the server automatically instead of connecting to a specific address.

Share this post


Link to post
Share on other sites
Swynol

I added an entry into the host file on the PC's that access my server. For example

 

The entry looks like

 

192.168.1.100 http://Emby:8096

 

So when I type Emby:8096 Resolves to the Ip

Share this post


Link to post
Share on other sites
CBers

Just make sure the PC running Emby server has a static address, otherwise you'll be forever changing the hosts file on the other PCs.

  • Like 1

Share this post


Link to post
Share on other sites
Koleckai Silvestri

I just access it via the machine name. http://machinename:8096

 

Then I don't need to care about the IP Address. Even machines physically outside my network can access it via VPN.

Edited by Koleckai Silvestri

Share this post


Link to post
Share on other sites
Blueeyiz702

I use a proxy server thru torguard,and it doesnt show my plugins? so how would i fix this show it shows them?

Share this post


Link to post
Share on other sites
DannyN

My situation is somewhat similar. I use Hamachi for a VPN and Emby has used that address, rather than the local 192.168.x.x  I'd rather use the local static IP. How do I change that in the settings? I think it's also causing Live TV recording to fail.

 

Danny

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...