Jump to content


Photo

Flac music missing

Flac

  • Please log in to reply
5 replies to this topic

#1 marc_al OFFLINE  

marc_al

    Advanced Member

  • Members
  • 50 posts
  • Local time: 10:24 PM

Posted 07 June 2015 - 01:52 PM

Hello,

 

I have created a Audio library (and also an undefined one) but when I select a directory with Flac only, there is no music (neither web player neither DLNA). The library is empty.

My music is put like that :

 

Directory with the Interpret name

      Directory with Album name

           Songs

 

Or sometimes

 

Directory with album nake

    Songs

 

Am i doing someting wrong?

 

Thank you

Marc



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146793 posts
  • Local time: 04:24 PM

Posted 07 June 2015 - 02:13 PM

did you specify Music as the library type? Can you show screenshots of the folders? thanks.



#3 ginjaninja OFFLINE  

ginjaninja

    Advanced Member

  • Members
  • 1654 posts
  • Local time: 09:24 PM
  • Locationuk

Posted 07 June 2015 - 02:19 PM

do make sure your flac files are tagged, emby's music appreciation is intended to come from the tags in the first instance....mp3tag is a good utility to check and correct tags. If your tags are blank there are quick ways to resolve either using mp3tag's scripting language {to convert path to tag} or use Musicbrainz Picard to detect albums and tag from musicbrainz {useful as emby uses musicbrainz in its matching and fetching functions}



#4 marc_al OFFLINE  

marc_al

    Advanced Member

  • Members
  • 50 posts
  • Local time: 10:24 PM

Posted 07 June 2015 - 11:20 PM

Hello,

 

I have tried with the type "Music" and as it didn't work I created a second livrary with the same files and the type "Undefined" so I have 2 libraries at the moment.

I will do a test and report back (tomorrow as I have to leave now.).

 

Marc



#5 marc_al OFFLINE  

marc_al

    Advanced Member

  • Members
  • 50 posts
  • Local time: 10:24 PM

Posted 08 June 2015 - 02:12 PM

Hello,

 

The tags were correct, but I have seen a M3U file in the root of the music directory.

EDIT : NOT the case (see bottom) As soon as I have removed it and recreated the Music folder (as Undefined) all the files have appeared.

I have also seen that If I keep the music type (FLAC, MP3...) and after that the Singer then Album then music, all the files are grouped in the Music type (FLAC) I am still lookinbg for the problem.

 

EDIT : All the music files are merged into the main sub directory so I can only see one directory and all the songs are inside the directory.

For some directories, I can see the songs and can play them, for other there is no song (but by DLNA there are songs). Is there something I am missing?

 

Thank you

Marc


Edited by marc_al, 09 June 2015 - 12:48 AM.


#6 marc_al OFFLINE  

marc_al

    Advanced Member

  • Members
  • 50 posts
  • Local time: 10:24 PM

Posted 11 June 2015 - 12:09 AM

Hello,

 

I have seen the problem. The first directory MUST be the Singer. (it is compared to the MP3 tag). If there is a difference, the song won't appear. By DLNA there is no such limitation.

 

Marc


  • vindevil likes this





Also tagged with one or more of these keywords: Flac

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users