Jump to content

[Feature Request] - Ability to set maximum bitrate


johnodon
 Share

Go to solution Solved by johnodon,

Recommended Posts

As with all other Emby Apps, the user has the ability to set a maximum bitrate for streaming.  Can this be accomplished with the Kodi plugin?

 

Case in point:  I have a FireTV Stick with OE sideloaded.  It works great playing lossless bdrip MKVs when plugged into the TV in my family room which is just feet away from my wireless router.  If I move the Stick to any other TV in the house (farther from the router), I get constant buffering when playing the same rips.  If I could throttle the bitrate just a bit, I would be set.

 

Thoughts?

 

John

Link to comment
Share on other sites

But, is Kodi actually streaming here?

 

If it is direct playing, there isn't going to be any way to limit the bitrate.

Link to comment
Share on other sites

In Kodi or the Emby Plugin?  I checked the latter and did not see anything.

 

I'll poke around Kodi itself and see if I can find a way to limit bitrate.

Link to comment
Share on other sites

No i mean in the Emby settings, I'm not at home at the moment but I thought we had an option to set the bit rate in the addon settings. This was at least how it worked in the previous addon. So if you were using it remotely for example you could set the bit rate to a capacity your network can cope with and it would transcode automatically

Link to comment
Share on other sites

No i mean in the Emby settings, I'm not at home at the moment but I thought we had an option to set the bit rate in the addon settings. This was at least how it worked in the previous addon. So if you were using it remotely for example you could set the bit rate to a capacity your network can cope with and it would transcode automatically

 

BINGO!

 

Play from HTTP rather that SMB.  Once selected, you can choose a bitrate.

 

I'll start playing around!  :)

 

Thanks im!

  • Like 1
Link to comment
Share on other sites

That did the trick!  I only tested from my desktop but I selected the play from HTTP option and set the bitrate @ 9.2mbits (or something).  I then played Avatar which I have seen peak @ close to 35mbit.  It did not go above the setting that I chose.  :)

 

Now I just need to test on the FireTV Stick and see if that causes it to choke for whatever reason (transcoding?).

 

John

Link to comment
Share on other sites

Cool, glad you got it sorted..it's a pretty amazing addon :)

Link to comment
Share on other sites

OK...I think I either found a bug...or...this plugin works better than I thought.   :)

 

I have 4 different scenarios:

 

1.  If I leave "play from http instead of smb" unchecked, Avatar BDRIP runs at fill bitrate and there is no transcoding (as expected) which is evidenced by the lack of any transcoding logs on the server.

2.  If I check "play from http instead of smb" and leave the default bitrate @ 100mbits, there is no transcoding (as expected) which is evidenced by the lack of any transcoding logs on the server.

3.  If I check "play from http instead of smb" and set the bitrate @ 12.2mbits, transcoding occurs (as expected) which is evidenced by the existence of transcoding logs on the server (attached as 2 files named  "http-12.2-transcodingxxxxx.txt)

4.  If I then leave the bitrate @ 12.2mbits and uncheck "play from http instead of smb", transcoding occurs (I would not expect this since I should now be back in Direct Play mode) which is evidenced by the existence of transcoding logs on the server (attached as 2 files named  "non-http-12.2-transcodingxxxxx.txt)

 

Point #4 abobe is the one that is confusing me.

 

Do the bitrate options that are available when "play from http instead of smb" is checked still apply even if that option is not checked?  (the bitrate options disappear when "play from http instead of smb" is unchecked)

 

Or maybe the plugin is not reverting to Direct Play if that bitrate option is set to anything lower than the bitrate of the source even when "play from http instead of smb" is unchecked?

 

John

http-12.2 - transcode-b995b639-9187-4970-b0fa-a7ee12467ef3.txt

http-12.2 - transcode-fd9d7a1c-6a16-4cc2-a2d5-28da0570d9c5.txt

non-http-12.2 - transcode-119851d0-86ac-41b1-a4d4-55afe5cb86a7.txt

non-http-12.2 - transcode-c4dda9e9-479b-4ecd-9b91-f42b5c0d9495.txt

Link to comment
Share on other sites

Yeah that sounds like a bug to me, I'm not sure it's been tested that thoroughly before so good spot. Either myself or one of the other kodi addon devs will take a look into it. Thanks for reporting back.

Link to comment
Share on other sites

@@xnappo - file is attached.

This is with bitrate set at 12.2mbit and "use http instead of smb" unchecked.  Again, I confirmed that the movie was running at the lower bitrate by pressing O.

 

John

kodi.log

Edited by johnodon
Link to comment
Share on other sites

Angelblue05

The bitrate does not apply if the play from http is not enabled. It will direct play your content.

 

I've checked your log and couldn't find any content not direct playing, are you sure this is the correct log? I will test on my side and let you know.

 

@@xnappo there's an error in the log related to delete items, I believe.

 

 

Sent from my iPhone using Tapatalk

Edited by Angelblue05
Link to comment
Share on other sites

The bitrate does not apply if the play from http is not enabled. It will direct play your content.

 

 

 

That is exactly what I would have expected to happen but it is not doing that.

Link to comment
Share on other sites

Angelblue05

@@xnappo fudge. I was looking at another log and I guess on my phone it didn't load the correct one. Because now that I'm checking the log again, it's not there. :(

 

My bad. @@johnodon your log is showing transcoding path indeed. I'll have a look, thanks :)

Link to comment
Share on other sites

Angelblue05

@@johnodon

 

I've just tested myself.

I had Play from HTTP enabled and set the bitrate to the lowest possible. It was transcoding on my server.

I then disabled Play from HTTP and left the bitrate to the lowest possible. It was direct playing on my server.

 

Can you confirm that Play from http is indeed disabled? I can't seem to reproduce the issue. Anyone else?

Link to comment
Share on other sites

Just want to add this:  The machine I experienced this on was Kodi v15 B1.  I'm not sure if that could be a factor.

 

I am going to install Helix on my laptop now and see if I can duplicate the issue.

 

Stay tuned...

Link to comment
Share on other sites

Confirmed on a fresh install of Helix 14.2 + Emby Plugin 1.0.0:

 

What I did...

 

Enabled HTTP playback.

Set bitrate to 12.2mbit

Disabled HTTP playback

 

LCAORK8.png

 

I then played Avatar and screencapped the bitrate.  With direct play the Mbit of this scene will fluxuate around 30Mbit.

 

aMpLYHl.png

Edited by johnodon
Link to comment
Share on other sites

Angelblue05

Ok can you also confirm in your Emby dashboard it's also transcoding (when you mouseover it says transcoding correct?)

NVM, saw your other post.

Edited by Angelblue05
Link to comment
Share on other sites

Ok can you also confirm in your Emby dashboard it's also transcoding (when you mouseover it says transcoding correct?)

NVM, saw your other post.

 

Never knew this feature existed so I did it anyway.  :)

 

D5DZWnP.png

  • Like 1
Link to comment
Share on other sites

Angelblue05

@@johnodon

 

Please install the custom version I've attached to my post. So in settings > add-ons > install from zip, restart Kodi and do the same thing again? Just post your Kodi log, I've added extra logging to see why Direct play is failing, since I can't reproduce.

Edited by Angelblue05
Link to comment
Share on other sites

Angelblue05

You don't have to, just install over. It will replace the old one leaving your device Id intact.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...