Jump to content
xnappo

Emby for Kodi

Recommended Posts

RavRob

Well I downloaded the beta server from the main download page Emby.media but the wizzard won't work.  When I get the wizzard started, the wheel at the bottom keeps on turning and never gives me a choice of language.  I can'e even get past the wizzard on this one and the other one (non beta) was always freezing.

 

Not sure what to do from here.

Share this post


Link to post
Share on other sites
im85288

You should start by creating a thread in the server support section, someone will assist you with the Emby server issues your experiencing. Once your servers running and you have your media setup then it's time to install Emby for Kodi.

Share this post


Link to post
Share on other sites
RavRob

Where do I get the Beta repo?

Kodi keeps freezing.  Dunno if that is caused by the server or by the plugin.  I'd love to get this working but not sure where to go to fix these issues.

Share this post


Link to post
Share on other sites
Angelblue05

When you say Kodi keeps freezing. What says it is freezing? Are you trying to exit while the sync is still going? If you check your Kodi log, are new lines still appearing? You seem to be experiencing something out of the ordinary.... :(

Edited by Angelblue05

Share this post


Link to post
Share on other sites
CBers

I have Music sync disabled in the addon, but Kodi (Artic Zephyr skin) shows 5000+ songs.

I reset the Kodi database, let Kodi restart, but before the sync starts, it still says 5000+ songs.

Any ideas please ?

 

screen_FTV_7.png

 

kodi log

 

.

Edited by CBers

Share this post


Link to post
Share on other sites
StealthDefender

I have Music sync disabled in the addon, but Kodi (Artic Zephyr skin) shows 5000+ songs.

 

I reset the Kodi database, let Kodi restart, but before the sync starts, it still says 5000+ songs.

 

Any ideas please ?

 

screen_FTV_7.png

 

kodi log

 

.

You lucky one, i get no musuc sync at all!

Share this post


Link to post
Share on other sites
im85288

Wasn't @@CBers stating he turned music sync off but is still getting music? I don't see how this can be related to it being on by default or not.

 

On that note, what do people think the default should be for music? On or Off?

  • Like 1

Share this post


Link to post
Share on other sites
im85288

I have Music sync disabled in the addon, but Kodi (Artic Zephyr skin) shows 5000+ songs.

I reset the Kodi database, let Kodi restart, but before the sync starts, it still says 5000+ songs.

Any ideas please ?

 

screen_FTV_7.png

 

kodi log

 

.

The reset Logic will only clean the music database if you have music sync enabled in the options! So your kind of stuck in a catch 22 position. I would suggest just removing it manually or leave it enabled, do the reset, then disable it.. Edited by im85288
  • Like 1

Share this post


Link to post
Share on other sites
CBers
 

Wasn't @@CBers stating he turned music sync off but is still getting music? I don't see how this can be related to it being on by default or not.

On that note, what do people think the default should be for music? On or Off?

 

Off by default.

 

Most people who have music, would probably have a large collection so on the initial sync it will take forever.

 

At least people can manually sync it if required.

 

The reset Logic will only clean the music database if you have music sync enabled in the options! So your kind of stuck in a catch 22 position. I would suggest just removing it manually or leave it enabled, do the reset, then disable it..

 

Bugger !!

 

Removing what manually ??

 

You can't do the reset and then change an option, as Kodi restarts.

Edited by CBers

Share this post


Link to post
Share on other sites
CBers

@@CBers

First, can you try enabling the "Enable music sync" option (it will disable music from syncing)? Then exit Kodi (even if the sync is going) and then start Kodi again.

See if that works for you. I'm guessing when you said disabled the music sync, you actually enabled the option then disabled it (therefore setting it back to enabled). It should disable music from syncing.

 

I have never enabled the option, so if it is ENABLED by default, then it shouldn't be (see above).

 

If I uninstall the addon, will that "reset" it ??

 

I'll check tonight when I'm home.

Share this post


Link to post
Share on other sites
im85288

I'm not following the confusion over the setting naming.

 

Yes it is enabled by default, this may change.

 

For now you will need to manually delete the music database, it's quite advanced so either Google or wait for a fix in our reset logic. Cheers

Share this post


Link to post
Share on other sites
im85288

Ok then CBers, just enable the option "Enable music sync" and restart Kodi, it will disable music from syncing at all. :) I think what im85288 is referring to is accessing your Emby for Kodi settings file and changingEnable sync music option manually from "true" to "false".

@@Angelblue05 - where are you getting this understanding of the music setting from?

 

As far as I can see it is called "Enable Music Library Sync" and is on by default (which does the sync!), turning it off prevents the sync. I'm very confused at the logic your stating above

  • Like 1

Share this post


Link to post
Share on other sites
scalda

I have never enabled the option, so if it is ENABLED by default, then it shouldn't be (see above).

 

If I uninstall the addon, will that "reset" it ??

 

I'll check tonight when I'm home.

Just go into the userdata/database folder and delete the music database.

 

As for the music sync setting mine says "enable music sync" so I would click it to turn it on.

 

I think it should be off by default and then people can turn it on if they want it before or after the initial sync

  • Like 1

Share this post


Link to post
Share on other sites
CBers

Wasn't Music syncing enabled ON in a recent beta release ??

 

Thanks @@scalda - I will try that later.

Share this post


Link to post
Share on other sites
im85288

Nope :) I don't follow it that way at all. How is the option visually disabled?

Share this post


Link to post
Share on other sites
CBers

@@im85288

 

Very simple, this is the option: 

<setting id="enableMusicSync" type="bool" label="Enable Music Library Sync" default="true" visible="true" enable="true" />

As you can see the option is still called Enable Music Library Sync and default="true". However, visually, the option is "disabled" and when you enable it, it changes the setting to false. So to disable Music sync, you actually have to enable the option "Enable music library sync". I hope this clarifies the confusion. :)

 

That makes no sense whatsoever !!

 

If it's set to TRUE then visually, the option should be ON.

 

I'll let you guys argue it out :D

 

.

Edited by CBers

Share this post


Link to post
Share on other sites
CBers

Just realised I posted about this in the STABLE release thread.

 

I'm running v1.0.06 of the add-on, so please move my posts to the relevant thread.

Share this post


Link to post
Share on other sites
scalda

Heheh, it's ok. Here's a screenshot of default settings. Music is currently ENABLED. To disable Music sync, I'd have to actually Enable "Enable Music Library Sync". I hope this makes sense, but the option should actually be called Disable Music Library Sync, not Enable Music Library Sync because in reality it is already enabled, so when you select the option, you therefore disable Music library sync. hehe :)

 

5579509d3fe7d_screenshot003.png

 

Edit: If it's still not clear, then nevermind...I don't know how else to explain hehe and will fix it myself. :)

 

mine is set like that and i don't get any music sync to all 5 instances of the addon

  • Like 1

Share this post


Link to post
Share on other sites
im85288

well you could say the same for add auto images etc etc. the default = "true" should select/enable it. Anyway let's take this discussion out of here. If it's confusing to anyone using the addon let us know!

 

Cheers

  • Like 1

Share this post


Link to post
Share on other sites
im85288

Just realised I posted about this in the STABLE release thread.

 

I'm running v1.0.06 of the add-on, so please move my posts to the relevant thread.

That's shocking behaviour for a moderator! Error has been noted :)

  • Like 2

Share this post


Link to post
Share on other sites
CBers

well you could say the same for add auto images etc etc. the default = "true" should select/enable it. Anyway let's take this discussion out of here. If it's confusing to anyone using the addon let us know!

 

Cheers

 

It's confusing :D

Share this post


Link to post
Share on other sites
CBers

That's shocking behaviour for a moderator! Error has been noted :)

 

I'm a user in this instance :D

 

A Kodi newbie you could say :D

Share this post


Link to post
Share on other sites
Angelblue05

Sorry, I will delete my posts and remove the confusion! :)

Share this post


Link to post
Share on other sites
CBers

That's shocking behaviour for a moderator! Error has been noted :)

 

Is there a beta thread ??

 

I'll move them if you want ??

Share this post


Link to post
Share on other sites
scalda

well you could say the same for add auto images etc etc. the default = "true" should select/enable it. Anyway let's take this discussion out of here. If it's confusing to anyone using the addon let us know!

 

Cheers

 

yes but your option shows that it is enabled in the config. whether by default or not

 

2015-06-11%2010.10.27.jpg

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...