Jump to content

Live TV tester needed


Luke
 Share

Recommended Posts

If you have an HDHomerun h264 transcoding model, and are using ServerWMC, I'd like to get direct play working with some of our apps.

 

@@krustyreturns fyi.

 

Please respond if you can help. Thanks.

Link to comment
Share on other sites

MrWebsmith

i have the hdhomerun prime.. a fairly new revision/release also i think (6months or so).. where/how can i tell its h264 abilities?

 

emby server: current dev.(Version 3.0.5607.0 right now)

swmc

ServerWMC

1.0.0.56, build: 1190  Up to date!

Edited by MrWebsmith
Link to comment
Share on other sites

I assume you mean the HDHR4-2US model?

http://www.silicondust.com/products/hdhomerun/hdhomerun-connect/

 

If so, I can help.

 

Great. Let's start in the web client, with chrome. Can you play live tv and then provide the server log? It will not direct stream. We need to see why it gets rejected, then figure out how to solve them. Thanks.

Link to comment
Share on other sites

I am running an HDHR3-CC with a good number of channels using the web client mostly for live TV and ServerWMC backend. I was also wondering why nothing would direct stream. Logs are attached. 

 

can you repeat the test with debug logging on? thanks.

Link to comment
Share on other sites

I have a HDHomeRun Prime as well.  Hope my log helps!

 

Either you don't have an h264 model, or the test wasn't followed exactly as requested.

Link to comment
Share on other sites

archangelz

I did some reading on that, apparently only the Gen 4 TC models transcodes. I believe these are the HDTC-2US and maybe HDHR4-2US (suspect no in the second case)

My HDHR3-CC does not do transcoding and only throws out what is available put down the stream by my provider which are H264 streams with AC3 audio or older mpeg2 streams, both of which are not going to transcode? It may very well be that the TC models only output H264 video and not audio, though wouldn't be able to tell without some logs. 

 

In any case, I've attached the logs though I don't think they'll be useful for your particular problem Luke. I turned up debug logging for these. 

transcode-30ebce10-566b-43c4-a676-ca4e086c661d.txt

server-63566726399.txt

transcode-62732ed5-0296-4042-a0f0-352e9722f2a7.txt

Edited by archangelz
Link to comment
Share on other sites

depends on the app. MBT will already direct play them. So can the fire tv app if the video is h264. win phone probably needs an update. win 8 - could possibly already direct stream the h264. roku will need an update but without h264 we can't test it

Link to comment
Share on other sites

archangelz

I thought chrome only did H264 w/AAC. In any case the transcode logs for 62732ed5 may be useful. Looks like it's from an H264/AC3 stream from my HDHR3-CC in the second set of logs but whether this matches the HDTC is a different story. 

Link to comment
Share on other sites

You're right, chrome can only do AAC audio, but i think the HdHomerun mobile stream might do AAC. So what we need to work out is, we need to get the server to choose the mobile stream as the one to play. Then it might work.

Link to comment
Share on other sites

Here are the server logs with debugging on from a live tv stream using HDHR4-2US.  Let me know if you need firmware versions, etc or to run it again.

 

Thanks. Looks like we might have to wait for krustyreturns because I'm not seeing what I'm expecting. He might have disabled it since we hadn't been using it. We'll see what he says.

Link to comment
Share on other sites

MrWebsmith

luke

 

you still want logs for this or hold until you and krusty reconnect a bit on whats already in the thread here?

Link to comment
Share on other sites

MrWebsmith

ok good to know, above1, thanks.

 

guess my prime isnt helping in any case so ill quietly retreat ;)

Edited by MrWebsmith
Link to comment
Share on other sites

krustyreturns

Sorry, I have been away.  I have not disabled the transcode profile thing, it should be working.

Link to comment
Share on other sites

Thanks krusty. then maybe these guys don't have the transcoding models because the log is only printing out one single media source.

Link to comment
Share on other sites

The model I have transcodes.  Are you looking for it ti be on a certain setting within the tuner?  Here is what I currently have it set to:

 

5554025906910_Untitled.jpg

Link to comment
Share on other sites

krustyreturns

@@econ,

 

Can you check the serverwmc log and see if it properly detects that you tuner can transcode?  or post the log and I'll check it.

Link to comment
Share on other sites

Is this the line you are looking for?

HDHRtuner::Init> DeviceId: 1050B4EE, IP: 192.168.1.14, Dlna: True, Transcode: True, Lineup.xml: True

I attached the log as well.

ServerWMC.log

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...