Jump to content

Media Browser Classic Configurator


Recommended Posts

Where did the Plugins tab for Configurator 3.0.262.0 go? I wanted to add some more Windows games but I can't do it.

Has installing Server 3.0.5572.0 screwed up Configurator? Help!

Link to post
Share on other sites
Maleficarum

In theater you add games via the external players screen. However MBC no longer has a config option for games and they must be added to the game.xml manually.

 

I'm working on an app for this and hope to have something ready in the near future,

Link to post
Share on other sites

Maleficarum, thanks for the reply. I tried to manually add new Windows games by editing the GameBrowser.xml file but it did not work. All my games installed before MB Classic Configurator was hobbled by the newest Server and MB classic updates are still playable from within MB3, so I'm at a standstill for adding new games to MB3. Your help would be much appreciated. Thanx.

Link to post
Share on other sites
Maleficarum

Yeah dos and windows games don't work the same way as emulator ones I believe. Would need to see a valid game.xml from someone that has those types working to see how the xml is structured for them.

Link to post
Share on other sites

Maleficarum, here is my game.xml file from within my Alan Wake game folder..... 

 

 

<?xml version="1.0" encoding="utf-8" standalone="yes"?>

<Item>
  <Players>1</Players>
  <GameSystem>Windows</GameSystem>
  <ContentRating>T</ContentRating>
  <Added>11/8/2014 7:38:21 AM</Added>
  <LockData>false</LockData>
  <Type>WindowsGame</Type>
  <Overview><![CDATA[When the wife of best-selling writer Alan Wake disappears on their vacation, his search turns up pages from a thriller he doesn't even remember writing. A dark presence stalks the samll town of Bright Falls, pushing wake to the brink of sanity in his fight to unravel the mystery and save the woman he loves.]]></Overview>
  <LocalTitle>Alan Wake</LocalTitle>
  <PremiereDate>2012-02-16</PremiereDate>
  <ProductionYear>2012</ProductionYear>
  <GamesDbId>9171</GamesDbId>
  <Genres>
    <Genre>Action</Genre>
    <Genre>Horror</Genre>
    <Genre>Shooter</Genre>
  </Genres>
  <Studios>
    <Studio>Remedy Entertainment</Studio>
    <Studio>Nitro Games / Remedy Entertainment</Studio>
  </Studios>
</Item>
 
And here is the corresponding GameBrowser.xml file from within the C:\ProgramData\MediaBrowser-Classic\Plugins\Configurations
 
<?xml version="1.0" encoding="utf-8"?>
  <GameSystems />
  <DosGames />
  <WinGames>
    <anyType xsi:type="GameSystem">
      <Name>Alan Wake</Name>
      <Executable>D:\GAMES\SteamApps\common\Alan Wake\AlanWake.exe</Executable>
      <Switches />
    </anyType>
  </WinGames>
  <EnableQuitKey>false</EnableQuitKey>
  <SelectedQuitKey>0</SelectedQuitKey>
</GameBrowserSettings>
 
Hope this helps.
 
Link to post
Share on other sites
Maleficarum

If you go into your Alan Wake folder is there a file called game.gbwin in there ? This is apparantly needed to make a windows game work.

Link to post
Share on other sites

Absolutely. That was a requirement for each game folder. With Gamebrowser III all games played just fine. And I was able to add new games to Media Browser 3 using Media Browser Classic configurator through it's plugins tab, easy peasy. Now that the plugins tab is gone, no can do. But, all the games installed through this old process still play just fine from within Media Browser. I just can't add new ones.

Link to post
Share on other sites

With Gamebrowser III all games played just fine. And I was able to add new games to Media Browser 3 using Media Browser Classic configurator through it's plugins tab, 

 

But the config xml you posted above doesn't have any of these other games in it - only the one.  What happened to the ones that were setup before and worked?  That's what we need - an example of what the configuration should look like for a working game.

Link to post
Share on other sites

Can you look at a definition for one that works and replicate that for the new one?  Can you post an example for others to try?

Link to post
Share on other sites

I have two Games libraries. The original D:\Games\SteamApps\common folder and the new D:\GOG\Games folder. I set up the GOG games folder just recently AFTER the hobbling of Media Browser Classic configurator. The games in the Steam folder all still play just fine from within Media Browser 3. But, as an example, RealMyst, in the new GOG games folder will not play even though I manually added it to the config xml. I added the game.gbwin file as always. Here is the game.xml file for RealMyst and GameBrowser.xml file after manually adding realMyst.....

 

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<Item>
  <Players>1</Players>
  <GameSystem>Windows</GameSystem>
  <ContentRating>E</ContentRating>
  <Added>4/15/2015 2:32:34 PM</Added>
  <LockData>false</LockData>
  <Type>WindowsGame</Type>
  <Overview><![CDATA[The original Myst is revamped for the new millennium, in 3D: dynamic and fully interactive with day and night condition cycles, changing weather, and real-time lighting effects. Unlike in the original version, with its "screen by screen" navigation and pre-rendered images that represented locations, Real Myst allows the player to physically explore the game's world and includes a fully rotatable camera.
The remake also adds a fifth "Age" (a world created by the power of human imagination), called the Rime Age, and a new available ending.]]></Overview>
  <LocalTitle>RealMYST</LocalTitle>
  <PremiereDate>2007-02-01</PremiereDate>
  <ProductionYear>2007</ProductionYear>
  <GamesDbId>10120</GamesDbId>
  <Genres>
    <Genre>Adventure</Genre>
    <Genre>Puzzle</Genre>
  </Genres>
  <Studios>
    <Studio>Gametap LLC</Studio>
    <Studio>Cyan Worlds</Studio>
  </Studios>
</Item>
 
Once again I edited the long config xml for brevity,
 
<?xml version="1.0" encoding="utf-8"?>
  <GameSystems />
  <DosGames />
  <WinGames>
    <anyType xsi:type="GameSystem">
      <Name>Alan Wake</Name>
      <Executable>D:\GAMES\SteamApps\common\Alan Wake\AlanWake.exe</Executable>
      <Switches />
    </anyType>
<anyType xsi:type="GameSystem">
      <Name>realMyst</Name>
      <Executable>D:\GOG Games\realMyst\RealMYST.exe</Executable>
      <Switches />
    </anyType>
 </WinGames>
 <EnableQuitKey>false</EnableQuitKey>
 <SelectedQuitKey>0</SelectedQuitKey>
</GameBrowserSettings>
 
 
Here is a pic of the PC Games section of my Media Browser 3 screen showing the RealMyst disc with the External Disk tag attached. Before the hobbling, if I ever saw this tag on any game disc icon I knew I needed to go to the plugins tab of MB Classic configurator and choose Gamebrowser and add the path to the executable for that game. It was nice and simple. Now I can no longer do this.
 
5531463a07897_RealMyst.jpg
Link to post
Share on other sites

That is what I meant.

 

Is the server on the same machine as the games?  Does it have access to that new folder?

 

Is MBC also on the same machine? 

Link to post
Share on other sites

ebr, why has MB Classic configurator been so hamstrung? It was so convenient to use it for plugins, especially Gamebrowser,  Can we please get it back. Why remove such simple convenience that worked so well? I'm MYSTified (no pun intended, but still amusing).

Edited by blixt99
Link to post
Share on other sites

Yes. The server is on the same machine as the Games folders. The game libraries(folders) are all on the same machine, as opposed to my music, movie, tv shows etc. which are on my network NAS box. Yes MBC is on the same machine.

Everything, all software etc. is installed on my HTPC machine. All has worked just fine before the latest round of MB and server updates, and still does except for adding new games. Do you think I should put my NEW games folder on the network NAS box?

Edited by blixt99
Link to post
Share on other sites

What happens if you add one of the new games to the old folder location.  I'm just stabbing in the dark but, since it is showing as an external disc, I'm thinking maybe GB is not able to access the location.  But I'm not familiar with the GB setup so I'm just guessing.

 

The reason this has been removed from the configurator is technical but, basically, it cannot load plug-ins anymore due to other changes in how we connect to the server.  GB is the only plug-in that required this type of configuration and the developer was aware of the impending changes many months in advance of them happening but never adjusted his plug-in for them.  Then he split.

Link to post
Share on other sites

ebr, I did install a game into the old games folder and it made no difference. The executable is just not being seen even though I manually added the path to it in the config xml file. 

Since I use Media Center for watching and recording TV shows and as my access point for Media Browser, I can just create a Steam entry point in Media Center that points to Steam.exe and use the Steam big picture interface to access all my existing games plus any new ones I may install. This is a poor substitute for the aesthetically pleasing interface of MB 3, but it will work. I would wish someone could solve the problem from within MB server and MB Classic.

Edited by blixt99
Link to post
Share on other sites

ebr, I did install a game into the old games folder and it made no difference. The executable is just not being seen even though I manually added the path to it in the config xml file. 

Since I use Media Center for watching and recording TV shows and as my access point for Media Browser, I can just create a Steam entry point in Media Center that points to Steam.exe and use the Steam big picture interface to access all my existing games plus any new ones I may install. This is a poor substitute for the aesthetically pleasing interface of MB 3, but it will work. I would wish someone could solve the problem from within MB server and MB Classic.

I'm with you blixt99.  I wish it wasn't removed until a new implementation for games existed.   Games not working correctly is kind of a huge feature loss.  I kinda regret building up the PCs to play games

 

I would hope that the previous versions of the server/client would be made available so we could make the decision to keep the functionality 

Edited by bxsteez
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...