Jump to content

Coverart: Not updating


heula
 Share

Recommended Posts

When I change things in Coverart I noticed it will not always be updated even after multiple library refreshes.

 

For testing I changed my thumb and episode overlay but it will not be changed. For episodes that is the case in ROC and NEO and for thumbs only Roc doesn't update like it seems.

 

https://dl.dropboxusercontent.com/u/901529/Media%20Browser/MB3/Coverart%20not%20updating%201.log

 

https://dl.dropboxusercontent.com/u/901529/Media%20Browser/MB3/Coverart%20not%20updating%202.log

 

Coverart%20not%20updating%202.jpg

 

Coverart%20not%20updating%201.jpg

Link to comment
Share on other sites

The first one looks like it is a collection item which has its own treatment style.

 

On the second, are you sure it is within the proper profile?

Link to comment
Share on other sites

The first one looks like it is a collection item which has its own treatment style.

 

On the second, are you sure it is within the proper profile?

The first is my own created thumb.jpg and the red bars must show that it has been treated as film once. That was the case till I changed it to border today. The film treatment is still there and is not updated.

 

Yes Im sure. Beauty and the beast is in Series Alex folder.

Link to comment
Share on other sites

I can't reproduce any of this so I will need to see a server log in debug mode when you make a change to a treatment and then bring that item up in a client for viewing (the web client will work).

Link to comment
Share on other sites

I can't reproduce any of this so I will need to see a server log in debug mode when you make a change to a treatment and then bring that item up in a client for viewing (the web client will work).

https://dl.dropboxusercontent.com/u/901529/Media%20Browser/MB3/server-Coverart%20not%20updating%201.log

 

https://dl.dropboxusercontent.com/u/901529/Media%20Browser/MB3/server-Coverart%20not%20updating%202.log

Link to comment
Share on other sites

There is a massive library scan and a lot of changes happening to your file system during that log but CoverArt was never called to process anything other than the configuration.

 

Is it possible for you to create this situation without all of that other stuff going on?  Plus, be sure you actually make a change to the configuration.  Don't just change it to one thing and then change it right back because that will cause the images to still be pulled from the cache.  You need to do something that is truly different for CA to re-process.

Link to comment
Share on other sites

There is a bug in the current server that will be fixed in the next release. If an image is requested using entirely default settings - no width or height values specified, then the original file is served as an optimization to avoid gdi processing. But it also needs to check if there are any image enhancers and that's what the current release is not doing. It's fixed and will be in the next one.

Link to comment
Share on other sites

There is a bug in the current server that will be fixed in the next release. If an image is requested using entirely default settings - no width or height values specified, then the original file is served as an optimization to avoid gdi processing. But it also needs to check if there are any image enhancers and that's what the current release is not doing. It's fixed and will be in the next one.

 

That sounds like a doozy ;) but all MBC image requests do contain the MaxWidth parameter...

Link to comment
Share on other sites

There are also new optimizations if the size falls within the max values requested. I'll review that. Could be a bug there.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...