Jump to content


Photo

How to force direct play for all videos via DLNA?


  • Please log in to reply
6 replies to this topic

#1 somy OFFLINE  

somy

    Advanced Member

  • Members
  • 304 posts
  • Local time: 07:31 PM

Posted 02 April 2015 - 05:16 AM

Hi,

 

I'm trying to find a way to force direct play for all videos via DLNA because I have some issue with the transcoded videos (green screen in the beginning and super shaky playback).

 

I tried the following without success:

  • I created a profile matching my device (a DLNA player in iOS), I double checked the log file that the profile is picked up correctly
  • In the profile, I configured the "Playback Settings" to allow max bitrate for videos to be 99999999 (I assume it mean 100Mbps)
  • In "Direct Play" I allowed videos with container "All", video codec "All" and audio codec "All".
  • In "Transcoding" section I kept everything default.
  • I then restarted Emby server

After restart, I connect my DLNA player to Emby and I still see most of videos being transcoded no matter what bitrate it is. My question is, is there any solution to simply force everything to direct play? Can I find out why Emby decides to transcode a certain video from the log files?

Thank you in advance!

 

PS. It looks to me like only .avi and .mp4 videos are not transcoded, all others formats are transcoded. Is it because DLNA only allow certain formats?


Edited by somy, 02 April 2015 - 05:24 AM.


#2 Deathsquirrel OFFLINE  

Deathsquirrel

    Advanced Member

  • Members
  • 2014 posts
  • Local time: 11:31 AM

Posted 02 April 2015 - 10:42 AM

Do you have a DLNA client device that supports all your formats?  That would be unusual but possible I suppose.

 

Generally speaking, the server transcodes what the client device can't natively play.



#3 somy OFFLINE  

somy

    Advanced Member

  • Members
  • 304 posts
  • Local time: 07:31 PM

Posted 05 April 2015 - 05:39 AM

Do you have a DLNA client device that supports all your formats?  That would be unusual but possible I suppose.

 

Generally speaking, the server transcodes what the client device can't natively play.

 

Yes I do, the mobile player on iOS I'm using is capable of playing any format (I have tested that over SMB).

Can I see in any log file when Emby decides to transcode certain videos? Thank you!



#4 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 16570 posts
  • Local time: 11:31 AM
  • LocationWashington State

Posted 05 April 2015 - 03:33 PM

Well if the device is capable of playing everything then you could remove the transcode option.



#5 somy OFFLINE  

somy

    Advanced Member

  • Members
  • 304 posts
  • Local time: 07:31 PM

Posted 14 April 2015 - 07:06 AM

Well if the device is capable of playing everything then you could remove the transcode option.

Hi,

I tried the following without success:

  • I created a profile matching my device (a DLNA player in iOS), I double checked the log file that the profile is picked up correctly
  • In the profile, I configured the "Playback Settings" to allow max bitrate for videos to be 99999999 (I assume it mean 100Mbps)
  • In "Direct Play" I allowed videos with container "All", video codec "All" and audio codec "All".
  • In "Transcoding" section I kept everything default.
  • I then restarted Emby server

How can I turn off transcoding completely for DLNA client? Thank you!



#6 esseki OFFLINE  

esseki

    Advanced Member

  • Members
  • 37 posts
  • Local time: 08:31 PM

Posted 28 April 2015 - 02:58 AM

Hi somy,

 

i am in the same situation as you but it seems that, luckily, i am having a bit more results than you.

Like you i am expecting my iOS app (VLC) to be able to decode any kind of content without requiring transcoding.

 

Here is what i did to successfully deactivate transcoding to my iOS devices running DLNA client app by creating a specific DLNA profile (DLNA / Profiles / New Custom Profile).

- in "Info" make sure that you have checked "Video", as a supported media type

- in "Info" / "Identification" : i have set some Http Headers (User-Agent in my case) to identify my DLNA client app and match this profile

- in "Direct Play" : i have kept only the "video" section (i'm not interested in Audio or Photo via DLNA) I left blank the "Container", "Video codec" and "Audio codec" to allow any of them. The result is the following :

Container: All
Video Codec: All
Audio Codec: All

- i left the "Container", "Codec" and "Response" tab empty

- i restarted emby

 

Now i'm realizing that you might have already done all what i mentioned just above.

In this case, if your media are still being transcoded you should check the following :

 

- Does your emby server access your media via a network share (smb or nfs) ? In this case you should set the path substitution (Library / Path Substitution). Here is what it looks like in my case considering the emby server is running on Linux and is  accessing my media stored on a Synology NAS via NFS :

From	                To
/mnt/nas_movies/	nfs://192.168.100.7/volume1/movies/

- The last possibility (even if it is seems that you already checked this) is that the profile you created for your iOS app is not being used properly. In this case you should share some logs to double check. To give you an example, i am using VLC on iOS to read my media via DLNA. To make sure the correct DLNA profile is selected, i followed the Http Headers route. Here is what my config looks like (DLNA / Profile /Custom Profiles / then pick your own custom profile) :

in "Identification", the "Http Headers" section contains two settings :

User-Agent: iOS
Substring

User-Agent: VLC
Substring

The reason why i had to define those two settings is that i realized that VLC was not using the same "User-Agent" when browsing the library and when launching a movie. So until i set the second "Substring" ("VLC"), i could see in my emby server logs that the appropriate custom profile was selected while browsing the library, but when launching a movie it was switching to the "default" profile.

 

I hope this will help.

 

By the way, may i ask you which iOS DLNA client app you are using ? And what does your "DLNA / Profile /Custom Profiles / Identification" settings look like ? The reason why i am asking this is that i would like to use some other DLNA client than VLC. The one i am really interested in is Infuse. I like its look and feel and the fact that it builds a library (with images and information about movies) in the iOS device. Library is always a nicer way to browse content rather than picking a file in a list. But my problem is i can not catch any interesting Http Header User Agent string to match the profile with this app. So i stick with VLC but i feel that i am missing something. Any advice would be greatly appreciated :)


Edited by esseki, 28 April 2015 - 03:11 AM.

  • Happy2Play likes this

#7 iorx OFFLINE  

iorx

    Newbie

  • Members
  • 4 posts
  • Local time: 09:31 PM

Posted 12 August 2019 - 04:39 PM

Hi, sorry for the necroposting here.

 

I just wanted to confirm that this helped me out getting rid of transcoding and make the internal mediaplayer to show all movies instead of just the ones it thought my LG-TV was able to show. Especially h265 material.

Now all movies are there and playing them, some, gives a short notice that the audio format isn't supported but I get sound anyway. Thinks the TV barfs on 7.1 but most files also have 5.1 track or some format it can handle because, as said, I got audio.

 

TV: LG 43UJ634V

 

I completed the generic profile according to the instruction but added LGE for a User-agent substring.

 

Brgs,






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users