Jump to content

GameBrowser broken after Emby server update


calvinm
 Share

Recommended Posts

calvinm

my Emby server was just updated to 3.0.5569.0 with GameBrowser 3.0.5354.30239.

My movies and tv shows still play fine through MediaBrowser Classic 3.0.258.0, but none of my video games play using GameBrowser 3.0.0.42. When i click play I am sent to the Windows desktop and nothing else happens. I have tried checking for more updates. I tried restarting and I've tried refreshing the Games library.

 

Every time I try to play a game, the following MediaBrowser Classic log file appears saying "The remote server returned an error". The local emulator and rom paths are correct:

 

2015-04-01 19:35:22.9773,Debug,,Loading full details for Spyro the Dragon,1,Application
2015-04-01 19:35:24.5473,Info,,No intros found for Spyro the Dragon,1,Application
2015-04-01 19:35:24.5473,Info,,Gamebrowser playback controller about to play Spyro the Dragon(G:\Games\Sony Playstation\Spyro the Dragon\Spyro the Dragon (US NTSC).bin) ,5,Worker thread for Play Action
2015-04-01 19:35:24.5573,Info,,Gamebrowser playback controller playing Spyro the Dragon,5,Worker thread for Play Action
2015-04-01 19:35:24.5573,Info,,*** GAMEBROWSER *** Trying to match GameSystem for Sony Playstation,5,Worker thread for Play Action
2015-04-01 19:35:24.5573,Info,,*** GAMEBROWSER *** GameSystem List has 9 entries,5,Worker thread for Play Action
2015-04-01 19:35:25.6174,Info,,*** GAMEBROWSER *** Process.Start(Sony Playstation,, C:\Program Files (x86)\Emulators\Sony Playstation\ePSXe.exe -nogui -loadbin "G:\Games\Sony Playstation\Spyro the Dragon\Spyro the Dragon (US NTSC).bin"),5,Worker thread for Play Action
2015-04-01 19:35:25.6174,Error,,Error playing item:  ( Exception.  Type=MediaBrowser.Model.Net.HttpException Msg=The remote server returned an error: (500) Internal Server Error. Src=MediaBrowser Method=Post Line=0 Col=0 [n] StackTrace= [n]    at MediaBrowser.ApiInteraction.MbHttpClient.Post(String url,, String contentType,, String postContent) [n]    at MediaBrowser.ApiInteraction.ApiClient.Post[T](String url,, Dictionary`2 args,, SerializationFormats serializationFormat) [n]    at MediaBrowser.ApiInteraction.ApiClient.Post[T](String url,, Dictionary`2 args) [n]    at MediaBrowser.ApiInteraction.ApiClient.ReportPlaybackStart(String itemId,, Guid userId,, String playMethod) [n]    at MediaBrowser.Application.ReportPlaybackStart(String id,, Boolean isStreaming) [n]    at GameBrowser_Classic.Code.ModelItems.GamePlaybackController.LaunchGame(Media media) [n]    at GameBrowser_Classic.Code.ModelItems.GamePlaybackController.PlayMediaInternal(PlayableItem playable) [n]    at MediaBrowser.Code.ModelItems.BasePlaybackController.Play(PlayableItem playable) ),5,Worker thread for Play Action
 
 
I also get the following Emby server log file saying that it was "Unable to cast object of type 'MediaBrowser.Controller.Entities.Game' to type 'MediaBrowser.Controller.Entities.IHasMediaSources' " :
 
*** Error Report ***
Version: 3.0.5569.0
Command line: C:\Users\Owner\AppData\Roaming\MediaBrowser-Server\system\MediaBrowser.ServerApplication.exe
Operating system: Microsoft Windows NT 6.1.7601 Service Pack 1
Processor count: 4
64-Bit OS: True
64-Bit Process: False
Program data path: C:\Users\Owner\AppData\Roaming\MediaBrowser-Server
Application Path: C:\Users\Owner\AppData\Roaming\MediaBrowser-Server\system\MediaBrowser.ServerApplication.exe
Unable to cast object of type 'MediaBrowser.Controller.Entities.Game' to type 'MediaBrowser.Controller.Entities.IHasMediaSources'.
System.InvalidCastException
  at MediaBrowser.Server.Implementations.Library.MediaSourceManager.<GetPlayackMediaSources>d__8.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at MediaBrowser.Server.Implementations.Session.SessionManager.<GetMediaSource>d__18.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at MediaBrowser.Server.Implementations.Session.SessionManager.<UpdateNowPlayingItem>d__1c.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at MediaBrowser.Server.Implementations.Session.SessionManager.<OnPlaybackStart>d__46.MoveNext()
 
2015-04-01 19:35:25.6174 Error - HttpServer: Error processing request for /mediabrowser/Sessions/Playing?CanSeek=False&IsPaused=False&IsMuted=False&ItemId=6911e4fc2ec13ad3f58bf1c9a8c6549c&QueueableMediaTypes=Audio&PlayMethod=DirectPlay&format=Json
*** Error Report ***
Version: 3.0.5569.0
Command line: C:\Users\Owner\AppData\Roaming\MediaBrowser-Server\system\MediaBrowser.ServerApplication.exe
Operating system: Microsoft Windows NT 6.1.7601 Service Pack 1
Processor count: 4
64-Bit OS: True
64-Bit Process: False
Program data path: C:\Users\Owner\AppData\Roaming\MediaBrowser-Server
Application Path: C:\Users\Owner\AppData\Roaming\MediaBrowser-Server\system\MediaBrowser.ServerApplication.exe
Unable to cast object of type 'MediaBrowser.Controller.Entities.Game' to type 'MediaBrowser.Controller.Entities.IHasMediaSources'.
ServiceStack.HttpError
No Stack Trace Available
 
2015-04-01 19:35:25.6174 Debug - HttpServer: HTTP Response 500 to 192.168.1.89. Response time: 0 ms.
 
I don't understand what either of those mean, but hope that there is an easy fix.
 
This is the XML for my GameBrowser 3.0.0.42 client:
 
<?xml version="1.0" encoding="utf-8"?>
  <GameSystems>
    <anyType xsi:type="GameSystem">
      <Name>Sony Playstation</Name>
      <Executable>C:\Program Files (x86)\Emulators\Sony Playstation\ePSXe.exe</Executable>
      <Switches>-nogui -loadbin "{rom}"</Switches>
    </anyType>
  </GameSystems>
  <DosGames />
  <WinGames />
  <EnableQuitKey>true</EnableQuitKey>
  <SelectedQuitKey>178</SelectedQuitKey>
</GameBrowserSettings>

 

 

This is the XML for my GameBrowser 3.0.5354.30239 server:

 

<?xml version="1.0"?>
  <GameSystems>
    <ConsoleFolderConfiguration>
      <Path>G:\Games\Sony Playstation</Path>
      <ConsoleType>Sony Playstation</ConsoleType>
    </ConsoleFolderConfiguration>
  </GameSystems>
</PluginConfiguration>
Link to comment
Share on other sites

calvinm

Thank you so much for everyone's hard work. Emby server was updated to 3.0.5572.0 and all the games started working again.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...