Jump to content

New CoverArt beta


ebr
 Share

Recommended Posts

I just put up version 4.0.3.5 as a beta.  It just has a couple of things in it:

 

  • I adjusted the scaling logic for drawing indicator overlays.  This definitely helped out the situation where you were putting these overlays on a landscape image and it might also help when you have your DPI set to over 100%.
  • I added a MetroCaseCDs treatment style for things like box sets when you are using the MetroCase for everything else.

It will cause all your treatments to re-build on first access to be sure everything is updated properly.

 

Please try it out and post any issues here.  Thanks.

Link to comment
Share on other sites

Hi Ebr,

Installed immediately eager to find out whether it solved the DPI issue, unfortunately it doesn't :(

Hopefully in a future release you'll be able to solve it.

Thanks for the effort though.

 

Greets,

Ernst

Link to comment
Share on other sites

Thanks for confirming Ernst.  I really didn't think it would help but thought it might.  I don't really know why this issue occurs as I am working off the size of the image that is reported to me by the framework.  Obviously, in this case, that is not actually the size of the image but, I don't know how I'd know that or what the real size is.

Link to comment
Share on other sites

Can't help you there either, I'm not really savvy on this topic.

I did notice something odd though that might give some indications.

If I use the icon option within CA, all media icons appear the same size (not propperly scaled and therefor overlapping each other)

If I use custom (using the mediaicons downloaded some time ago) some seem to be smaller and some bigger, despite the fact they are all .png's sized 102x76.

i'll send some screenshots later, in the mean time I'll try some differrent icon sizes myself and report back.

Link to comment
Share on other sites

OK, I had a bit of play around with the custom icons and found the following:

Applying the icons downloaded only works when monitor dpi is at 96 ppi (100%) it looks awfull at a higher setting.

Looking into the png's itself, i noticed they are set at 72 dpi.

I changed the dpi to 125 and reapplied. now they all look great!

I then changed them to 96 dpi and they still look good.

 

It did however take me a bit of work to see the changes comming through (don't see all of them yet).

Is there a way to force all cached images to be rebuild?

 

Could you send me the icons you have embedded in CoverArt (including the 3D ones and the subtitle ones) so I can convert them to 96 dpi?

 

If you like, I can send the converted ones back to you to embed in a later release?

Link to comment
Share on other sites

OK, I converted them to 96 dpi and all seem fine now, with one exception:

I couldn't get the 3d one working properly.

In the zip enclosed, I have included some extra files:

the command line .exe I used to convert and the bat file to treat all the files in the directory.

Additionlly I copied the 3dtext icon to 3d.png and made it 125 dpi instead of 96, that seems to work.

I also added a subt_dut.png to be able to test them.

https://www.dropbox.com/s/fdr0gdn496injy9/Custom-Overlays.zip

Hope this helps making CA even more versatile.

Link to comment
Share on other sites

I don't quite understand why the 3d one is working differently, but in the CA configuration i did work once I changed it to 125 dpi, I did't see any update in the web browser though.

Still trying to get it refreshed

 

OK, I changed the cover treatment to force it to refresh and 125 dpi on the 3d image now shows up correct.

You can use the 3d.png  rename it back to 3dText.png or use the setdpi to change the setting yourself.

Edited by Ernst
Link to comment
Share on other sites

Please try this version of CA and see if the internal versions work now.  You'll need to stop using your custom versions of course.

 

The treatments should re-build automatically without you having to refresh anything.

Link to comment
Share on other sites

OK, now I'm officially stumped!!

The 3d icon shows up fine now, but the others are still sort of overlapping. Far better then before, but still not quite.

Strangely enough, my custom icons are also not showing up as I would expect them to (exactly the same as yours)

Maybe I am experiencing some caching issue?

I will try again and make them all 125 dpi

Link to comment
Share on other sites

ok, that makes sense.

I was starting to doubt myself.

I have increase the dpi to 125 and it looks good (on my custom icons)

I also tried changing it to 300 dpi and it does not show any different.

Maybe it would be an idea to use the higher dpi so any screen resolution shows it correctly?

This it how it looks at 300 dpi (for the icons not the screen)

52825df6685dd_0.png

Link to comment
Share on other sites

redownloaded, but it doewn't solve the issue.

I was doing my previous post when you updated.

The screenshot above is with the first version 6 and seems to be oke.

I can send you the 300 dpi ones if you like.

 

version 7 does not seem to make a difference.

Edited by Ernst
Link to comment
Share on other sites

rats! the 300 ones show fine on covers but are far to small on tumbs.

I hoped I found the solution, but it seems to be a bit more difficult.

I'm afraid I'm at the end of my knowledge on this.

Link to comment
Share on other sites

Will have to change everithing back first and the refreshing isn't as straight forward as we thought.

Will try to put the 96 ones back in and try again.

Link to comment
Share on other sites

Agreed, I would leave it at this (at least for now untill someone solves this little mistery)

Although there is some ovelap in my views (see picture below) I can live with it.

For my personal use, I will probably tinker a bit with dpi settings untill it looks perfect and stick to custome icons.

It seems almost impossible to get this right for everyone.

Thanks for trying though

 

5282705ee347f_0.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...