Jump to content

Permission problem? with downloading images


Poptartica
 Share

Recommended Posts

Hey all. I was wondering if anyone had come across a similar problem recently.. running the latest (installed yesterday via the instructions on the site) Mediabrowser server on an Ununtu 14.04 LTS install..

 

Attempting to get images for a series does not work, in fact I cannot download any series images through the metadata manager (automatically, through refresh, or by individually choosing).

 

At first it was giving me an access denied error, so I changed permissions on the disk to be writable to all users just to see if that would help. I still got an error though in the webclient, stating that there was "An Error downloading the file ... " for individual items (refreshing did not work either still). Strangely enough though I was able to add the folders to my library just fine as they were seen immediately.

 

Attached is the log for the event(s), with the most recent error where the permissions were changed being the very last error on the log. I'm pretty new to Linux in general so if I'm missing something obvious here I'd love to know..

 

Any help would be greatly appreciated :)

server-63561740443.txt.zip

Link to comment
Share on other sites

thefirstofthe300

From the looks of everything, you have your videos in your home folder?

 

The last error in the log appears to still be related to permissions issues. Ubuntu is quite locked down when it comes to permissions so it may not like the fact that all of your videos are in your home folder.

 

The best way to go about setting up you library is to create a folder in the root filesystem (for example, /data) and move the videos to that folder. Then change the permissions so that MediaBrowser can access them (I do believe something like chown -R mediabrowser /data will do). To allow only certain users access to the folders, you will want a group dedicated to media management. Create the group media using groupadd media. Add the mediabrowser user to it with usermod -aG media mediabrowser. Add your user to the group with usermod -aG media {YOUR_USERNAME}. Change the permissions to be writable by the group: chmod 775 -R /data. Change the group owner on th folder: chgrp -R media /data. And you should be done with setting up the permissions and MediaBrowser should have full reign over your library. :)

  • Like 1
Link to comment
Share on other sites

From the looks of everything, you have your videos in your home folder?

 

The last error in the log appears to still be related to permissions issues. Ubuntu is quite locked down when it comes to permissions so it may not like the fact that all of your videos are in your home folder.

 

The best way to go about setting up you library is to create a folder in the root filesystem (for example, /data) and move the videos to that folder. Then change the permissions so that MediaBrowser can access them (I do believe something like chown -R mediabrowser /data will do). To allow only certain users access to the folders, you will want a group dedicated to media management. Create the group media using groupadd media. Add the mediabrowser user to it with usermod -aG media mediabrowser. Add your user to the group with usermod -aG media {YOUR_USERNAME}. Change the permissions to be writable by the group: chmod 775 -R /data. Change the group owner on th folder: chgrp -R media /data. And you should be done with setting up the permissions and MediaBrowser should have full reign over your library. :)

 

At the moment the home folder is where the drive that contains the media is mounted to, as I was having issues with other programs being able to access it in /media for some reason. When I attempted to change the permissions with chown a+wre, it didn't rid me of the error (that is the last error you see there on the log). Though I don't/didn't intend to keep it that way, it was mostly to see if that would help alleviate the problem so I could approach the issue with a more nuanced understanding of what was going on. Strangely, I actually was able to fix the issue by changing the permissions in the nautilus UI of the folder(s) to allow all to read/write/execute. Does the nautilus manager use a different permission assignment command than chown a/u/g+/-wre etc.. ?

 

Thanks though for that explanation, I'm new to Linux systems and that is stuff I wasn't aware of :) when I get a chance I'll likely do something similar to what you suggested and move the mounts to a more appropriate location.

 

Since things are now working I've gotten down to a more nit-picky issue about subtitle delays that I'm unsure of how to solve, but I'm uncertain if it's better to start a new topic for that one or not.

Link to comment
Share on other sites

thefirstofthe300

I bet the problem had to do with the fact that you weren't using the correct command. :) To allow access to folders, the folder has to have execute permissions which is granted either using octal (777) or using the letter, which happens to be x, not e. If you had used chmod +x instead of +e, I bet it would have worked.

 

As far as /media, I wouldn't recommend putting anything there if you are using Ubuntu. Ubuntu uses /media as the place to mount external drives so I would put your media somewhere else.

Link to comment
Share on other sites

I bet the problem had to do with the fact that you weren't using the correct command. :) To allow access to folders, the folder has to have execute permissions which is granted either using octal (777) or using the letter, which happens to be x, not e. If you had used chmod +x instead of +e, I bet it would have worked.

 

As far as /media, I wouldn't recommend putting anything there if you are using Ubuntu. Ubuntu uses /media as the place to mount external drives so I would put your media somewhere else.

 

Ahh, I see! I may have misspoke in my last post since at the time I'm fairly certain I used the correct command (mainly because I was referencing an Ubuntu guide - not because I have any faith in my own memory, lol!). Regardless, I'll just stick to octal permission assignment next time since that seems to be a go-to in many cases.

 

As for the drives, I'll be sure to avoid placing them in /media, I think Ubuntu's auto-mount tool placed them there and I just didn't know any better of it. That's good to know :)

 

I really appreciate the help! Setting everything up the best way possible will help me avoid future headaches..

 

I might as well ask, I've been having some issues with subtitles lagging behind the transcoding of my files significantly (by a few seconds or more - even on direct stream), whereas I haven't experienced this with some of the other media presentation solutions I've tried using the same exact files. I'm thinking it's something wrong with my setup for MediaBrowser, would you (or anyone else reading for that matter) have any possible server-setup solutions that might help with this off the top of your head? I considered separating the subtitle files from every single one of my files so they wouldn't have to be transcoded as well, but that would be a looooooot of files. I can grab a log file later for the transcoding of such a file should that be helpful, though last I checked them I didn't see any clearly-labeled errors myself (to my untrained eye, of course).

Link to comment
Share on other sites

thefirstofthe300

I am not an expert on subtitles so you will probably want to make another post detailing your problem, what you have tried, and post the server and transcode logs from your attempts.

 

http://mediabrowser.tv/community/index.php?/topic/739-how-to-report-a-problem/

 

The only thing I can think of is that the subtitle is meant for a file that plays a different number of frames per second but if it plays ok with other players that probably isn't the problem.

Link to comment
Share on other sites

I am not an expert on subtitles so you will probably want to make another post detailing your problem, what you have tried, and post the server and transcode logs from your attempts.

 

http://mediabrowser.tv/community/index.php?/topic/739-how-to-report-a-problem/

 

The only thing I can think of is that the subtitle is meant for a file that plays a different number of frames per second but if it plays ok with other players that probably isn't the problem.

Sounds good. Thanks again for the help! :)

Link to comment
Share on other sites

  • 7 months later...

I am going to try the following on a fresh install of KodiBuntu (14.04) and Kodi Helix. Emby server is installed. I have some questions. FYI...I am a big time noob, normally using windows.

 

First: Are we still using (user) "mediabrowser" or is it now "emby?"

Second: What is the command to move my hard drive's folders (movies) to the new "/data" folder (or whatever the name would be) in the root?

Thirdly: Will there be a conflict with the command including "media" (per FIRSTOFTHE300's example, see quote below).

, given that the default path to MOVIES includes "/media," or is this intentional?

 

BACKSTORY: I have gary as user, and emby as a user from the install. The drives are attached usb, named "WDBLACK" AND "WDBLUE." Each drive has a folder "Movies, "home videos" and "music."

In the Browser (8096) I can select these paths (or type them in on command line) and a pop-up warns ..."be sure emby has access to them." Then nothing happens. Eg., /media/gary/WDBLACK/movies.

Thanks for any help!

 

 

From the looks of everything, you have your videos in your home folder?

 

The last error in the log appears to still be related to permissions issues. Ubuntu is quite locked down when it comes to permissions so it may not like the fact that all of your videos are in your home folder.

 

The best way to go about setting up you library is to create a folder in the root filesystem (for example, /data) and move the videos to that folder. Then change the permissions so that MediaBrowser can access them (I do believe something like chown -R mediabrowser /data will do). To allow only certain users access to the folders, you will want a group dedicated to media management. Create the group media using groupadd media. Add the mediabrowser user to it with usermod -aG media mediabrowser. Add your user to the group with usermod -aG media {YOUR_USERNAME}. Change the permissions to be writable by the group: chmod 775 -R /data. Change the group owner on th folder: chgrp -R media /data. And you should be done with setting up the permissions and MediaBrowser should have full reign over your library. :)

Edited by GSSA1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...