Jump to content

Cant display subtitles when cast to Chromecast


saintchelo
 Share

Go to solution Solved by Luke,

Recommended Posts

saintchelo

Hi to all

I´m trying to cast from my PC and from my Android to Chromecast,

but none of the subtitles that I have associated with my media appear on my tv.

I have external srt and vosub (embedded in the media), but none of them appear even using MB for windows or MB for android
My PC version is 3.05518.3 and the version for android is the 02.02.03
Could someone help me?
Thank you all.

Edited by saintchelo
Link to comment
Share on other sites

jackblades

Edit: Oh geeze I thought this was my original post! Either way this may help.

 

Seems that the subtitles button (top left, "T") has appeared after selecting the automatically download subtitles from opensubtitles.org setting. You can find this setting under metadata->subtitles. 

 

My original srt was named: Paprika (2006) 1080p [Jpn 5.1 & Eng 5.1] Blu-ray English.srt, the downloaded srt was named: Paprika (2006) 1080p [Jpn 5.1 & Eng 5.1] Blu-ray.eng.srt

 

 

I'm guessing that MB3 is looking for a specific naming convention (eng.srt vs English.srt). Can anyone confirm or deny this?

Edited by jackblades
Link to comment
Share on other sites

saintchelo

Edit: Oh geeze I thought this was my original post! Either way this may help.

 

Seems that the subtitles button (top left, "T") has appeared after selecting the automatically download subtitles from opensubtitles.org setting. You can find this setting under metadata->subtitles. 

 

My original srt was named: Paprika (2006) 1080p [Jpn 5.1 & Eng 5.1] Blu-ray English.srt, the downloaded srt was named: Paprika (2006) 1080p [Jpn 5.1 & Eng 5.1] Blu-ray.eng.srt

 

 

I'm guessing that MB3 is looking for a specific naming convention (eng.srt vs English.srt). Can anyone confirm or deny this?

Thanks but I renamed my subtitles to movie_name.eng.srt and still dont appear when cast to Chromecast

Link to comment
Share on other sites

saintchelo

confirmed. click the help button in the library setup area to see the supported naming conventions.

Thanks but I renamed my subtitles to movie_name.eng.srt and still dont appear when cast to Chromecast

Link to comment
Share on other sites

saintchelo

confirmed. click the help button in the library setup area to see the supported naming conventions.

Thanks but I renamed my subtitles to movie_name.eng.srt and still dont appear when cast to Chromecast

Link to comment
Share on other sites

by default the subtitles that get sent to CC are based on your user profile settings. so click your user icon to set your subtitle preferences.

Link to comment
Share on other sites

saintchelo

by default the subtitles that get sent to CC are based on your user profile settings. so click your user icon to set your subtitle preferences.

Thanks, but what changes i must to do to make my subtitles visible when cast to Chromecast ?

Because my folder structure is

 

all_movies

                movie_name

                                    movie_01.(mkv or avi or mp4)

                                    movie_01.(eng or por or spa).srt

 

and I dont want to download subtitles from opensubtitles.org.

I want to use my subtitles that are working perfectly in any video player including when I use plex to cast to Chromecast, they working normaly (android and PC), with any kind of subtitle

(vosub , srt, in any color , etc)

 

Why I cant view my subtitles when I cast to Chromecast from MB (android and PC)

 

Coul you be more specific when you say settings please ?

        

Thanks again

Edited by saintchelo
Link to comment
Share on other sites

saintchelo

i thought i just covered that. based on your subtitle settings in your user profile.

And why I cant view the subtitles when I cast to Chromecast ?

When you say user profile settings, you say goto to into my MB client in browser Metadata>subtitles ?

 

post-8345-0-02169500-1424145864_thumb.png

Edited by saintchelo
Link to comment
Share on other sites

no those are just your optional downloading settings. those only pertain to obtaining subtitles.

 

to configure your playback settings, click your user icon in the top right of the web interface -> my preferences -> playback. for now you probably want to enable the option to always show subs just for testing purposes.

 

and you probably want to test playback in the regular web interface first to make sure it's functional there.

Link to comment
Share on other sites

saintchelo

no those are just your optional downloading settings. those only pertain to obtaining subtitles.

 

to configure your playback settings, click your user icon in the top right of the web interface -> my preferences -> playback. for now you probably want to enable the option to always show subs just for testing purposes.

 

and you probably want to test playback in the regular web interface first to make sure it's functional there.

I will try.

Thanks

Edited by saintchelo
Link to comment
Share on other sites

saintchelo

no those are just your optional downloading settings. those only pertain to obtaining subtitles.

 

to configure your playback settings, click your user icon in the top right of the web interface -> my preferences -> playback. for now you probably want to enable the option to always show subs just for testing purposes.

 

and you probably want to test playback in the regular web interface first to make sure it's functional there.

Thanks its working now in both PC and MB for android.

There is a possibility to change the color of subtitle ?

Because I have a movie that have 1 vosub (embed) in yellow and 1 .srt also in yellow, but the subtitles appear in white.

It´s possible to change color or view the subtitles color  that was pre-formatted ?

Thanks

Link to comment
Share on other sites

saintchelo

subtitle fonts are not yet configurable. we hope to do that in the future.

Thanks so much for your attention.

Another sugestion is that when browse playlists in MB for android, the playlists could be more easy to identify if the name of playlist was showed instead only thumbnail.

Thanks so much.

Link to comment
Share on other sites

  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...