Jump to content


Photo
- - - - -

Skip forward/back not working for MKVs

MKV skip

  • Please log in to reply
7 replies to this topic

#1 mdean1120 OFFLINE  

mdean1120

    Member

  • Members
  • 13 posts
  • Local time: 06:23 PM

Posted 26 December 2014 - 10:34 PM

I recently (today) upgraded from Media Browser 2 to 3.   I really like the new player interface, but I can't skip forward 30 sec, or jump to the middle of a movie like I used to be able to. Most of my movies are mkv (h264) make with handbrake.    I thought it didn't work at all until I tried playing an AVI movie I ripped.   The AVI worked just as the usage guide describes.   I saw a post the mentioned maybe the 5.1 is the cause?    I tried:

 

MKV w/2ch AC-3 audio   Fails

MKV w/2ch  mp3 audio   Fails

MKV w/6ch AC-3 audio   Fails

 

Is this a known issue?  Is there a fix in progress?

 

Other notes:

Resume does not even show up if you stop playback

Clicking on a chapter always restarts the movie.

This happens on 2 different client PCs (windows 7)

 

Thanks,

Michael



#2 steelman1991 OFFLINE  

steelman1991

    Advanced Member

  • Members
  • 161 posts
  • Local time: 06:23 PM

Posted 27 December 2014 - 07:54 AM

Have a look at this thread - http://mediabrowser....ce-usage-guide/

 

Some of the functionality has changed, but is explained there.

 

Not sure why 'resume' isn't showing up, other than you might not have played past the point where resume becomes functional - I think this can be user set from the Server Dashboard (yip - under Playback).



#3 mdean1120 OFFLINE  

mdean1120

    Member

  • Members
  • 13 posts
  • Local time: 06:23 PM

Posted 27 December 2014 - 09:13 AM

I did find and read over that and none of those functions work for the MKV (h264) files.  They do work for the one AVI (divx) file I tried.



#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 51984 posts
  • Local time: 01:23 PM

Posted 27 December 2014 - 01:18 PM

Be sure your items are actually direct playing and not streaming from the server.  Please post an MBC log when you attempt these operations.



#5 mdean1120 OFFLINE  

mdean1120

    Member

  • Members
  • 13 posts
  • Local time: 06:23 PM

Posted 27 December 2014 - 01:40 PM

This seems to indicate it is transcoding?    I understand why that would prevent skipping.   Why is it transcoding?  I increased the local network max bitrate as high as it would go (40) and have the warn if streaming checked.  I did not see a warning, but i might just be missing it.

 

 

2014-12-27 12:32:50.8661 Info - App: SessionInfoWebSocketListener stop transmitting over websocket to 192.168.15.100:55541
2014-12-27 12:32:50.8661 Info - App: ScheduledTasksWebSocketListener stop transmitting over websocket to 192.168.15.100:55541
2014-12-27 12:33:43.7339 Info - App: /media/81736aca-ec4b-4861-94db-4debb6890d26/mediabrowser/ffmpeg/20140716/ffmpeg -fflags +genpts -i file:"/mnt/samba/Movies/Frozen/Frozen.mkv" -map 0:0 -map 0:1 -map -0:s -vcodec msmpeg4 -force_key_frames expr:gte(t,n_forced*5) -vf "scale=min(iw\,720):trunc(ow/dar/2)*2" -mbd 2 -b:v 933788 -vsync vfr -map_metadata -1 -threads 0 -acodec wmav2 -ac 2 -ab 128000 -af "aresample=async=1,volume=2" -y "/media/81736aca-ec4b-4861-94db-4debb6890d26/mediabrowser/transcoding-temp/4b338fe96080c1d07481b25010d66bbf.asf"



#6 mdean1120 OFFLINE  

mdean1120

    Member

  • Members
  • 13 posts
  • Local time: 06:23 PM

Posted 27 December 2014 - 02:58 PM

Ok, I think i understand.   I need to use Path Substitution to get this to work like i want.



#7 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 51984 posts
  • Local time: 01:23 PM

Posted 27 December 2014 - 07:32 PM

Ok, I think i understand.   I need to use Path Substitution to get this to work like i want.

 

Yep.



#8 tornadotj OFFLINE  

tornadotj

    Advanced Member

  • Members
  • 105 posts
  • Local time: 11:23 AM

Posted 30 December 2014 - 05:18 PM

I am directly playing, and I have these same issues. I connect to (for example) \\192.168.1.1\movies for content. I also have a substitution set up, just in case. 

 

I think we may have two threads for the same issue going?







Also tagged with one or more of these keywords: MKV, skip

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users