Jump to content

Wake on Lan


Deihmos
 Share

Recommended Posts

Deihmos

Kodi has a function to auto wake a remote server but it does not work with XBMB3C and I really wish it did. Any plans to add this function in the near future?

Link to comment
Share on other sites

im85288

This may be looked into when MB Connect is integrated into the addon. For the other apps please request that in the appropriate thread.

Link to comment
Share on other sites

7illusions

The functionality is implemented in the win8 app, yes. But it's pretty much untested..

I'm actually uncertain where the WOL settings for the server are configured. (if implemented yet?).. @@Luke, I guess I need your input here regarding that part.

Link to comment
Share on other sites

im85288

As long as your sending the magic packets to the server address it should be fine. No changes on the media browser server side are needed.

Link to comment
Share on other sites

7illusions

I'm very much aware of how WOL works, but it's our "It Just Works" functionality I'm unaware of atm.

Basically, the Connection manager tries to connect, if it doesn't work it will  send of the magic package to the stored server. My question is if the ServerInfo object has this data from the server already or not.. (This is what should be configured on the server, in the dashboard)

 

Even though I could add a basic WOL method, that's not what we are intending to do..

Link to comment
Share on other sites

I can't get wake on wan working at all with an app that uses the mac address of my pc, never mind mb...

All the correct settings in device manager for Nic, no bios settings for it...

It's my new pet hate after fixing two Mary j bliges!!!

Link to comment
Share on other sites

e123enitan

I use XBMB3c in XBMC

for WOL 

 XBMC> Setting > program  addon> advance wake up land,

very simple to setup

Link to comment
Share on other sites

elcabong

I can't get wake on wan working at all with an app that uses the mac address of my pc, never mind mb...

All the correct settings in device manager for Nic, no bios settings for it...

It's my new pet hate after fixing two Mary j bliges!!!

 

There has to be a bios setting on the pc you want to wake.. it will not be in the OS device manager because the OS is not running when the WOL packet is sent.  The nic must stay powered up to receive the request, search google for your mobo and how to enable WOL.  unless its a pretty old mobo, there will be a setting for it in the bios, it might not be called WOL but should be in the same menu or submenu where you can enable turning the computer on using keyboard or mouse presses when in standby or sleep.

Link to comment
Share on other sites

There has to be a bios setting on the pc you want to wake.. it will not be in the OS device manager because the OS is not running when the WOL packet is sent.  The nic must stay powered up to receive the request, search google for your mobo and how to enable WOL.  unless its a pretty old mobo, there will be a setting for it in the bios, it might not be called WOL but should be in the same menu or submenu where you can enable turning the computer on using keyboard or mouse presses when in standby or sleep.

http://uk.msi.com/faq/mb-25.html

 

did it and forwarded ports 7&9 = no dice

Link to comment
Share on other sites

elcabong

here are some resources i found that have more info than the msi website.  it looks like i was wrong about the windows settings.. interesting..  i guess some manufacturers thought it was too hard to set 1 variable in the bios for this, and now you need to mess about in the os for an "easier" way to do advanced setup.. 

 

http://www.tomshardware.com/answers/id-2025866/wake-lan-msi-z87-g43.html

 

http://forum.overclock3d.net/showthread.php?t=58831

 

 

what are the open ports for, so you can send the wol from the internet?  make sure you can get the wol to happen on lan first, then go to the wan side.

Link to comment
Share on other sites

Wake on WAN only works if your Router don't flush its ARP-Table after a Device is offline

(Most Router are deleting offline devices from their ARP-Table after some time)

 

Nevertheless Wake on LAN should work with all Routers

Link to comment
Share on other sites

Wake on WAN only works if your Router don't flush its ARP-Table after a Device is offline

(Most Router are deleting offline devices from their ARP-Table after some time)

 

Nevertheless Wake on LAN should work with all Routers

I've given it a fixed up in dhcp, so ports are forwarded there. That should work surely?

Link to comment
Share on other sites

I've given it a fixed up in dhcp, so ports are forwarded there. That should work surely?

 

No, it has nothing to do with port forwarding or fixed IP's.

Most routers detele offline devices from their ARP-Table, like i already said.

 

If a device is not on the ARP-Table the portforwardings to this adress don't work  ;)

It's because the Router don't have a corresponding NIC Adress if the device is not on the ARP-Table.

 

 

The only solution would be to add a portforwarding to the broadcast adress of your network.

The broadcast adress is normaly 192.168.X.255

But most routers don't allow portforwarding to the broadcast adress  :unsure: 

Edited by CM000n
Link to comment
Share on other sites

Looking at that it uses the ip address and mac address, both of which are supplied by the WOWAN software I have on my phone.. So "should" work..?

Link to comment
Share on other sites

Looking at that it uses the ip address and mac address, both of which are supplied by the WOWAN software I have on my phone.. So "should" work..?

 

Sry, I don't understand what you want to say me with that. Looking at what?  :blink:

;)

 

Btw: What is you router model?

Edited by CM000n
Link to comment
Share on other sites

The link to arp-table...

ARP is used to convert an IP address to a physical address such as an Ethernet address (also known as a MAC address).

 

It's a crappy ee brightbox tried swapping it out for my old zyxel the other day but it wouldn't have it.. Not sure why?

Link to comment
Share on other sites

The link to arp-table...

 

ah ok, now i understand  :)

 

The WOL Software on your Smartphone don't send any routing instructions to your router.

It just sends a magic package  (which consists of the MAC address). But yor Router don't know where to send this magic package if you PC isn't in the ARP-Table

 

 

.::edit::. I have now read some threads on the internet. Your router does not seem to support static ARP-Tables.

Have you tried portfowarding to your broadcast adress?

Edited by CM000n
Link to comment
Share on other sites

Make a port forward to this 192.168.0.255 or this 192.168.1.255 (depends on you network configurationadress, instead to the adress of your PC.

  • Like 1
Link to comment
Share on other sites

  • 3 months later...
Deihmos

I tried advanced WOL and it works but Media browser times out too quickly. Is there a way to increase the wait time for the server?

Edited by Deihmos
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...