Jump to content

Media Browser Classic, Windows Media Center and Album Art?


keef
 Share

Go to solution Solved by keef,

Recommended Posts

I don't know whether this is a settings/configuration/file structure issue on my end, but how does MBC (currently on 3.0.78.0 B10-17.2) pass album art to the Windows Media Center player?  Indeed, does it even need to pass album art.

 

All my music is structured Artist/Album/Track, and all tracks have embedded artwork.  But this is what I'm seeing:

 

Playing a track from Media Browser Classic:

 

WY_MBC.jpg

 

And playing the same track directly from Windows Media Center:

 

WY_WMC.jpg

 

All art shows OK when browsing the MB server (3.0.5031.21343) via the web interface.

 

What am I doing wrong/missing?

 

EDIT - apologies for the language on the background waterfall images :huh:

Edited by keef
Link to comment
Share on other sites

We don't/can't pass any of the metadata displayed in the WMC players.  So that is coming from wherever it comes from normally within WMC.  Probably looking for folder.jpg in the folder with the music files.

Link to comment
Share on other sites

WMC/WMP has done its thang and created hidden folder.jpg and AlbumArtSmall.jpg system files.  This folder.jpg shows up when playing directly from WMC's music library but not when playing from MBC, which I don't understand.  Playing from WMC gets the info, playing from MBC doesn't...

Edited by keef
Link to comment
Share on other sites

And you've defined your music library on the server using UNC paths?

 

Other than that, I'm not sure.  I don't see this behavior with my albums.

Link to comment
Share on other sites

Yes, just the one media location, defined using UNC.  I'll have a play/dig and see if I can figure whats wrong.

 

EDIT:  Hmmm, I've just initiated playing on some more random tracks from MBC - album art shows for some, not others.  But the ones it doesn't show for are by far the majority.  At least I've got something to go on...

Edited by keef
Link to comment
Share on other sites

strugglez

I was wanting to post this yesterday and show a screen shot like yours. I am experiencing exactly the same thing. What I can tell you though is from another thread I started, is I disabled WMP from updating  my library and deleted all the folder.jpg's that are system/hidden files from within my music folders and sub-folders. I then ran a bacth file to extract my embedded album art from my albums and create album.jpg files within the album folders. I then fired the server up and away it did it's thing. I now have my assigned album art loading up in MB3 but as you have pointed out, some are not displayed when playing in the play now tab etc.

 

When I get home, I will try muck around with WMC/WMP more and try find where else it may store this data. I assume it's a temp/cache folder tbh, as it's not adding the files to any library but merely playing the file.

Link to comment
Share on other sites

swhitmore

I use Windows Media Player to get all my album art and metadata for music. Works well in WMC.

Link to comment
Share on other sites

  • Solution

OK, this had nothing to do with MBC - looks like an issue with the WMC music library.

 

It's fixed - I removed my music directory from WMC, and let it rebuild the library until nothing showed under Music.  I then deleted all the hidden AlbumArt system files, re-added the directory to the WMC music library and album art seems to show now when played from MBC.

 

I still don't understand why the art showed before for playing from WMC but not MBC.... 

  • Like 2
Link to comment
Share on other sites

AlwinHummels

OK, this had nothing to do with MBC - looks like an issue with the WMC music library.

 

It's fixed - I removed my music directory from WMC, and let it rebuild the library until nothing showed under Music.  I then deleted all the hidden AlbumArt system files, re-added the directory to the WMC music library and album art seems to show now when played from MBC.

 

I still don't understand why the art showed before for playing from WMC but not MBC.... 

It's one of the wonders they called Microsoft Windows :P

Edited by AlwinHummels
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...