Jump to content

Playback keeps freezing


amateurgod

Recommended Posts

amateurgod

Starting today every episode I watch keeps freezing for a few seconds, sometimes it can be minutes apart sometimes it can be seconds, after checking theog I noticed that this appears when it freezes 

 

Quote

Warn SessionWebSocketListener: Unable to determine session based on url: /embywebsocket?api_key=readacted&deviceId=redacted

And then when it starts playback again it looks like it creates a new session for playback as the logs show the server sending the device the progress information 

 

I'm watching on android TV using an external player, have also tried with built in player and experience the same issues 

Link to comment
Share on other sites

amateurgod
Posted (edited)

I've also noticed this in the logs every now and then, not sure if it's related however the IP is the IP of my Nginx VM

 

Quote
Warn Server: AUTH-ERROR: 192.168.80.187 - Access token is invalid or expired.
2024-04-21 00:26:36.994 Error Server: Access token is invalid or expired.

 

However I doubt it's related as the issue happens even when using IP:Port to connect to emby

Edited by amateurgod
Link to comment
Share on other sites

amateurgod

Not sure what caused this however seems to have been fixed by changing the IP assigned to the client device

Link to comment
Share on other sites

amateurgod

After a couple of hours this has started happening again, with the same errors about invalid access token and unable to determine session

Link to comment
Share on other sites

amateurgod

Here you go, I cycled the log file before pressing play and then again after the issue happened so that there wasn't tons of stuff to go through, I also have an earlier one where I enabled debug logging if needed 

embyserver-63849270739.txt

Link to comment
Share on other sites

amateurgod

This also seems to only be happening on android TV devices as if I start playback on my android phone then I don't have any issues with the playback 

Link to comment
Share on other sites

3 hours ago, amateurgod said:

Here you go, I cycled the log file before pressing play and then again after the issue happened so that there wasn't tons of stuff to go through, I also have an earlier one where I enabled debug logging if needed 

embyserver-63849270739.txt 6.91 kB · 1 download

Hi, this looks like starting from the middle of playback. Can you please attach the complete emby server log file? Thanks.

Link to comment
Share on other sites

3 hours ago, amateurgod said:

Here you go, I cycled the log file before pressing play and then again after the issue happened so that there wasn't tons of stuff to go through, I also have an earlier one where I enabled debug logging if needed 

embyserver-63849270739.txt 6.91 kB · 1 download

Hi.  Can you try sideloading our standard android app on the same device and see how that compares?

https://emby.media/emby-for-android.html

Thanks.

 

Link to comment
Share on other sites

amateurgod
On 21/04/2024 at 08:26, Luke said:

Hi.  Can you try sideloading our standard android app on the same device and see how that compares?

https://emby.media/emby-for-android.html

Thanks.

 

Hi sorry for the delay in getting back to you, I tried on the standard android app and had the same issue, I tried on Kodi however on the same device and had no issues with playback 

 

Here are the logs for an issue from start of playback to end of play back, once the issue occured I waited for the show to start playing again before ending playback and then rotating the log file 

 

 

embyserver-63849438510.txt

Link to comment
Share on other sites

  • 2 weeks later...
amateurgod
Posted (edited)

@Lukeany feedback on this as it has basically made watching emby on TV impossible unless use Kodi which I'm not a fan of as this seems to be happening on all android TV devices regardless of whether I use the android TV app or the standard Android App. 

 

Could it be something caused by an update to the android TV OS?

Edited by amateurgod
Link to comment
Share on other sites

hi, have you updated to Emby for Android 3.3.86? Has that helped?

Link to comment
Share on other sites

amateurgod
On 03/05/2024 at 19:50, Luke said:

hi, have you updated to Emby for Android 3.3.86? Has that helped?

Yes that's the version I'm on and no it hasn't helped 

Link to comment
Share on other sites

Hi, can you give an example of a file that this is happening on? Thanks.

Link to comment
Share on other sites

  • 1 month later...
amateurgod
On 17/05/2024 at 00:15, Luke said:

Hi, can you give an example of a file that this is happening on? Thanks.

hi apologies busy month and i forgot to reply, its happening on any file i try to play of varying formats and filesizes

Link to comment
Share on other sites

Is this high bitrate video? Freezing over the local network usually means the data just isn't getting there quickly enough.

Link to comment
Share on other sites

amateurgod

thats what i thought so i did some tests to rule it out its hardwired with Cat8 cables via 1gbps ports, according to unifi the devices arent having any issues with speed, they are all getting GbE and are no where near reaching there bandwidth limit, i have installed both plex and jellyfin onto the devices to test and they both stream fine with no issues, its only Emby that has issues and only on the androidTV/GoogleTV os, works fine on windows and android phone, the files range from 720p to 4k.

Link to comment
Share on other sites

  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...