Jump to content


Photo

iOS app - cannot access server via cellular


Best Answer Longrifle , 27 October 2013 - 01:57 AM

Hi all I am posting this because I was so frustrated with not being able to connect via cellular I was about to give up. hopefully this helps other people that may be experiencing the same problem.

I finally figured out why the port did not show as open.

 

I am running a Motorola Modem/wi-fi router that was provided by my ISP but I am also running a Linksys Gigabit router in line with it. I was forwarding the ports on the lynksys router but forgot all about the Motorola router, the Motorola router was blocking these ports.

 

So if you are running two routers you have to forward the ports on both or it will not work.

 

if anyone needs helps with this I am willing to lend a hand.

 

thank you all for your help.

Go to the full post


  • Please log in to reply
22 replies to this topic

#1 smarty39 OFFLINE  

smarty39

    Member

  • Members
  • 12 posts
  • Local time: 04:38 AM
  • LocationCalgary, Canada

Posted 17 October 2013 - 04:52 PM

Hopefully I am just missing something here, but I cannot access my server from anywhere BUT internall via wifi?  I have MBS on one box and then 2 HTPC's running MBC and 2 iPhones running the iOS app.  The HTPC's obviously work flawlessly (on the same network) and the iPhones work when I'm on my home wifi.

 

Anybody have any ideas as to why I can't access the server?

 

TIA ;)



#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50083 posts
  • Local time: 05:38 AM

Posted 17 October 2013 - 04:57 PM

Are you using your routers external IP address?  Have you set up the proper port-forwarding on the router to find the server?



#3 smarty39 OFFLINE  

smarty39

    Member

  • Members
  • 12 posts
  • Local time: 04:38 AM
  • LocationCalgary, Canada

Posted 17 October 2013 - 05:01 PM

I assume not (because I don't really know what you mean lol).  My main router feeds directly into a Linksys switch and then all my computers connect to that.  The IP of the MBS is 192.168.1.99 which I assume is from the Linksys...are you saying I need some sort of 'rule' on the main router to recognize the Linksys IP?

 

Thanks for the quick reply too!  I love 'active' forums :)



#4 Abobader OFFLINE  

Abobader

    Super-Tester

  • Administrators
  • 9463 posts
  • Local time: 01:38 PM

Posted 17 October 2013 - 05:14 PM

Good day,

 

You need 3 things for this to work (be able to access your MB3 server on WAN "Internet"):

 

1 - If you have static IP (that mean your internet IP do not change) check your internet IP from site like whatmyip

 

Here if you have static, then it easy, but if your IP change (Dynamic IP) you need some sort of DDNS service like : NOIP and make your account there.

 

2 - Now you need to go to this site: portforward and see how you can port forward your IP from your router.

 

3 - On your MB3 server PC, from your firewall make sure the ports for MB3 server been open for "Public".

 

My best


  • ebr likes this

#5 darwindeeds OFFLINE  

darwindeeds

    Advanced Member

  • Alpha Testers
  • 993 posts
  • Local time: 05:38 AM

Posted 18 October 2013 - 11:51 AM

Thanks Abo. 

 

You need the external address in the server list to be able to access it from cellular. 



#6 PiratePete OFFLINE  

PiratePete

    Newbie

  • Members
  • 1 posts
  • Local time: 06:38 AM

Posted 22 October 2013 - 04:05 PM

Was wondering if there was step by step documentation available to address the above issue. Port forwarding seems challenging for us non-tech users.



#7 Popeye2468 OFFLINE  

Popeye2468

    Advanced Member

  • Members
  • 73 posts
  • Local time: 10:38 AM
  • LocationNorwich

Posted 22 October 2013 - 07:31 PM

Has anybody solved this yet? got the app sat on my phone being pretty redundant as im not sure how to setup access over cellular network.  I think it would be a really good idea to make this in to a tutorial step by step for people like myself who are unable to figure this out



#8 Tikuf OFFLINE  

Tikuf

    Obsolete User

  • Members
  • 3626 posts
  • Local time: 09:38 PM

Posted 22 October 2013 - 07:56 PM

As it is different on every router it is hard to make a catch all kb article. Head on over to 

 

http://portforward.c...routerindex.htm

 

see if you can find your router and follow the instructions and fwd both ports 8096 and 8945

 

 (provided you are using the default settings) 

 


Edited by Tikuf, 22 October 2013 - 07:56 PM.

  • darwindeeds likes this

#9 Popeye2468 OFFLINE  

Popeye2468

    Advanced Member

  • Members
  • 73 posts
  • Local time: 10:38 AM
  • LocationNorwich

Posted 23 October 2013 - 04:17 AM

Im sorry but im not very good with all this could we please have a step by step guide on what to do my ports are forwarded but I cannot connect

thanks



#10 smarty39 OFFLINE  

smarty39

    Member

  • Members
  • 12 posts
  • Local time: 04:38 AM
  • LocationCalgary, Canada

Posted 23 October 2013 - 01:00 PM

Sorry guys, didn't get a chance to try the port forwarding.  I'll get it working tonight and try and do up a quick tutorial ;)



#11 Longrifle OFFLINE  

Longrifle

    Advanced Member

  • Alpha Testers
  • 136 posts
  • Local time: 02:38 AM

Posted 23 October 2013 - 06:38 PM

OK, well I forwarded both ports to my pc running MB3Server, on my iPhone I am using the routers ip address and port 8096. still does not work? why two ports? do I need to list both ports on the phone? do I need to add :8096 to the address on the phone app?

 

please help.

 

thank you so much in advance.


Edited by Longrifle, 24 October 2013 - 12:14 PM.


#12 sfnetwork OFFLINE  

sfnetwork

    Advanced Member

  • Alpha Testers
  • 2632 posts
  • Local time: 06:38 AM
  • LocationSaint-Eustache, Qc. Canada

Posted 23 October 2013 - 07:20 PM

Confirm your ports are opened first: http://www.yougetsig...ols/open-ports/

This site will also confirm your WAN IP (Internet)

Try to access the web client from Internet (disable Wifi from iPhone then try "(your IP):8096/mediabrowser" from your cellular network using Safari)

See first if those works.


Edited by sfnetwork, 23 October 2013 - 07:21 PM.


#13 Popeye2468 OFFLINE  

Popeye2468

    Advanced Member

  • Members
  • 73 posts
  • Local time: 10:38 AM
  • LocationNorwich

Posted 24 October 2013 - 04:21 AM

Ok 100% confirmed ports are open I can even access the server through safari but still no access through ios app

 

in safari my address was http://(External ip address):8096/mediabrowser

 

So how does that translate into what I should put into the media browser app to have access I have tried

 

(external ip address):8096/mediabrowser

 

and

 

http://(External ip address):8096/mediabrowser

 

 

Ok No probs I totally figured it out

 

If anyone having trouble PM me and I will help


Edited by Popeye2468, 24 October 2013 - 04:29 AM.


#14 Tikuf OFFLINE  

Tikuf

    Obsolete User

  • Members
  • 3626 posts
  • Local time: 09:38 PM

Posted 24 October 2013 - 08:11 AM

Easier if you just post it here for those that may not be members



#15 Abobader OFFLINE  

Abobader

    Super-Tester

  • Administrators
  • 9463 posts
  • Local time: 01:38 PM

Posted 24 October 2013 - 08:17 AM

As Tikuf said, if you find a solution that work with you, it best just to share it publicly on the forum for all members/guest.



#16 Longrifle OFFLINE  

Longrifle

    Advanced Member

  • Alpha Testers
  • 136 posts
  • Local time: 02:38 AM

Posted 24 October 2013 - 12:34 PM

after checking my ports on the website above, it reports my ports as closed?? does that mean they are closed on the router or my PC?

I even try to manually open the port in my windows firewall. (see attached)

 

still reports closed.

Attached Files


Edited by Longrifle, 24 October 2013 - 01:02 PM.


#17 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50083 posts
  • Local time: 05:38 AM

Posted 24 October 2013 - 01:04 PM

You have to open and forward them on your router.



#18 Longrifle OFFLINE  

Longrifle

    Advanced Member

  • Alpha Testers
  • 136 posts
  • Local time: 02:38 AM

Posted 24 October 2013 - 01:16 PM

I did. look at my settings  526955e42a728_Screenshot20131024at100737



#19 Longrifle OFFLINE  

Longrifle

    Advanced Member

  • Alpha Testers
  • 136 posts
  • Local time: 02:38 AM

Posted 27 October 2013 - 01:57 AM   Best Answer

Hi all I am posting this because I was so frustrated with not being able to connect via cellular I was about to give up. hopefully this helps other people that may be experiencing the same problem.

I finally figured out why the port did not show as open.

 

I am running a Motorola Modem/wi-fi router that was provided by my ISP but I am also running a Linksys Gigabit router in line with it. I was forwarding the ports on the lynksys router but forgot all about the Motorola router, the Motorola router was blocking these ports.

 

So if you are running two routers you have to forward the ports on both or it will not work.

 

if anyone needs helps with this I am willing to lend a hand.

 

thank you all for your help.


  • ebr likes this

#20 TJ73 OFFLINE  

TJ73

    Member

  • Members
  • 11 posts
  • Local time: 10:38 AM

Posted 15 November 2013 - 03:32 AM

I had some trouble setting up my iOS app, so thought I'd add to the conversation about how I resolved my issues in case it helps anyone else who could use some hand holding like me.

 

1) Went to the command prompt and did an ipconfig /all to get my server's ip address (mine was 192.168.1.___)

2) Went into the router settings to the port forwarding section

3) Opened two ports, 8096 and 8945, using the ip address from 1). if you modified the default ports during MB Server setup, you can find them again in the server dashboard.

4) Disconnected my VPN

5) Went to http://www.yougetsig...ols/open-ports/ (thanks sfnetwork) to verify that the ports were open, and to get the external IP address

6) Opened the iOS app and entered the ip address from 5) and port 8096

7) Verified that my library appears on the iPhone

8) Re-enabled my server's VPN and verified that the connections still worked

 

I'm still having an issue with audio only working via headphone and bluetooth (not speakers) but I think it's an unrelated problem.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users