Jump to content

Recordings not showing in Emby


iiiJoe
 Share

Recommended Posts

Hello everyone!. Just wondering if I might get some assistance. I'm recording a series and it shows that it's recording in the on now section but it doesn't show as an active recording anywhere else (Home screen section 1 and 2 are set to show active recordings) and is not accessible once the recording is finished. It does show up in the recordings destination folder on my server and can be played from there with Windows media player. It just can't be played in Emby due to not showing as a recording. Any help would be greatly appreciated! Thanks in advance

embyserver.txt recording-conversion-81bcc8e8-cad2-4b2a-9c79-52b9cd2a4b8e_1(2).txt

Link to comment
Share on other sites

Hi, yes this has been reported to happen in some cases and we're looking into it. Thanks.

Link to comment
Share on other sites

Posted (edited)

Thanks for the quick response. Is this just on Windows based servers? Or just series recordings maybe?

 

Edited by iii2405
Link to comment
Share on other sites

It could affect any recording, but it doesn't always happen. So that's what we're looking into. Thanks.

Link to comment
Share on other sites

Another caveat, the recording issue seems to be present only on certain programs on certain channels, at certain times. On one particular channel all programs record just fine all through the day until the 7pm cst time slot. The recording is successful for the first 2 minutes and then stops. The 2 minutes shows in Emby and the destination folder and can be played in Emby, but 2 minutes is it. Interestingly, the IPTV programming is approx 2 minutes behind (I assume the lag is due to the IPTV provider cleaning up the streams). Everything before and after records fine. That same program repeats at midnight and it records without issue. I have verified with another IPTV provider the exact same issue. 

On another channel all programs record successfully at any time of day except for one. That program does not show as an active recording but it does show up in the destination folder (as a TS file) and can be played with a windows based player. It could prob be played with Emby as well if it would show in the recordings tab. I’m happy to share the channels and programs but would prefer to send in dm.

The utility of Emby is incredible and I appreciate all of the work you’ve put into it’s  development. Please let me know your thoughts. 

Link to comment
Share on other sites

seanbuff
1 hour ago, iii2405 said:

It could prob be played with Emby as well if it would show in the recordings tab

Sorry if this is a silly question, but just confirming you have granted your User access to the 'Recordings' library in Library Access?

image.png.908d16ca8893b35f5f7af7c0f5b09c77.png

Link to comment
Share on other sites

Lol, not silly at all! Where would I find this setting? I've looked in Libray, Users, Settings and others tabs. I'm using a windows 10 pc for my server.

Link to comment
Share on other sites

11 hours ago, iii2405 said:

Lol, not silly at all! Where would I find this setting? I've looked in Libray, Users, Settings and others tabs. I'm using a windows 10 pc for my server.

Users -> Click on a User -> Then click on the Access tab at the top.

Link to comment
Share on other sites

On 8/26/2022 at 12:49 AM, iii2405 said:

Another caveat, the recording issue seems to be present only on certain programs on certain channels, at certain times. On one particular channel all programs record just fine all through the day until the 7pm cst time slot. The recording is successful for the first 2 minutes and then stops. The 2 minutes shows in Emby and the destination folder and can be played in Emby, but 2 minutes is it. Interestingly, the IPTV programming is approx 2 minutes behind (I assume the lag is due to the IPTV provider cleaning up the streams). Everything before and after records fine. That same program repeats at midnight and it records without issue. I have verified with another IPTV provider the exact same issue. 

On another channel all programs record successfully at any time of day except for one. That program does not show as an active recording but it does show up in the destination folder (as a TS file) and can be played with a windows based player. It could prob be played with Emby as well if it would show in the recordings tab. I’m happy to share the channels and programs but would prefer to send in dm.

The utility of Emby is incredible and I appreciate all of the work you’ve put into it’s  development. Please let me know your thoughts. 

We'd have to look at a specific example: 

 

Thanks.

Link to comment
Share on other sites

Sorry it’s taken some time to get back. I should have an example tonight. Would you like for me to post here or start a new thread? Thanks!

Link to comment
Share on other sites

1 hour ago, iii2405 said:

Sorry it’s taken some time to get back. I should have an example tonight. Would you like for me to post here or start a new thread? Thanks!

If it's a different issue then a new thread would be ideal. Thanks !

Link to comment
Share on other sites

Luke, here's a recent example of what I've been experiencing on one particular show that comes on at 7pm cst. On this occasion it did not show as an active recording in the active recordings section but did show that it was recording in the guide. It doesn't show as a recorded program in emby and thus cannot be played. It is, however in the destination folder (the full hour minus 1min at the beginning) and can be played from there with my windows player on my pc. This happens with this program virtually every night. I did notice at the end of the log their is no exit command as their is with successful recordings that show in emby. Not sure if that means anything or not. Would appreciate your input. Thank you!

 

recording-conversion-7500b23d-66d0-467f-9266-130bd138124a_1(1).txt embyserver-63797578305.txt

Link to comment
Share on other sites

Hi, Luke. Recording for my show at 7PM actually worked perfectly Tues and Wednesday but had some trouble tonight. The partial recording showed in Emby initially but then disappeared. It is, however, in the destination folder and can be played from there on my pc with a windows based player. I'm attaching the logs. Still enjoying Emby, just wanted to keep the info flowing. Thanks!

recording-conversion-94ed1544-c63b-4e3e-a5d2-bc45819b0e5d_1.txt embyserver-63798267787(1).txt

Edited by iiiJoe
More detail
  • Thanks 1
Link to comment
Share on other sites

It showed in latest recordings on my Home Screen, I clicked on it to see how long it was (19 min) then hit the back button to go back to Home Screen and it was no longer present in latest recordings or the recordings section that you access by clicking on the recordings button on the Home Screen.

Edited by iiiJoe
More detail
Link to comment
Share on other sites

  • 4 weeks later...
Posted (edited)

Not at all. In fact, since the latest update my recordings have been working perfectly. No more 404 disconnection issues with my provider. Not sure if something was tweaked with Emby to work around that problem but I really appreciate the reliability! Thank for for following up!!

Edited by iiiJoe
  • Thanks 1
Link to comment
Share on other sites

Quote

Not sure if something was tweaked with Emby to work around that problem but I really appreciate the reliability!

I wish I could take credit for it, but to be honest, there wasn't. Still I'm glad to hear about the better result. Thanks !

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...