Jump to content

Qsv errors when transcoding on Intel 12th Gen platform


Renyu
 Share

Recommended Posts

Hi, I just assembled a PC to run Emby server, but I came into some problem about transcoding.

The server has a 12400 CPU and three graphic cards: UHD 730 iGPU, Intel DG1 and Nvidia T400. Emby server runs on windows server 2022. The server indicates transcoding failed every time I try to use Intel GPU to transcode, but NVIDIA T400 is fine. I have tried the instruction of RDP setting, but the error still exists. To find out the reason, I tried using Intel Qsv transcoding on Handbrake in a RDP session, everything is ok. I also have a N6005 MiniPC, Qsv transcoding is ok on it. So, I think it might be a problem about ffmpeg and Intel Qsv Encoder on Xe/Xe series GPU, including 12th iGPU. Is there any one also came into similar problem?

Link to comment
Share on other sites

Hello Renyu,

** This is an auto reply **

Please wait for someone from staff support or our members to reply to you.

It's recommended to provide more info, as it explain in this thread:


Thank you.

Emby Team

Link to comment
Share on other sites

Happy2Play

Can you post ffmpeg logs for an example.

What are your Transcoding settings?

But may be related to RDP session.  Is this a headless server?

https://support.emby.media/support/solutions/articles/44001160185-hardware-acceleration-on-windows#:~:text=Intel Media SDK.-,Remarks,-Emby only supports

Have you tried this?

Hardware Video Acceleration Fails with Remote Desktop (RDP) on Windows : (emby.media)

 

@rbjtechHave any ideas?

Link to comment
Share on other sites

Hmm - the DG1 is the obvious unknown here ..

This could be really interesting - as this is effectively what I'm looking to do very soon with the A380 (dGPU from Intel).    This may be trying to use intel 'deep link' drivers that are effectively trying to split the encoding/decoding workload across the iGPU and dGPU. 

I was also under the impression that the DG1 only 'works' in specialist motherboards - it is not a generic plug and play GPU.. ?

The UHD770 on it's own (in my case) works extremely well as a dec/enc QSV transcoder - so that is not the issue here.

Ensure you have installed the native Intel drivers - do not use the built in MS ones.

RDP 'should' not make any difference - I use RDP on my server with a UHD770 and it works just fine.  Same with a much older UHD iGPu and Nvidia GTX 1070 - all work fine via RDP.  @softworkz can confirm - but I don't think RDP is an issue anymore.

Can you provide the ffmpeg log - as it should show all the hardware that you have available and what it is trying to use ?

It would also be worth screen grabbing how you have configured the 'advanced' transcoding settings.

Thanks.

--

These are my QSV settings -

 

image.thumb.png.433ce572c8f79131f1d9c67d37cf5ebc.png

Edited by rbjtech
Link to comment
Share on other sites

@Renyu - Please post the hardware detection log.

Xe Max is untested at this time, but you should at least be able to use the iGPU graphics.

Link to comment
Share on other sites

justinrh
22 hours ago, Happy2Play said:

But may be related to RDP session.  Is this a headless server?

@Happy2Play Did you read the OPs post?  Does that answer your question?

Link to comment
Share on other sites

On 8/25/2022 at 6:10 AM, justinrh said:

@Happy2Play Did you read the OPs post?  Does that answer your question?

 

On 8/24/2022 at 7:29 AM, Happy2Play said:

Can you post ffmpeg logs for an example.

What are your Transcoding settings?

But may be related to RDP session.  Is this a headless server?

https://support.emby.media/support/solutions/articles/44001160185-hardware-acceleration-on-windows#:~:text=Intel Media SDK.-,Remarks,-Emby only supports

Have you tried this?

Hardware Video Acceleration Fails with Remote Desktop (RDP) on Windows : (emby.media)

 

@rbjtechHave any ideas?

I will post  a transcoding log once I get connected to my server, it shut down at home and I’m on a trip😂

Link to comment
Share on other sites

On 8/25/2022 at 12:27 AM, softworkz said:

@Renyu - Please post the hardware detection log.

Xe Max is untested at this time, but you should at least be able to use the iGPU graphics.

Unfortunately, iGPU cannot work…An interesting thing is that iGPU and DG1 GPU’s decoding function is good, If I select hardware decoding and CPU encoding, everything is fine. But once I choose iGPU to encode, no matter what kind of decoding method, the transcoding thread fails.

Link to comment
Share on other sites

The server I use is a headless PC, but I plugged a virtual HDMI output in it. Once I get the log, I will post it here. Thanks for all your help.

  • Thanks 1
Link to comment
Share on other sites

Please also post an ffmpeg log showing iGPU encoding failure.
Thanks

Link to comment
Share on other sites

  • 2 weeks later...

@Renyu

Thanks for the logs. It's always better to choose encoders and decoders of the same type. In the first example, the Nvidia decoder should not have been selected in combination with the QSV encoder.

Could you please post the hardware_detection log?

The second case is a bit doomed due to the gigantic about of subtitles. Could you try the second case with the file from the first one?

Thanks,
sw

Link to comment
Share on other sites

No, the same error

3 minutes ago, softworkz said:

Does it work when you do not select subtitles for playback?

10:33:06.079 [h264_qsv @ 000001702de700c0] Error during encoding: device failed (-17)
10:33:06.079 Video encoding failed
10:33:06.111 Conversion failed!
Link to comment
Share on other sites

3 minutes ago, Renyu said:

But the graphic driver I'm using now is the latest version

Is it the same I posted?

3 minutes ago, Renyu said:

I have also tried serveral history graphic driver...none of them work.

On Linux, there are huge issues with Gen12 graphics drivers as well, so the only way is forward not backward 🙂 

Link to comment
Share on other sites

2 minutes ago, softworkz said:

31.0.101.3413

Yes, it's this one. I just installed 2 days ago.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...