Jump to content

Tracks belonging to the same album added to different albums.


MartinCheetham
 Share

Go to solution Solved by Luke,

Recommended Posts

MartinCheetham

I have a couple of tracks which belong to the same album but EMBY puts them into separate albums.  Generally when this has happened in the past I have figured it out as there was some tag which was different.  In this case I have looked at all the tags (including the hidden ones) and can see no obvious reason why these tracks have been put in different albums (with the same name).  The only difference that I can see is that one track is a .mp3 the other is an .aac.  Admittedly this is an unusual situation but I don't see why this should cause the tracks to be put in different albums.

Link to comment
Share on other sites

Hi there, are they tagged with the same album and album artist values? That's what you need for them to be grouped as an album.

Link to comment
Share on other sites

MartinCheetham

Yes - as far as I can tell the relevant tags are identical.  I'm attaching some images.  Perhaps you can see something I've missed.  MP3TAG of the two tracks, images of the extended tags and finally of the EMBY music library.

Extended Tags1.jpg

Extended Tags2.jpg

MP3TAG Image.jpg

EMBY Library.jpg

Link to comment
Share on other sites

  • Solution

What do you see in the emby metadata editor for each track? That will be the easiest way to spot the differences.

Link to comment
Share on other sites

MartinCheetham

OK - good call.  The album name was truncated for one track.  I fixed that and now all is OK.  I am baffled though as the tags for both tracks have the full album name and I have rescanned the library many times since spotting this.  Perhaps just changing a tag doesn't force EMBY to rescan the metadata for the track?

Link to comment
Share on other sites

On 7/28/2022 at 12:39 PM, MartinCheetham said:

OK - good call.  The album name was truncated for one track.  I fixed that and now all is OK.  I am baffled though as the tags for both tracks have the full album name and I have rescanned the library many times since spotting this.  Perhaps just changing a tag doesn't force EMBY to rescan the metadata for the track?

Hi, it does. A normal library scan should have picked up the changes, assuming the date modified timestamp of the audio file has also changed.

Thanks for the feedback.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...