Jump to content

can't find database reset option in addon menu


mooncaptain
 Share

Go to solution Solved by quickmic,

Recommended Posts

mooncaptain

 

Running emby 4.7.5.0 on Ubuntu/RPI

Kodi 19.4.0 - on Windows 10

Emby-next-gen 6.2.20

I did find this link but I didn't find the new reset location that was described

https://emby.media/community/index.php?/topic/68116-latest-emby-beta-for-kodi-how-to-reset-database/

  1. using estuary skin
  2. select Add-ons from gear icon
  3. select My add-ons
  4. select Video Add-ons
  5. I have two options here
    Emby-next-gen
    Library Data Provider
  6. select Emby-next-gen
  7. image.png.fe75c7aff69b781fdd85d6c387ace957.png

I don't see a reset database option here and database reset option isn't  on the Configure Menu.

Link to comment
Share on other sites

  • Solution
quickmic

"Configure" -> "Sync" -> "Perform local database reset"

Link to comment
Share on other sites

mooncaptain
Posted (edited)

Duh.

 

Thanks,

Cheers

I can now reset the database from the user interface in Kodi.

However, this reset sequence requires  more steps.

  1. Emby Settings
  2. Sync / Reset
    Automatically shuts down and
    - on libreelec restarts
    - on windows requires manual restart
  3. Emby welcomes me back but does nothing
  4. Navigate to video add-ons /Emby-next-gen
  5. Select Configure
  6. Connect to Server - do several steps including typing in password
  7. Select libraries / Select OK
  8. Manually shutdown Kodi.
  9. Restart Kodi
  10. Database refreshes REALLY FAST

In the version I updated from especially on libreelec I selected reset answered a few questions and the system restarted. Then I answered a few more questions and the database reloaded, but more slowly.

Or am I missing some step or not waiting long enough after the first shutdown?

Edited by mooncaptain
  • Like 1
Link to comment
Share on other sites

quickmic
1 hour ago, mooncaptain said:

Duh.

 

Thanks,

Cheers

I can now reset the database from the user interface in Kodi.

However, this reset sequence requires  more steps.

  1. Emby Settings
  2. Sync / Reset
    Automatically shuts down and
    - on libreelec restarts
    - on windows requires manual restart
  3. Emby welcomes me back but does nothing
  4. Navigate to video add-ons /Emby-next-gen
  5. Select Configure
  6. Connect to Server - do several steps including typing in password
  7. Select libraries / Select OK
  8. Manually shutdown Kodi.
  9. Restart Kodi
  10. Database refreshes REALLY FAST

In the version I updated from especially on libreelec I selected reset answered a few questions and the system restarted. Then I answered a few more questions and the database reloaded, but more slowly.

Or am I missing some step or not waiting long enough after the first shutdown?

In 7.x versions there is another option called factory reset which removes everything.

 

 

 

Link to comment
Share on other sites

quickmic
1 hour ago, mooncaptain said:

Or am I missing some step or not waiting long enough after the first shutdown?

Once shutdown, no need to wait, but the database reset is very slow. It removes only Emby related records (lot of queries). The factory reset (in 7.x) will wipe everything and is much faster.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...