Jump to content

Playing 4k content via Chromecast with Google TV connected to 1080P TV


altramarine
 Share

Recommended Posts

altramarine

Good day,

I have a general (and rather silly) question: What to expect from playing 4K content using Chromecast with Google TV device connected to a 1080p capable TV?

  • Does Emby need to transcode?
  • Is Chromecast device capable of downscaling?

In Chromecast app, with default streaming bitrate, the 4K content is struggling to play (I see one frame update every ~5 seconds). Server management dashboard also reports playback errors.
If I drop down the app streaming bitrate low enough, Emby starts to transcode and content is playable BUT with god awful quality.
Is it a Chromecast device issue?

Thank you!

 

 

Link to comment
Share on other sites

5 hours ago, altramarine said:

In Chromecast app

Hi.  Are you "casting" to the device or running our Android TV app?

  • Like 1
Link to comment
Share on other sites

altramarine
Posted (edited)
2 hours ago, ebr said:

Hi.  Are you "casting" to the device or running our Android TV app?

Hi Ebr, thanks for reply.
Not casting, I am using the Android TV app.

Edited by altramarine
Link to comment
Share on other sites

RanmaCanada

The Emby server if it's underpowered will choke and die as it attempts to transcode and possibly tone map the content down.  Friends don't let friends transcode 4k content.  Buy a 4k capable TV or stop trying to play 4k content.

AFAIK nothing is done on the client, everything is done on the server.  It's why we have a hardware thread where we talk about doing 4k transcodes and how many our servers can handle.  

Link to comment
Share on other sites

altramarine
Posted (edited)
On 6/26/2022 at 12:30 PM, Luke said:

My sincere apologies for the delay @Luke@ebr

Here is the link to the emby and trans-code logs. Also attached is the screenshot of the error I see in the Emby management right after Emby falls back to intermittent transcoding (after failing with Direct Play). Time stamp: 2022-06-27 23:23:22.809

 

Virtual server specs: 8 VCores, 8GB, SSD
OS: CentOS 7.9.2009
Emby: 4.7.4.0
Client Device: Google Chromecast with Google TV: AndroidTV 2.0.70g

 

@RanmaCanadaEmby attempts to Direct Play initially so I do not believe it is the server hardware issue. I generally do not have any issues with transcoding, plenty of power for that.

 

Edited by altramarine
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...