Jump to content

Emby 4.7.1.0 iMac server - TV show not indexing by server


Mendocinotim
 Share

Go to solution Solved by Mendocinotim,

Recommended Posts

Mendocinotim

Please have a look at the attached screen shot.

Here's what's happening..
I just added a new TV show to my TV Shows directory on my iMac, and told Emby server to index TV Shows.
The name of the new show (according to IMDB - copied and pasted into the associated file and folder names) is "NCIS: Hawai'i".

Note the apostrophe between the "i"'s.
Mac OS doesn't allow colons in finder names - it always substitutes them with a forward slash - see the NCIS Losangeles example in the screenshot (it indexes just fine).

Also note that I tried two variations: "NCIS Hawai'i" and "NCIS Hawaii".
I also tried "NCIS/ Hawai'i" and "NCIS/ Hawaii" - not shown in the screenshot (these did not index either).

Can you offer any suggestions or help in this matter?

Many thanks in advance.
PS: I am an Emby premier lifetime member.

NCIS Hawaii vs Hawai'i not indexing in Emby server.jpg

Link to comment
Share on other sites

Hi, are you saying you have a / in the folder name, or is there a parent ncis folder?

Link to comment
Share on other sites

Happy2Play

Never seen naming scheme like that, colon always replaced with space or comma not /.

Is the series not identified or is it mis-identified and merger into something else?

But we would need to see the server log for when this series was added to Emby.

Link to comment
Share on other sites

Mendocinotim
30 minutes ago, Luke said:

Hi, are you saying you have a / in the folder name, or is there a parent ncis folder?

Yes - just as is shown in the screenshot of the actual iMac Finder - it always substitutes the original ":" with a "/" in the file and folder name.
And as I have pointed out, this is never a problem from the PLex server side - however, it is with Emby.

My suspicion is that it is not the "/" causing the issue - i'm willing to bet it is caused by the apostrophe in Hawai'i. (between the two i's) - that's the one characteristic that sets it appart from all the other NCIS shows in my library.

BTW: I'm new to Emby. I'm enclosing a screenshot of the recent Emby logs. I searched all the logs from today for NCIS. Nothing found! 
I also searched the iMac's Console for NCIS - agan, nothing there.

Perhaps you can tell me which logs you want me to send you, and I will be happy to do so.

Thanks again.

2022-05-26_15-44-18.jpg

Link to comment
Share on other sites

Mendocinotim

To answer your question..

"are you saying you have a / in the folder name, or is there a parent ncis folder? "

Yes, there is a / in the folder name.
And there is a parent folder hierarchy as shown  below..

Movies and TV (folder)

        Movies (child folder)

                movie file name.m4p
                another movie file name.m4p
                etc...

        TV Shows (child folder)

                TV Show name (folder)
                        Season 1 (child of child folder)
                                Show Name Sn01En01.m4p
                                Show Name S01E02.m4p
                                Etc..

                        Season 2 (child of child folder)

 

I hope this clarifies your query.

Link to comment
Share on other sites

Happy2Play

I guess since that is an illegal character in Windows is why I have never seen it used before.  So it is impossible for me to even test this.  But still don't see it playing well across the board.

Link to comment
Share on other sites

Mendocinotim

I did try it by ommiting the / in the flae and folder names as well - again no joy.
But the / works fine for NCIS/ Los Angeles and NCIS/ New Orleans - just not for NCIS/ Hawai'i

I just tried using the exact same folder and file naming conventions that work for NCIS Los Angeles and NCIS New Orleans..
Then I told Emby server to interrogate the TV Shows folder again.
As previously described, this did not work.
The only outstanding difference between tose that work and the one that doesn't is the i'i in Hawai'i..

Screenshot attached

2022-05-26_16-14-11.jpg

Link to comment
Share on other sites

Happy2Play

All I can say is "NCIS, Hawai'i (2021)" without issue here.  And all we can do is guess that these episodes are being multi-versioned into one of the existing NCIS series or something else.

As for logs we would need to see the log for when you imported Hawai'i, or even just adding and episode for that series.

Link to comment
Share on other sites

Mendocinotim

Regarding the log question, perhaps I did not make my question clear..

There are numerous Emby log files, all for the same day that I imported (that is to say "added") the episodes onto the computer, and there are the Mac log files (viewable in agregate form using the utility app "Console" that comes with every Mac). I did not understand which logs you wanted for the day in question, Emby or Mac logs? There are numerous Emby logs, all from the same day - and as I am not yet familiar with which of those, or do you want all, you want - I was hoping for clarification. Here again is a screenshot of all the Emby logs - as you can see, there are multiples from the same day. I added NCIS Hawai'i to the computer today, at about 7 or 7:30am.

2022-05-26_15-44-18.jpg

Link to comment
Share on other sites

Mendocinotim

I appreciate all the comments here.

Unfortunately - possibly because I am using a Mac instead of a PC to host my Emby server - no one here can offer any helpful solutions.
I will have to tell my members to use Plex for NCIS Hawai'i, as it does not seem to have this problem.
That saddens me.  😒  As I am trying to break away from Plex (too much bloat there - it has become unstable).
I like Emby because it is not so corporate. I know it's kinda new and still working out the kinks.
I'm here to stay though.. 😉

Link to comment
Share on other sites

Happy2Play
5 minutes ago, Mendocinotim said:

Regarding the log question, perhaps I did not make my question clear..

There are numerous Emby log files, all for the same day that I imported (that is to say "added") the episodes onto the computer, and there are the Mac log files (viewable in agregate form using the utility app "Console" that comes with every Mac). I did not understand which logs you wanted for the day in question, Emby or Mac logs? There are numerous Emby logs, all from the same day - and as I am not yet familiar with which of those, or do you want all, you want - I was hoping for clarification. Here again is a screenshot of all the Emby logs - as you can see, there are multiples from the same day. I added NCIS Hawai'i to the computer today, at about 7 or 7:30am.

2022-05-26_15-44-18.jpg

Every day at midnight a new log is recreated and every server restart creates a new log, embyserver.txt is the current log.

Hopefully a log will show what it is doing, but currently am guessing it is multi-versioning into one of the other NCIS shows.

Link to comment
Share on other sites

Mendocinotim
4 minutes ago, Happy2Play said:

Every day at midnight a new log is recreated and every server restart creates a new log, embyserver.txt is the current log.

Hopefully a log will show what it is doing, but currently am guessing it is multi-versioning into one of the other NCIS shows.

Here are the Two log files for today - one from before I updated to the latest public release from the beta, and the other from after I updated.
I was processing the Hawai'i files across both. Hopefully you will be able to find the issue - but as I already stated, I did perform a search on bot, and there was nothing with "NCIS" there that I could find.

embyserver-63789150082.txt embyserver-63789150022.txt

Link to comment
Share on other sites

Happy2Play
Posted (edited)

The log ending 0082 shows the database is locked, but yes neither of these logs show anything related to NCIS or every the item paths.

2022-05-26 11:48:02.041 Error ProviderManager: Error refreshing item
	*** Error Report ***
	Version: 4.7.1.0
	Command line: /Applications/EmbyServer.app/Contents/MacOS/EmbyServer.dll
	Operating system: Darwin 19.6.0 Darwin Kernel Version 19.6.0: Mon Apr 18 21:50:40 PDT 2022; root:xnu-6153.141.62~1/RELEASE_X86_64
	Framework: .NET 6.0.5
	OS/Process: x64/x64
	Runtime: Applications/EmbyServer.app/Contents/MacOS/System.Private.CoreLib.dll
	Processor count: 8
	Data path: /Users/w3/.config/emby-server
	Application path: /Applications/EmbyServer.app/Contents/MacOS
	SQLitePCL.pretty.SQLiteException: Busy: database is locked
	SQLitePCL.pretty.SQLiteException: Exception of type 'SQLitePCL.pretty.SQLiteException' was thrown.
	   at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc)
	   at SQLitePCL.pretty.StatementImpl.MoveNext()
	   at Emby.Server.Implementations.Data.SqliteItemRepository.GetUserDataKeyId(String userDataKey, IStatement insertUserDataKeyStatement, IStatement getUserDataKeyStatement)
	   at Emby.Server.Implementations.Data.SqliteItemRepository.SaveItemsInTranscation(IDatabaseConnection db, List`1 tuples, MetadataRefreshOptions metadataRefreshOptions)
	   at Emby.Server.Implementations.Data.SqliteItemRepository.SaveItems(List`1 items, MetadataRefreshOptions metadataRefreshOptions, Action`1 afterSave, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.Data.SqliteItemRepository.SaveItems(List`1 items, MetadataRefreshOptions metadataRefreshOptions, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.Library.LibraryManager.CreateItems(List`1 items, BaseItem parent, MetadataRefreshOptions metadataRefreshOptions, CancellationToken cancellationToken)
	   at MediaBrowser.Controller.Entities.Folder.ValidateChildrenInternal(IProgress`1 progress, CancellationToken cancellationToken, Boolean recursive, Boolean refreshChildMetadata, MetadataRefreshOptions refreshOptions, IDirectoryService directoryService)
	   at Emby.Providers.Manager.ProviderManager.RefreshItem(BaseItem item, MetadataRefreshOptions options, CancellationToken cancellationToken)
	   at Emby.Providers.Manager.ProviderManager.StartProcessingRefreshQueue()
	Source: SQLitePCL.pretty
	TargetSite: Void CheckOk(SQLitePCLEx.sqlite3, Int32)

As for this log all I can do is ask if your current logs shows the same error?  It is minor as it means the database was not close correctly on the last shutdown and the new session can not take control of the database.  If new server log shows the same error you will have to perform the steps in the kb to unlock the database.

See "Remove Database Locks" section

As for NCIS Hawai'i all I can suggest if removing the show from your library, perform a library scan.  Restart Emby or go to scheduled tasks and rotate server log, then readd this show and if it still does not show up provide this server log.

 

 

Edited by Happy2Play
Link to comment
Share on other sites

Mendocinotim

I will have to wait until tomorrow morning, when all my users know I perform server maintenance and are not using Emby.
I will follow you suggestions then, and will get back to you here after I'm done doing so.

Thank you so much for your kind assistance.

Link to comment
Share on other sites

Happy2Play
Posted (edited)
6 minutes ago, Mendocinotim said:

I will have to wait until tomorrow morning, when all my users know I perform server maintenance and are not using Emby.
I will follow you suggestions then, and will get back to you here after I'm done doing so.

Thank you so much for your kind assistance.

Can you check the current embyserver.txt for this error it will have no effect on your users.  If the log will be flooded with this error, all your current user activity will be lost as it can not be written.

Edited by Happy2Play
Link to comment
Share on other sites

Mendocinotim

Yep - it's flodded with "SQLitePCL.pretty.SQLiteException: Busy: database is locked".

I'll let them know I have to fix it now.
Be back to you once the work is done - shortly. 😉

Link to comment
Share on other sites

Mendocinotim

Am unable to view the DB using DB Browser SQLite - see attached animated gif.

2022-05-26_18-32-13 (1).gif

Link to comment
Share on other sites

Mendocinotim

I will try using terminal instead

BRB

Link to comment
Share on other sites

Mendocinotim

No Joy..

-iMac:data w3$ pwd
/Users/w3/.config/emby-server/data
iMac:data w3$ sqlite3 library.db "PRAGMA integrity_check"
Error: database is locked
iMac:data w3$

 

 

 

 

 

 

 

 

 

 

Link to comment
Share on other sites

Happy2Play
11 minutes ago, Mendocinotim said:

Am unable to view the DB using DB Browser SQLite - see attached animated gif.

2022-05-26_18-32-13 (1).gif

 

10 minutes ago, Mendocinotim said:

I will try using terminal instead

BRB

 

6 minutes ago, Mendocinotim said:

No Joy..

-iMac:data w3$ pwd
/Users/w3/.config/emby-server/data
iMac:data w3$ sqlite3 library.db "PRAGMA integrity_check"
Error: database is locked
iMac:data w3$

 

 

 

 

 

 

 

 

 

 

You have to shutdown Emby then delete the shm and wal files.  When those files exist the database is already open and locked.  Per your animation you should see those files if you scroll down further.

Link to comment
Share on other sites

Mendocinotim

So I moved on to the recover step and got an error..

Last login: Thu May 26 18:44:10 on ttys000
-bash: /Users/w3/.profile: No such file or directory

The default interactive shell is now zsh.
To update your account to use zsh, please run `chsh -s /bin/zsh`.
For more details, please visit https://support.apple.com/kb/HT208050.
iMac:data w3$ pwd
/Users/w3/.config/emby-server/data
iMac:data w3$ sqlite3 library.db ".recover" | sqlite3 library-recovered.db
Error: unknown command or invalid arguments:  "recover". Enter ".help" for help
iMac:data w3$ 












I did delete those files first.. see screenshot (did I do it correctly?)

2022-05-26_18-51-13.jpg

Link to comment
Share on other sites

Mendocinotim

I'm not sure that SQLite installed correctly - is there a mac installer that you know of?

 

Link to comment
Share on other sites

Happy2Play
Posted (edited)
5 minutes ago, Mendocinotim said:

I'm not sure that SQLite installed correctly - is there a mac installer that you know of?

 

Not sure but If you start Emby the shm and wal will be recreate and Emby should have control over the database again (check server log).  And if you shut down Emby they should automatically delete.  If they do not automatically delete themselves after Emby shutdown then there is a bigger issue.

Edited by Happy2Play
Link to comment
Share on other sites

Mendocinotim

Well, I just restarted Emby - it is still not indexing the Hawai'i show.

See the latest attached logfile.

I then shut down Emby, and retried opening the library.db file in DB Browser for SQLite.
This time it did open the file, but whay I tried running the PRAGMA integrity_check SQL command it would not let me.
I made a short video to show exactly what I tried here..

 

embyserver-63789188623.txt

Link to comment
Share on other sites

Your log shows a locked database. Make sure to shutdown DBBrowser before starting up Emby Server. 

Emby Server opens the database in exclusive mode - that means no other application can be touching the .db file at the same time.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...