Jump to content

Update 4.6 to 4.7 on Synology RS816 failed


emingy
 Share

Go to solution Solved by emingy,

Recommended Posts

emingy

Hi, I was brave enough to install the 4.7.0.60 update, but cannot start Emby server any longer. This is what I did:

  • Shutdown Emby Server from the web frontend
  • Download emby-server-synology_4.7.0.60_armv7.spk and install via Synology web frontend

Synology logs say "Package [Emby Server] has been successfully updated.", but service is not running. If I go to package manager and click "Run", nothing will happen.

Any help appreciated.

Link to comment
Share on other sites

Hi, is any emby server log created under /var/packages/EmbyServer/var/logs?

Link to comment
Share on other sites

emingy

There is no /var under /EmbyServer. This is all I see:

admin@Datenablage:/$ ls /var/packages/EmbyServer/
conf  etc  INFO  scripts  target

Link to comment
Share on other sites

alucryd

On DSM 7 logs should be in /var/packages/EmbyServer/target/var/logs, I'll start the synology in a couple hours and see if I can reproduce.

Link to comment
Share on other sites

emingy

Thanks alucryd. We're still on DSM6, and there's no /var under /target.

Link to comment
Share on other sites

alucryd
Posted (edited)

Ah! Then logs should be in /volume1/Emby/logs :) There should be an embyserver.txt file there, please share it if there is.

Edited by alucryd
Link to comment
Share on other sites

45 minutes ago, emingy said:

Yes! Here you go.

Well, it ends with "Info Main: Shutdown complete", so it seems nothing was logged about the update.

embyserver-63788828013.txt 4.29 MB · 1 download

Nothing is logged about the update because that's something you do when the server is shut down.

Are you going to update to DSM 7?

Link to comment
Share on other sites

emingy

No, probably not in the near future. We're running another package which is not ready for DSM7 yet.

Link to comment
Share on other sites

emingy

Just wondering: as long as I have a copy of /volume1/Emby, could I try to uninstall and reinstall the package? Should I try to return to the previous version of Emby? If so: where can I get it?

Link to comment
Share on other sites

Cadkey
Posted (edited)
3 hours ago, emingy said:

 

About your problem, have you restarted your Synology, you never know?

Edited by Cadkey
Link to comment
Share on other sites

emingy
25 minutes ago, Cadkey said:

About your problem, have you restarted your Synology, you never know?

Yes, already tried this. Without success, unfortunately.

Link to comment
Share on other sites

Cadkey
Posted (edited)
6 minutes ago, emingy said:

Yes, already tried this. Without success, unfortunately.

You can download beta 4.7.0.40 or wait for 4.8.0.0 beta a few minutes or hours. Uninstalling a version keeps all your settings and database

Edited by Cadkey
Link to comment
Share on other sites

alucryd
Posted (edited)

The beta probably won't help much,  the server is likely segfaulting, there has been a dotnet core upgrade between the previous stable and the current one, not the first time dotnet breaks on older ARMv7 processors. Our usual 'fix' is to migrate the package to mono, if it really is a segfault, of the DSM6 firmware that has become too old for dotnet.

Could you try to run the following as root and post the output?

APP_NAME=EmbyServer
APP_DIR=/var/packages/$APP_NAME/target
APP_DATA_DIR="$(/usr/syno/sbin/synoshare --get Emby | grep Path | awk -F[ '{print $2}' | awk -F] '{print $1}')"
su -s /bin/sh -c "$APP_DIR/bin/emby-server $APP_DATA_DIR" emby

 

Edited by alucryd
Link to comment
Share on other sites

emingy

I guess there's a " missing in the last line? Where?

Link to comment
Share on other sites

54 minutes ago, emingy said:

I guess there's a " missing in the last line? Where?

Hi, can you try to run the command he provided and post the output? Thanks.

Link to comment
Share on other sites

emingy

As I said, I guess there's a typo, but this is what happens:

admin@Datenablage:/$ APP_NAME=EmbyServer
admin@Datenablage:/$ APP_DIR=/var/packages/$APP_NAME/target
admin@Datenablage:/$ APP_DATA_DIR="$(/usr/syno/sbin/synoshare --get Emby | grep Path | awk -F[ '{print $2}' | awk -F] '{print $1}')"
-sh: /usr/syno/sbin/synoshare: Permission denied
admin@Datenablage:/$ su -s /bin/sh -c "$APP_DIR/bin/emby-server $APP_DATA_DIR emby
>
 

Link to comment
Share on other sites

emingy

In the meantime, I read a couple of threads where people fixed problems by downgrading to 4.6.7. I'm super willing to support you in debugging, but I'd also love to have my installation up again soon. Therefore I'd be very glad for a download link to the previous version - I don't have it around anymore. I'm also getting prepared for switching to DSM7, but I'm trying not to break even more stuff.

Link to comment
Share on other sites

emingy

Thanks alucryd! The result is "Segmentation fault (core dumped)"

Also thanks for the link to the previous version. I wasn't able to find it there. I'll give it a try with the downgrade.

 

Link to comment
Share on other sites

emingy

It works! Everything's in place as before. Thank you!

Did I get you right that I could try again after installing DSM7?

Link to comment
Share on other sites

2 minutes ago, emingy said:

 

Did I get you right that I could try again after installing DSM7?

Yes, certainly.

Link to comment
Share on other sites

My main server is a DS218j on DSM6. Is it safe to say I should wait to see how this thread resolves before I try to update to 4.7?

Link to comment
Share on other sites

27 minutes ago, roaku said:

My main server is a DS218j on DSM6. Is it safe to say I should wait to see how this thread resolves before I try to update to 4.7?

I would try it and report your experience. We don't have every single model on hand for testing so some things we just don't find out about until it gets out there.

Link to comment
Share on other sites

FrostByte
On 5/23/2022 at 11:27 AM, emingy said:

Yes! Here you go.

Well, it ends with "Info Main: Shutdown complete", so it seems nothing was logged about the update.

embyserver-63788828013.txt 4.29 MB · 3 downloads

Since Emby is down when the upgrade happens, you can still see details of the update in the Synology package logs.

/var/log/packages/

under that folder you should see logs for every package you've loaded.

Filename will be EmbyServer.log or emby-server.log depending on DSM.

You can open them in notepad.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...