Jump to content

Subtitle confusion


KLF&TLF
 Share

Recommended Posts

KLF&TLF

Hi

i have a question regarding subtitles. I’m trying to watch Ozark S4 pt 2 and need subtitles for the Spanish aspect. If I turn on English it gives me Closed Captions not just the translation. 
 

what should my settings be? 

Link to comment
Share on other sites

Hi, do you already have the subtitles that you need?

Link to comment
Share on other sites

KLF&TLF

This is what I have in Subtitles and Plugins is there anywhere else I need to look?

Screen Shot 2022-05-02 at 1.52.09 pm.png

Screen Shot 2022-05-02 at 1.52.47 pm.png

Link to comment
Share on other sites

seanbuff
2 hours ago, KLF&TLF said:

This is what I have in Subtitles and Plugins is there anywhere else I need to look?

What Luke is referring to is if you already have foreign or forced subs for the media in question. If you only have the full subtitle or hearing impaired set - then there is no way Emby will be able to only display subs for the foreign parts.

Forced subtitle tracks are often separate and will need to be obtained for your series, you can use Emby to download them on a per-episode basis, or as part of your TV Show Library settings:

image.png.937f63f9c33276e2a5e2b899d611f2ab.png


Then I would set your Subtitle Mode for your user back to 'Smart' and you should be good to go.

Link to comment
Share on other sites

KLF&TLF

I have that and I’ve been ducking around all afternoon looking at solutions in Emby, Plex and VLC and keep hitting my head against the wall and thinking keep learning Spanish 

Link to comment
Share on other sites

seanbuff

Can you maybe show us a screenshot of the subtitles you have for one of the episodes in question, you should have something like this:

image.png.1e54ee8112a00d0bad99be60f2e9147a.png

image.png.24e5d87faa2597d8c4077a92f82cac16.png

A 'forced' sub will be separate to the complete one, and should be marked 'Forced' in order for it to be shown always.

The subtitle can be marked 'Forced' if embedded in the video file itself using something like MKVtoolnix

Otherwise, if it is external, the correct naming of the file should match the episode name, and be appended with the language and .forced.srt

Example:

Ozark - S03E10 - Episode 10 BluRay-1080p.mkv
Ozark - S03E10 - Episode 10 BluRay-1080p.en.forced.srt

 

Please refer to the KB for more information:
https://support.emby.media/support/solutions/articles/44001159160-subtitles

 

30 minutes ago, KLF&TLF said:

and thinking keep learning Spanish

this is also not a bad idea 🙂

Link to comment
Share on other sites

KLF&TLF

OK nope I don't have that option, so I am downloading the incorrect file then? 

So thinking about what you are showing I have something similar with Queen of the South files but my Subtitle options aren't forced? So have I screwed up (happy for you to say hell yeah you have) 

Screen Shot 2022-05-03 at 5.00.16 pm.png

Screen Shot 2022-05-03 at 5.02.41 pm.png

Screen Shot 2022-05-03 at 5.04.08 pm.png

Screen Shot 2022-05-03 at 5.04.18 pm.png

Link to comment
Share on other sites

seanbuff

You haven't screwed up, but in general Forced subs can be harder to source if they don't already come embedded with your media. Or ripped correctly from disc.

Having tried searches for both Ozark and Queen of the South for 'Forced' only subs, yields no results (using the default Open Subtitles)

image.png.9d9bb8d3682c814f8a6ed03e0a3613d5.png

image.png.f6bc2c07fb89a619cdfd72258630701c.png


You could possibly try using another subtitle source via one of the other plugins
image.png.34cb933f4eebb9f8bf1621555244a186.png

Link to comment
Share on other sites

KLF&TLF

Well lets make matters worse Open Subs won't open for me to create an account with as their certificate is expired. But I have them as my subs. I downloaded from here and created a folder for my SRT files for season 4 because QoS worked perfectly but not Ozark from here  - https://australiapopulation.com/ozark-season-4-subtitle/

I did have all the subtitle plugins installed but deleted them to see if that was my issue. Is there one you would choose first to try?

Link to comment
Share on other sites

seanbuff
1 hour ago, KLF&TLF said:

Open Subs won't open for me to create an account with as their certificate is expired

Try their new site, they are migrating to a new .com website

https://www.opensubtitles.com/en

Link to comment
Share on other sites

KLF&TLF

Thanks for the link I was able to create an account and subscribed hoping that will help me. I have changed my Subtitle back to Smart, so am I best to download files without subs or with? Because watching Mayans last night my subs were hardcoded so my headache didn't exist but as you said Ozark is a whole other story. 

Link to comment
Share on other sites

Quote

I have changed my Subtitle back to Smart

This is your subtitle playback setting and is not related to automated downloading, just FYI. Automated downloading is something you setup in Emby library setup.

Please let us know if this helps. Thanks.

Link to comment
Share on other sites

KLF&TLF

Well I have done something right somewhere as I was watching something last night and I went "ooh look Emby they are white, drop shadow etc and I didn't need to do anything" So I think I can successfully say my Subtitles issue is resolved minus Ozark 

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...