Jump to content

Where did the "remember" check box go...


diaz1510
 Share

Recommended Posts

diaz1510

In the auto-organize pop up when manually adding the show to an existing one (creating a Smart Match)?  It used to have a check box down at the bottom...where I made the red circle...

@chef

Running Emby v4.6.7.0 and Auto-Organize v1.6.0.0

Untitled.jpg

Edited by diaz1510
Link to comment
Share on other sites

I've sent you an invite to the PM.

A lot has changed since the last publically posted version of this plugin. :) 

We'll soon make another public release, but handling the file system is such a mammoth task that it has to be done correctly, and it can be very difficult. 

Look forward to seeing you on the PM. :) 

 

Link to comment
Share on other sites

22 minutes ago, diaz1510 said:

anybody?

Hi, did you read the previous response?

Link to comment
Share on other sites

diaz1510
Posted (edited)
4 hours ago, Luke said:

Hi, did you read the previous response?

I did and although I've asked the question there multiple times, I'm not getting help.  And since there are only 12 people in that chat...it doesn't look like I will get my answer there.  so, I'm reverting back here...where more eyes are on it...

It was brought up that an Emby update could've broken the plugin.

Edited by diaz1510
Link to comment
Share on other sites

4 hours ago, diaz1510 said:

I did and although I've asked the question there multiple times, I'm not getting help.  And since there are only 12 people in that chat...it doesn't look like I will get my answer there.  so, I'm reverting back here...where more eyes are on it...

You need to chill a bit.
Your expectations are waayyy tooo high, he is not a paid Emby dev.
@chef is doing all this in his free time and doing the best he possibly can to improve the plugin.

Give him time, he will do some great stuff - already proofed his capabilities many times. 😉

  • Like 1
Link to comment
Share on other sites

Posted (edited)

 

In the original code the remember corrections check-box in the original plugin is hidden by default

https://github.com/chefbennyj1/Emby.AutoOrganize/blob/master/Emby.AutoOrganize/Configuration/fileorganizer.template.html#L49

It is then only shown if the result has a "Name" attached to it, and the Name has a length longer then 3 character.

https://github.com/chefbennyj1/Emby.AutoOrganize/blob/master/Emby.AutoOrganize/Configuration/fileorganizer.js#L199

 

Have you identified the item in the UI by either selecting from existing items:

browser-error_1.thumb.png.2bb4bb01e0a9a9881ca3c04779773fcf.png

 

Or by Pressing the "+" icon to identify the item through the provider?

browser-error_2.png.172cc16515d7f8b055cf841695404987.png

 

Once the item has been identified one of these two ways, and a Name is attached.

The check box will appear, but from what I can see. It will only appear for TV Shows. The option is not available for Movies.

browser-error_3.thumb.png.0e726a430355b2d0582a3c2924a5c5a7.png

 

 

 

browser-error.png

Edited by chef
  • Like 1
Link to comment
Share on other sites

Posted (edited)
On 4/30/2022 at 12:12 AM, diaz1510 said:

In the auto-organize pop up when manually adding the show to an existing one (creating a Smart Match)?  It used to have a check box down at the bottom...where I made the red circle...

@chef

Running Emby v4.6.7.0 and Auto-Organize v1.6.0.0

Untitled.jpg

Your initial image shows that you have not identified the item yet.

It needs a name to remember the correction.

Follow what I have mentioned above.

Choose from an existing items in the drop-down, or use the "+" icon to identify the item.

Once the item has been identified in the UI, the check box will appear.

I hope this helps.

Edited by chef
Link to comment
Share on other sites

diaz1510
8 hours ago, neik said:

You need to chill a bit.
Your expectations are waayyy tooo high, he is not a paid Emby dev.
@chef is doing all this in his free time and doing the best he possibly can to improve the plugin.

Give him time, he will do some great stuff - already proofed his capabilities many times. 😉

No, there was a function that broke. I'm simply asking what version it was that broke so I can roll back to it, so that they can do what they need to do and I can not be impacted.  I frankly don't care for all the silly, over the top updates that broke something that worked.  It worked fine...no changes were necessary.

 

Again....not sure how hard this question is to answer, it isn't rocket science...but what version broke so that I can get my functionality back?

Link to comment
Share on other sites

diaz1510
Posted (edited)
4 hours ago, chef said:

Your initial image shows that you have not identified the item yet.

It needs a name to remember the correction.

Follow what I have mentioned above.

Choose from an existing items in the drop-down, or use the "+" icon to identify the item.

Once the item has been identified in the UI, the check box will appear.

I hope this helps.

OK, simply because I took a screen shot were I didn't "fill in the box" doesn't mean I didn't try that already.  But for the sake of covering my bases for you here you go...

 

items selected...still no check box...

 

now what?

 

Again...WHAT VERSION BROKE SO I CAN ROLL BACK?

Untitled.jpg

Edited by diaz1510
Link to comment
Share on other sites

diaz1510

There's even a possibility that this feature being broke is completely unrelated to the updates that are being performed. I simply don't know, which is why I'm asking.

Link to comment
Share on other sites

1 hour ago, diaz1510 said:

OK, simply because I took a screen shot were I didn't "fill in the box" doesn't mean I didn't try that already.  But for the sake of covering my bases for you here you go...

 

items selected...still no check box...

 

now what?

 

Again...WHAT VERSION BROKE SO I CAN ROLL BACK?

Untitled.jpg

To be honest. I don't know what has changed to break the plugin. The checkbox should appear when the form is filled out.

 

The auto organize plugin from the catalogue hasn't been updated in a long time. 

I would like to see a log, then maybe it might tell me some way to help you.

 

 

 

 

 

Link to comment
Share on other sites

diaz1510
Posted (edited)
2 minutes ago, chef said:

To be honest. I don't know what has changed to break the plugin. The checkbox should appear when the form is filled out.

 

The auto organize plugin from the catalogue hasn't been updated in a long time. 

I would like to see a log, then maybe it might tell me some way to help you.

 

 

 

 

 

So why has my "remember" check box disappeared?  There is nothing to log.  I am not performing a logable action...it SIMPLY ISNT THERE!!!!!!!!!

Geezus...how many different ways do I need to explain?

ITS GONE!

Edited by diaz1510
Link to comment
Share on other sites

1 minute ago, diaz1510 said:

So why has my "remember" check box disappeared?  There is nothing to log.  I am not performing a logable action...it SIMPLY ISNT THERE!!!!!!!!!

Geezus...how many different ways do I need to explain?

ITS GONE!

There could be many reason why the check box doesn't appear.

There could be an error in the web page. There could be an error in the backend.

If I could see a log, then I might be able to track down the error for you, and help you.

 

Link to comment
Share on other sites

Happy2Play
1 minute ago, diaz1510 said:

So why has my "remember" check box disappeared?  There is nothing to log.  I am not performing a logable action...it SIMPLY ISNT THERE!!!!!!!!!

Geezus...how many different ways do I need to explain?

ITS GONE!

Well are you saying is has be broke for a years as that was the last update to the plugin?

 

Link to comment
Share on other sites

diaz1510
2 minutes ago, Happy2Play said:

Well are you saying is has be broke for a years as that was the last update to the plugin?

 

No, that's not what I'm saying at all...I just noticed the other day when trying to manually create a smart match that the "remember" check box is gone. I've used it extensively up until the other day.

 

Hey, I don't really know what's going on here.  I just need some help getting this thing to work.  I made no changes, made no updates, just want this thing to work again.  Why is this such a difficult questions?

Link to comment
Share on other sites

Happy2Play

Because nothing has changed in a year, and no one has reported an issue.  So, all anyone can do is guess and ask you questions.

Is it only an issue for you? or specific to your setup?

Log? 

Browser console errors?

I may have to test this plugin as I don't use Emby for organization I use MediaCenterMaster.

Link to comment
Share on other sites

diaz1510
1 minute ago, Happy2Play said:

Because nothing has changed in a year, and no one has reported an issue.  So, all anyone can do is guess and ask you questions.

Is it only an issue for you? or specific to your setup?

Log? 

Browser console errors?

I may have to test this plugin as I don't use Emby for organization I use MediaCenterMaster.

Maybe...IDK...

That's.Why.I.Came.Here.To.Ask.....

Link to comment
Share on other sites

diaz1510
3 minutes ago, Happy2Play said:

Because nothing has changed in a year, and no one has reported an issue.  So, all anyone can do is guess and ask you questions.

Is it only an issue for you? or specific to your setup?

Log? 

Browser console errors?

I may have to test this plugin as I don't use Emby for organization I use MediaCenterMaster.

 

embyserver.txt

Link to comment
Share on other sites

diaz1510
17 minutes ago, chef said:

There could be many reason why the check box doesn't appear.

There could be an error in the web page. There could be an error in the backend.

If I could see a log, then I might be able to track down the error for you, and help you.

 

 

embyserver.txt

Link to comment
Share on other sites

Happy2Play

I am not seeing anything really in the server log.  (OT: there is an issue with ytrailers)

Are there any browser console errors?

Quick test in 4.6.7.0 with v1.6.0.0 and don't see an issue.  Only error I see is for the throbber.gif.

image.png.4a8a25edfbf1211c224dac71ecb8f809.png

Link to comment
Share on other sites

diaz1510
Posted (edited)

Well, I think I solved it...and could've identified a crack in the armor that is Auto-Organize.

It's the 3-letter name limitation.  As an average user, I had no idea about this limitation.

I have been wondering why this "broke" all of a sudden and after reading the earlier response by @chef I remember the show "Undone" that I am trying to Auto-Organize, only had a single letter "U" in this version.

Untitled.jpg.b5debeeccddf71e966f24a282f3bf2d9.jpg

I changed the name in my watched folder to make it longer than 3 letters and the "remember" box showed up.

This doesn't happen often, but from time to time, it does and I never put 2 and 2 together until just now.

My suggestion: Either place a short set of instructions in the smart match window or change the limit down to a single digit/letter (I realize that may cause other issues, so it may not be feasible). Or, just leave that "Remember" box there all the time. No idea why it has to be hidden.

6 hours ago, chef said:

 

In the original code the remember corrections check-box in the original plugin is hidden by default

https://github.com/chefbennyj1/Emby.AutoOrganize/blob/master/Emby.AutoOrganize/Configuration/fileorganizer.template.html#L49

It is then only shown if the result has a "Name" attached to it, and the Name has a length longer then 3 character.

https://github.com/chefbennyj1/Emby.AutoOrganize/blob/master/Emby.AutoOrganize/Configuration/fileorganizer.js#L199

 

Have you identified the item in the UI by either selecting from existing items:

browser-error_1.thumb.png.2bb4bb01e0a9a9881ca3c04779773fcf.png

 

Or by Pressing the "+" icon to identify the item through the provider?

browser-error_2.png.172cc16515d7f8b055cf841695404987.png

 

Once the item has been identified one of these two ways, and a Name is attached.

The check box will appear, but from what I can see. It will only appear for TV Shows. The option is not available for Movies.

browser-error_3.thumb.png.0e726a430355b2d0582a3c2924a5c5a7.png

 

 

 

browser-error.png

 

Edited by diaz1510
  • Like 3
Link to comment
Share on other sites

vaise
2 hours ago, Happy2Play said:

MediaCenterMaster

Wow! That's a blast from the very distant past Happy!  I cant remember when I stopped using that (or even why I did), Many many years ago - probably when I discovered the 'arr's and usenet I suspect .....

Link to comment
Share on other sites

Posted (edited)

I have removed the three letter naming restriction from an upcoming release of the expanded version.

I'm sure there was a reason why that logic was there. Probably because the Library manager was unable to parse a name when it only contained on letter... Which makes sense.

Emby has naming condition to consider when attempting to have it understood in the server.

The expanded version will tell you both in the logs and in the UI the reason why (exactly) the items couldn't be sorted.

Parsing the name of the file being one of them. 

This is something that the original version didn't do as indepth as the expanded version.

I understand the frustration of not being able to identify the issue at hand.

I've definitely put a lot of time into simplifying the outcomes of sorting files in the expanded version.

My hopes are that we have something to release soon. It is very close to being great!

Hope to see you all on the thread when it is released.

 

-Chef

 

Edited by chef
  • Like 1
Link to comment
Share on other sites

Posted (edited)
5 hours ago, diaz1510 said:

Well, I think I solved it...and could've identified a crack in the armor that is Auto-Organize.

It's the 3-letter name limitation.  As an average user, I had no idea about this limitation.

I have been wondering why this "broke" all of a sudden and after reading the earlier response by @chef I remember the show "Undone" that I am trying to Auto-Organize, only had a single letter "U" in this version.

Untitled.jpg.b5debeeccddf71e966f24a282f3bf2d9.jpg

I changed the name in my watched folder to make it longer than 3 letters and the "remember" box showed up.

This doesn't happen often, but from time to time, it does and I never put 2 and 2 together until just now.

My suggestion: Either place a short set of instructions in the smart match window or change the limit down to a single digit/letter (I realize that may cause other issues, so it may not be feasible). Or, just leave that "Remember" box there all the time. No idea why it has to be hidden.

 

The reason it checks for three letters in a name, is for instances where you are trying to parse a name like "u"...  because "u" is not a name.

Please take a moment to  read the Emby wiki about proper name conventions. Also please take a moment to read "How to Report a problem" as well. This will help you best understand how to manage your emby server.

Best of luck. 

Edited by chef
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...