Jump to content

Error "Thumbnail set not found"


DooDafiit
 Share

Recommended Posts

DooDafiit

 Hi guys, 

I have the problem that several episodes from several tv series take veeery long time to start.

For example:
- episode x from tv series y tooks up to 90 seconds to start. Episode x has a filesize of approx 800MB.
- episode x2 from tv series y2 starts immediatly. Epsiode x2 has a filesize of approx 4000 MB.

Ich checked the log when I ran episode x and I saw the following error:

2022-04-27 10:38:19.342 Error Server: Error processing request
	*** Error Report ***
	Version: 4.6.7.0
	Command line: /usr/local/lib/emby-server/system/EmbyServer.exe -os freebsd -ffmpeg /usr/local/bin/ffmpeg -ffprobe /usr/local/bin/ffprobe -programdata /var/db/emby-server -updatepackage emby-server-freebsd_{version}_amd64.txz
	Operating system: Unix 12.2.14.0 
	Framework: Mono: 6.8.0.123 (tarball Wed Apr  6 16:52:25 UTC 2022)
	OS/Process: X64/X64
	Runtime: usr/local/lib/mono/4.5/mscorlib.dll
	Processor count: 8
	Data path: /var/db/emby-server
	Application path: /usr/local/lib/emby-server/system
	MediaBrowser.Common.Extensions.ResourceNotFoundException: MediaBrowser.Common.Extensions.ResourceNotFoundException: Thumbnail set not found.
	  at MediaBrowser.Api.Images.ImageService.GetThumbnailImageResult (MediaBrowser.Api.Images.ImageRequest request, System.Int64 positionTicks, System.Int64 itemId, System.Boolean isHeadRequest, System.Nullable`1[T] cacheDuration) [0x00088] in <d4cf71f39be44938a3a539378f888df6>:0 
	  at MediaBrowser.Api.Images.ImageService.GetImage (MediaBrowser.Api.Images.ImageRequest request, System.Int64 itemId, MediaBrowser.Controller.Entities.BaseItem item, System.Boolean isHeadRequest) [0x001ba] in <d4cf71f39be44938a3a539378f888df6>:0 
	  at Emby.Server.Implementations.Services.ServiceController.GetTaskResult (System.Threading.Tasks.Task task) [0x00081] in <0914aad53d214f5093d6e8aa4f5ba4c1>:0 
	  at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync (Emby.Server.Implementations.HttpServer.HttpListenerHost appHost, MediaBrowser.Model.Services.IRequest httpReq, MediaBrowser.Model.Services.IResponse httpRes, Emby.Server.Implementations.Services.RestPath restPath, System.String responseContentType, System.Threading.CancellationToken cancellationToken) [0x001da] in <0914aad53d214f5093d6e8aa4f5ba4c1>:0 
	  at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler (MediaBrowser.Model.Services.IRequest httpReq, System.ReadOnlyMemory`1[T] urlString, System.ReadOnlyMemory`1[T] localPath, System.Threading.CancellationToken cancellationToken) [0x00b8e] in <0914aad53d214f5093d6e8aa4f5ba4c1>:0 
	Source: mscorlib
	TargetSite: Void Throw()

I run Emby Server on FreeBSD and the client apps on several Android and iOS devices -> this bug happens on Android and iOS devices and not in the web player.

Maybe this error relates with the bad loading time.

Link to comment
Share on other sites

Hi there, please attach the complete emby server log. thanks.

Link to comment
Share on other sites

DooDafiit

Okay, I attached the current file. For debugging I activate the debug logging and then I started an episode with bad loading time. After that I saved the log file. Strangely enough there is no thumbnail error now but other errors at a time where nobody used an emby client. Planned tasks should happen at night.

embyserver.txt

Link to comment
Share on other sites

Can you please attach the ffmpeg log as well? Thanks.

Link to comment
Share on other sites

DooDafiit

@Luke

I now think that this is not a problem with the thumbnail issue named in the topic name. I moved to a new topic, this one could be closed.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...