Jump to content

cover art plugin


hjason7812
 Share

Recommended Posts

hjason7812

I was wondering if there is a way to change the look of the photos in the screenshot through cover art plugin?

Because i really would like to be able to change them they look all blah compared to the rest of the pics and thumbs and so on.

Could someone please let me know if there is an easy way to do this or the person who created the cover art plugin please implement these to be allowed to get changed.

 

thank you

Sample emby pictures.png

Link to comment
Share on other sites

GrimReaper

You can select style in Plugin settings>select Profile>Treatments>Thumb. 

Link to comment
Share on other sites

hjason7812
8 hours ago, GrimReaper said:

You can select style in Plugin settings>select Profile>Treatments>Thumb. 

Nope doesn't work for those particular pictures. It's the only ones that aren't in the plug in to be able to get changed. 

Link to comment
Share on other sites

GrimReaper

It does, but there are only three treatments you can choose from. And you can have indicator overlays on movies, not TV shows, though, as episodes show series thumb.

873896870_Screenshot2022-03-16105022.thumb.png.8322fbda24348168cdd8a41cc40f89c7.png

Link to comment
Share on other sites

hjason7812
13 hours ago, GrimReaper said:

It does, but there are only three treatments you can choose from. And you can have indicator overlays on movies, not TV shows, though, as episodes show series thumb.

873896870_Screenshot2022-03-16105022.thumb.png.8322fbda24348168cdd8a41cc40f89c7.png

The only thin thumbs changes is the people in the shows and movies nothing else because I went through everything and changed everything and nothing changes those two sections

Link to comment
Share on other sites

Happy2Play

Looking at images in first post, I believe the issue is you do not have Thumb/landscape images, they appear to be fallback Backdrop images so they are not treated with CA.

If you chose edit images on one of the Movies or Series you do not have a Thumb image correct?

image.thumb.png.1c2f65dd2517c639ad0fdb4f9bba5a6c.png

Link to comment
Share on other sites

hjason7812
On 3/16/2022 at 8:06 PM, Happy2Play said:

Looking at images in first post, I believe the issue is you do not have Thumb/landscape images, they appear to be fallback Backdrop images so they are not treated with CA.

If you chose edit images on one of the Movies or Series you do not have a Thumb image correct?

image.thumb.png.1c2f65dd2517c639ad0fdb4f9bba5a6c.png

Yes I have a primary and backdrop images nothing else though none of that loaded in with the image pull in from the server. 

Link to comment
Share on other sites

Right, CoverArt doesn't process backdrops because they tend to be extremely large and that can cause major performance problems.

Link to comment
Share on other sites

hjason7812
41 minutes ago, Luke said:

Right, CoverArt doesn't process backdrops because they tend to be extremely large and that can cause major performance problems.

And this isn't a picture problem it's a cover art plug-in problem that doesn't change the cover art 

Link to comment
Share on other sites

Happy2Play
1 hour ago, hjason7812 said:

And this isn't a picture problem it's a cover art plug-in problem that doesn't change the cover art 

It is about image processing as it could bring some server to their knees.  So you have to have the appropriate images to be treated by CA.

Link to comment
Share on other sites

hjason7812
11 hours ago, Happy2Play said:

It is about image processing as it could bring some server to their knees.  So you have to have the appropriate images to be treated by CA.

And where do I get those pics from then? Because that's what the cover art is for and the server itself os for not me to go searching for the things it needs it pulled everything else in that it needs just fine except for these two photos it is just weird 

Link to comment
Share on other sites

5 minutes ago, hjason7812 said:

And where do I get those pics from then? Because that's what the cover art is for and the server itself os for not me to go searching for the things it needs it pulled everything else in that it needs just fine except for these two photos it is just weird 

Hi.  The CoverArt plug-in does not provide images.  It just gives "treatments" to the ones you have.  There are many options of obtaining images in the Emby Server but not all items will have all image types available.

Link to comment
Share on other sites

Happy2Play

Currently they only come from FanArt.tv, but will be expanded to TMDB.

You need to ensure FanArt is enabled as a image fetcher for Series and Movies and you have image type selected.

Order will not matter

image.png.74d08438f9a17e98fe2b490d5d6e2231.png

Fetcher settings (ensure Thumb is enabled)

image.thumb.png.03c5aad7d790f899a3ecc19ebe936219.png

Link to comment
Share on other sites

hjason7812
11 minutes ago, Happy2Play said:

Currently they only come from FanArt.tv, but will be expanded to TMDB.

You need to ensure FanArt is enabled as a image fetcher for Series and Movies and you have image type selected.

Order will not matter

image.png.74d08438f9a17e98fe2b490d5d6e2231.png

Fetcher settings (ensure Thumb is enabled)

image.thumb.png.03c5aad7d790f899a3ecc19ebe936219.png

I hate the fanart thing I always deselect that lol. I'll try it though thank you

Link to comment
Share on other sites

Happy2Play
1 minute ago, hjason7812 said:

I hate the fanart thing I always deselect that lol. I'll try it though thank you

Only other option is manually applying Thumb image on all media.

But I guess is a script out there that could copy backdrop to thumb if you just want some random image there instead of properly designed image for that placeholder.

Link to comment
Share on other sites

hjason7812
2 hours ago, Happy2Play said:

Only other option is manually applying Thumb image on all media.

But I guess is a script out there that could copy backdrop to thumb if you just want some random image there instead of properly designed image for that placeholder.

I put fanart on there and scanned the entire library and still nothing new popped up

Link to comment
Share on other sites

Happy2Play
6 minutes ago, hjason7812 said:

I put fanart on there and scanned the entire library and still nothing new popped up

A library scan does not look for anything missing.  You have to Refresh all libraries with Refresh all or Search for Missing.

Link to comment
Share on other sites

hjason7812
4 minutes ago, Happy2Play said:

A library scan does not look for anything missing.  You have to Refresh all libraries with Refresh all or Search for Missing.

That is the same as a library scan is it not? To me that seems like a scan all the library at once is a refresh like you're talking about. But I'll go through each one and refresh then and see if it works. Thanks

Link to comment
Share on other sites

Happy2Play
4 minutes ago, hjason7812 said:

That is the same as a library scan is it not?

No as a library scan does not Refresh metadata of any item, it only looks for changes in media that has already been imported.  Now a New item yes.

Link to comment
Share on other sites

hjason7812
On 3/18/2022 at 4:51 PM, Happy2Play said:

No as a library scan does not Refresh metadata of any item, it only looks for changes in media that has already been imported.  Now a New item yes.

Lol, that's crazy I've had emby for like 10 years almost and I've always thought the library scan pulled everything in. Well after all night long of it running the refresh Metadata on everything it pulled everything in. Thank you for all your help everybody it didn't pull in some quite a few actually idk why but it's Allright. 

  • Thanks 1
Link to comment
Share on other sites

hjason7812
On 3/18/2022 at 4:51 PM, Happy2Play said:

No as a library scan does not Refresh metadata of any item, it only looks for changes in media that has already been imported.  Now a New item yes.

After setting up everything when you do a library scan it actually pulls in all the pictures automatically now. I.e the disc image, thumb, and so on are all automatically pulled in with a library scan since it has all been set up. Just in case someone didn't know this information and was looking for it. 

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...