Jump to content

Music: "Various" folder and files keep disappearing from library


phunzie
 Share

Recommended Posts

phunzie

i have almost all my music organized in a Artist->Album->Files folder structure which works fine....but i have some audio files in a "Various" folder, and these files have all been tagged with "Various" as the "Album Artist"....i never had problems with this before, but now i notice this folder keeps disappearing from my library after a library update....if i refresh the metadata and do a library update, the folder and files will show up, but after subsequent library updates,  the folder disappears....i have verified several times that the audio files are tagged properly with "Various" as the "Album Artist"

any advice?

Link to comment
Share on other sites

quickmic
41 minutes ago, phunzie said:

i have almost all my music organized in a Artist->Album->Files folder structure which works fine....but i have some audio files in a "Various" folder, and these files have all been tagged with "Various" as the "Album Artist"....i never had problems with this before, but now i notice this folder keeps disappearing from my library after a library update....if i refresh the metadata and do a library update, the folder and files will show up, but after subsequent library updates,  the folder disappears....i have verified several times that the audio files are tagged properly with "Various" as the "Album Artist"

any advice?

Yes, please wait for 7.x. I'll release it in the next days as experimental. The complete music library has been redesigned.

In 6.x "samplers" have issues.

Link to comment
Share on other sites

phunzie

great, because i have been going crazy the last few days...after a complete database reset, i'll get my music library looking good, thinking everything is fine, but after another library update, i start noticing strange issues like folders disappearing from library or having artist's albums showing up in other artist's folders

looking forward to 7.x  👍

Link to comment
Share on other sites

phunzie

so far this is looking promising, even though i'm using it in Native Mode

but i'm still having a very strange issue...i have one album that keeps getting displayed in another Album Artist's folder....this album resides in a completely different folder on my HDD and has no tags related to the Album Artist folder it's getting put into...i have done countless database resets, i've removed the problem album folder, done a reset, then re-added the album and it still winds up displayed in the wrong Album Artist folder...i've also refreshed and confirmed the metadata for the album/files many times, and there is nothing i can find that connects it to the Album Artist it shows up in....there are no artist names, album names, track names, genre or anything else in common

AlbumArtists.PNG

Link to comment
Share on other sites

quickmic

Well, the plugin focuses on Artists not Albumartists (with stock Kodi config). I assume The affected Album has an Artist called "Irish Punk drinking songs" -> Is this actually an Artist ("Irish Punk drinking songs")?

If plugin would use Album Artist on regular base, I would really mess up the sorting. Currently albums (and songs) are assigned to all Artists of an Album or song. e.g.

Song "Say Say Say" from Michael Jackson and Paul McCartney will be assigned to both Artists.

Browsing "Michael Jackson" -> Say Say Say, browsing "Paul McCartney" -> Say Say Say.

If the plugin would use the Album Artist for assignment which should be "Various Artists", ONLY selecting "Various Artists" would list Say Say Say.

Possible would be to assign this song for all 3 Artists. "Various Artists", "Michael Jackson", "Paul McCartney". But this makes no sense to me, you would have (even with a medium sized collection) thousands of songs assigned to "Various Artists".

 

So you need to figure out, what Artists are assigned to the Album and probably I can tell you why it's listed that way. Could be still a bug, but not possible to trace the issue without detailed information.

 

 

 

Edited by quickmic
Link to comment
Share on other sites

phunzie

the affected album "The Essential 80s" has no artist remotely similar to "Irish Punk drinking songs", nor any songs remotely similar...there is nothing i can find that would lump this album in with "Irish Punk drinking songs"

this is your plug-in, so you obviously know how it's designed to work, but all i can say is that only within the last few weeks has this album been problematic...and it's not a recent addition, it's been part of my library for years...previously it has shown up properly in my Various folder along with several other albums/ mp3s that have been tagged with "Album Artist" = Various

below is a screen shot of my "Various" folder in my library, with compilation albums and oddball mp3's there as intended, only thing missing is the affected "The Essential 80s" album, which is tagged exactly the same as these albums/files (Album Artist=Various, Artist=actual artist name)...prior to a few weeks ago, it was there, but now for some reason it's lumped in with the Irish Songs album

below is the setting in Kodi ,"Show Song and Album Artist", that i have toggled Off, which has always shown my library organized by "Album Artist" only....if i toggle the setting to On, my library will show a folder for every Artist tagged in a song/mp3 in my library, similar to what you describe in your example

the reason i like using Album Artist= Various and displaying my library by Album Artist is that i have several compilation albums, with dozens of artists for which i may only have a single mp3, and i don't want all these artists cluttering up my library display

so if the plug-in is now working as originally intended, i guess i should consider myself fortunate that by some dumb luck/bug(?) it's worked how i wanted it to for the last few years

VariousFolder.PNG

AlbumArtistSetting.PNG

Link to comment
Share on other sites

quickmic
8 hours ago, phunzie said:

the affected album "The Essential 80s" has no artist remotely similar to "Irish Punk drinking songs", nor any songs remotely similar...there is nothing i can find that would lump this album in with "Irish Punk drinking songs"

this is your plug-in, so you obviously know how it's designed to work, but all i can say is that only within the last few weeks has this album been problematic...and it's not a recent addition, it's been part of my library for years...previously it has shown up properly in my Various folder along with several other albums/ mp3s that have been tagged with "Album Artist" = Various

below is a screen shot of my "Various" folder in my library, with compilation albums and oddball mp3's there as intended, only thing missing is the affected "The Essential 80s" album, which is tagged exactly the same as these albums/files (Album Artist=Various, Artist=actual artist name)...prior to a few weeks ago, it was there, but now for some reason it's lumped in with the Irish Songs album

below is the setting in Kodi ,"Show Song and Album Artist", that i have toggled Off, which has always shown my library organized by "Album Artist" only....if i toggle the setting to On, my library will show a folder for every Artist tagged in a song/mp3 in my library, similar to what you describe in your example

the reason i like using Album Artist= Various and displaying my library by Album Artist is that i have several compilation albums, with dozens of artists for which i may only have a single mp3, and i don't want all these artists cluttering up my library display

so if the plug-in is now working as originally intended, i guess i should consider myself fortunate that by some dumb luck/bug(?) it's worked how i wanted it to for the last few years

VariousFolder.PNG

AlbumArtistSetting.PNG

Have you searched in Emby for "Irish Punk drinking songs"? It should find something. If you found something, take a screenshot of the metadata please.

Can you also send me your Kodi's mymusic.db and emby_xxx.db via PM for review.

More infos later... I must think about what's going on in your library.

 

Link to comment
Share on other sites

phunzie
Posted (edited)

i made some changes before seeing your reply above....should not make any difference, but i renamed the Artist Album tag "Various" to "Various Artists"...i also tagged the Irish Drinking Songs album/songs to Album Artist=Various Artists, which is really where it belongs since it's a compilation album...i also removed the problem album, "The Essential 80s", from the library and added some other 80's compilation albums (all with AlbumArtist=Various Artists)...as you can see in shot below, everything is looking good for now

i'll also add that Emby server always showed the Artists, Albums, and AlbumArtists properly, including the "The Essential 80s" and "Irish Punk Drinking Songs" albums/mp3s...for some reason it was Kodi and/or the plug-in that was lumping those two items together when it came to displaying library by Album Artist, while all other 250+ albums and 4,000+ mp3s were organized and displayed correctly as tagged

a major thing that appears to be fixed in 7.0 is that my entire Various folder (now renamed Various Artists) is not disappearing any more 🤩....as mentioned in title of this thread, starting several weeks ago, the folder would appear properly after a database reset, but after a Library Update or two it would completely disappear

so for NOW, everything is looking good again...thanks for your great work on this awesome plug-in 👏

AlbumArtistDisplay.PNG

VariousArtists.PNG

Edited by phunzie
Link to comment
Share on other sites

quickmic
Quote

"Various" to "Various Artists"

Yes this makes a difference. I don't exactly know how Kodi internally handles samplers, but this is some sort of Musicbrainz "standard" and Kodi uses Musicbrainz.

Also the plugin uses "Various Artists" as a detection.

I also assume Emby does it too, but not sure.

 

Yes, "Various Artists" will not appear as Artist cause it's not an artist. But 7.x supports compilation detection (new feature) so you should be able to select your compilations with this sort option. Please try this.

 

 

Link to comment
Share on other sites

phunzie

i'll play around with compilation detection later

but as i've said before, everything had been working fine for several years, with the same library, up until a few weeks ago...this includes using "Various" as an AlbumArtist tag instead of "Various Artists"....but i don't know if it was after a Kodi update or a plug-in update that my problems arose recently

 

Link to comment
Share on other sites

quickmic

I see, "Various Artists" are listed in Artist selection in your screenshot. Have you included (Kodi settings) Album Artists as a browsing option? Cause "Various Artists" should not be included there.

Link to comment
Share on other sites

quickmic
8 minutes ago, phunzie said:

working fine for several years, with the same library

Well, I try to rebuild how stock Kodi would handle such cases. Therefore I tested adding same music library to Kodi and again with plugin. It should be the same -> that's the goal.

Even it was handled differently in the past, this doesn't necessarily mean it's "correct". I'll continue comparing stock Kodi vs plugin, I cannot rule out bugs at this point.

 

Edited by quickmic
Link to comment
Share on other sites

phunzie
Posted (edited)

the reason you see "Various Artists" is because the library is displaying by Album Artist and those albums/mp3s have tag AlbumArtist=Various Artists...for example, here is a screenshot of my AlbumArtist=The Sex Pistols....but i can make the AlbumArtist tag anything i want, and it will display that...like i now made the AlbumArtist=QuickMic for the same Sex Pistols album

the only place i find in the Kodi settings that mentions Album Artist is what i showed in a screenshot above (and below), "Show Song and Album Artist" that i toggle Off, which shows my library organized by "Album Artist" only....if i toggle the setting to On, my library will show a folder for every Artist tagged in a song/mp3 in my library, which adds a lot of clutter to my library view

SP.PNG

QM.jpg

AlbumArtistSetting.PNG

Edited by phunzie
Link to comment
Share on other sites

quickmic

Update:

I'll continue working on the issues asap. Focus is still on 6.x version, 7.x has lower priority at the moment.

Link to comment
Share on other sites

phunzie
Posted (edited)

that's cool...99%+ of time i use Kodi/Emby for movie watching, so music is not a major priority for me, although i do like to see my music organized...but so far 7.0 has been working really well....i do have issues when adding new music or updating the metadata of existing audio files, and the "Album Artist" and "Artist" tags are not the same, my library gets thrown out of whack...but worst case a database reset fixes everything...the movie and tv shows libraries seem to be working perfectly fine

it would be great if the plug-in continues to be compatible with Album Artist as a view option, as it is in stock Kodi and Emby server

Edited by phunzie
Link to comment
Share on other sites

quickmic
On 3/21/2022 at 6:24 AM, phunzie said:

that's cool...99%+ of time i use Kodi/Emby for movie watching, so music is not a major priority for me, although i do like to see my music organized...but so far 7.0 has been working really well....i do have issues when adding new music or updating the metadata of existing audio files, and the "Album Artist" and "Artist" tags are not the same, my library gets thrown out of whack...but worst case a database reset fixes everything...the movie and tv shows libraries seem to be working perfectly fine

it would be great if the plug-in continues to be compatible with Album Artist as a view option, as it is in stock Kodi and Emby server

...I have time to continue working on 7.x in the next days

btw, I already fixed several issues including artwork updates for music content. I'll release a new 7.x. version in the next days.

Can you please summarize, what issues are currently open from your side?

Edited by quickmic
  • Like 1
Link to comment
Share on other sites

phunzie
Posted (edited)

i've been using 7.x for almost 2 weeks....and it's been great except for only one single issue...the plug-in seems to have a problem when an audio file's "Artist" and "Album Artist" tags are not the same...if the audio files have both the "Artist" and "Album Artist" as the actual artist name, there is no problem....but, for example, if i have "Artist" = actual artist name, but "Album Artist" = xVarious Artistsx, a problem will develop (the folders will disappear)...same thing will happen with files i have tagged Artist = Leonard Bernstein, Album Artist =  West Side Story ST...and actually after a database reset everything appears fine, but it’s only after a subsequent library update/refresh, that the folders containing the files with the Artist/AlbumArtist mismatch will disappear

neither Kodi nor Emby Server have a problem displaying the library by Album Artist even with mismatched Artist/AbumArtist tags as you can see in the following Emby server screenshot

aside from this single issue with the Music library, the Movie and TV libraries have been working perfectly for me 

Emby_AlbumArtist.PNG

E4K_AlbumArtist1.png

E4K_AlbumArtist2.png

Edited by phunzie
  • Thanks 1
Link to comment
Share on other sites

quickmic
9 hours ago, phunzie said:

i've been using 7.x for almost 2 weeks....and it's been great except for only one single issue...the plug-in seems to have a problem when an audio file's "Artist" and "Album Artist" tags are not the same...if the audio files have both the "Artist" and "Album Artist" as the actual artist name, there is no problem....but, for example, if i have "Artist" = actual artist name, but "Album Artist" = xVarious Artistsx, a problem will develop (the folders will disappear)...same thing will happen with files i have tagged Artist = Leonard Bernstein, Album Artist =  West Side Story ST...and actually after a database reset everything appears fine, but it’s only after a subsequent library update/refresh, that the folders containing the files with the Artist/AlbumArtist mismatch will disappear

neither Kodi nor Emby Server have a problem displaying the library by Album Artist even with mismatched Artist/AbumArtist tags as you can see in the following Emby server screenshot

aside from this single issue with the Music library, the Movie and TV libraries have been working perfectly for me 

Emby_AlbumArtist.PNG

E4K_AlbumArtist1.png

E4K_AlbumArtist2.png

I've send you a test version via PM. Not sure if this fixes the issue, but please try it.

  • Like 1
Link to comment
Share on other sites

phunzie

ok, i installed the test version and will keep my eye on it...but it can be several days and/or library updates before the problem folders suddenly disappear

Link to comment
Share on other sites

quickmic
7 minutes ago, phunzie said:

ok, i installed the test version and will keep my eye on it...but it can be several days and/or library updates before the problem folders suddenly disappear

No problem, I just added the album artists when songs are synced and linked the songs also to album artists. As mentioned, not sure if this fixes the issue. Based on your report, there is a good chance.

Edited by quickmic
Link to comment
Share on other sites

quickmic
17 minutes ago, phunzie said:

folders suddenly disappear

This could be related to a different sort of issue I'm currently working on. Realtime updates could cause issues. At least I observed missing album tag infos on realtime updates like album artwork or album runtime missing. Emby server sends an added/updated item list as soon as a "filechange" was detected. At this point, not all tag infos are available. (musicbrainz queries are pending on Emby server when the update list was pushed)

Unfortunately, Emby doesn't sent another update list when all infos are added. On next version, I delay the realtime updates till Emby server (internal) sync has finished + 1 minute extra delay. Not nice but no other way at the moment.

 

Edited by quickmic
Link to comment
Share on other sites

phunzie

that sounds good....actually i stopped Emby server from scraping music metadata while troubleshooting what was causing the folders to eventually disappear, but it didn't have any effect on the issue...i guess i'll enable the scrapers again

will continue to stress test the plug-in

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...