Jump to content

File Permissions on new RAID array - what am I doing wrong?


SmilesOBrien
 Share

Go to solution Solved by SmilesOBrien,

Recommended Posts

SmilesOBrien

Hello,

Linux novice here, and I am out of ideas for solving this problem on my own. Forgive me if any terminology is incorrect, I will clarify if needed

---------- Preface ----------

I run a home NAS using OpenMediaVault, and have Emby installed via Docker image.

I recently rebuilt my RAID 0 array (bought new disks, restored data from a local backup) and am trying to reconnect my library.

The RAID's storage is located at /srv/dev-disk-by-uuid-d505f779-daca-47be-9bb1-176d8857b9e9

The root of my library directory is /srv/dev-disk-by-uuid-d505f779-daca-47be-9bb1-176d8857b9e9/NAS/Emby/ with subfolders there for TV, Music, Movies.

Previous to this RAID upgrade, I had Emby running like a dream.

---------- Problem ----------

When I try to add a library folder, I can get as far as /srv in my file directory. No subdirectories show up. I *think* I have Emby's user and group permissions tied into my main user permissions on my NAS (if smilesobrien is my main user group, emby's user and group accounts have permissions under smilesobrien). If I just add the full path, Emby complains it can't find the path.

Here's some of my permission settings

Emby group permissions:

emby : emby video render smilesobrien

/srv permissions:

drwxrwx---   8 smilesobrien smilesobrien  4096 Feb 14  2019 srv

/srv/dev-disk-by-uuid-d505f779-daca-47be-9bb1-176d8857b9e9 permissions:

drwxrwx---  4 smilesobrien smilesobrien 4096 Mar  6 16:52 dev-disk-by-uuid-d505f779-daca-47be-9bb1-176d8857b9e9

And the relevant subdirectories all have the same set of permissions

And this is what happens when I try to add a library folder to Emby:

image.png.159bcbcd5e016f8c5c7c920f80c5c710.png

ANd if I try to go further, I get an error stating it can't find the path.

I guess my hangup here is that everything looks right, but I can't tell what's wrong. Please let me know what other information you may need to assist!

Link to comment
Share on other sites

  • Solution
SmilesOBrien

Disregard!

This was a docker/portainer issue. I had neglected to update the volume mappings when I re-built my RAID. Doing so restored my previous server version (as the config was still there) and let me add/edit my libraries.

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...