Jump to content

TrueNAS Emby install - not visible via DLNA / WiFi


Frankie3142
 Share

Recommended Posts

Frankie3142

Hi!
I have just installed the Emby app on my TrueNAS system - latest versions of each. While the install went smoothly and looks really good when viewed from the attached PC via it's web interface, that's the only place it can be seen, which rather defeats the purpose. I wanted to use it as a home DLNA media server over wifi, but it won't show up. I have a Samsung Smart TV, model UE46ES8000. It can see several other DLNA servers I have, inc Plex, Serviio and Logitech Media Server, (I have reasons for wanting to uninstall and not use them), but I can never see Emby. As an aside, I have a Masters degree in computer science so yes, I've tried everything except witchcraft at this point. Nothing works. I even tried to create a minimal profile for my TV - that didn't help either.

 

Any hints as to what else I might try would be hugely welcomed. Thank you in anticipation!

 

Frank.

Edited by Frankie3142
Link to comment
Share on other sites

HI there, what version number of Emby Server exactly? Can you please attach the emby server log?

Thanks !

Link to comment
Share on other sites

Frankie3142

Hi Luke
Thank you so much for taking the time to consider my problem. Actually, I've browsed this forum looking at similar DLNA related issues and noted your input, and I have to say you must have the patience of a saint! So I'm sorry to anticipate that I might test your patience further here, although I shall try to be as helpful as possible too!

First, there have been a few developments since y last post, so let me begin anew. I'm using TrueNAS Core, current edition - 12.0-U8. Under 'Plugins' I notice now that it lists two separate community contributed copies of Emby, one called simply 'Emby', the other called 'Emby Server'.  However there are some key differences. This could get quite complicated to explain so I'll try to lay this out in a tabular fashion for clarity. I should note too that I'm making use of an Android app that looks for and makes DLNA connections and plays whatever it finds. The app's called "DMS Explorer" and I'm using it to help diagnose/verify the presence or absence of DLNA servers, as reported by my TV - the main thing I hope to connect here. One more item to help clear up potential confusion. Since both versions of Emby are available and we need to distinguish between the behaviour of each, I'll note that on TrueNAS, one has a pure green icon, while the other is predominantly white - see the attached image - as grabbed from the TrueNAS web interface. So for clarity I will refer to them henceforth as the 'green' version (aka Emby Server) and the 'white' version (aka Emby). Here's how they each behave.

Web interface:
Images.
White - full presentation of all images & metadata for both film and music libraries
Green - only the film library has all images; music library has no images at all

Play video through web interface.
White - videos play to the web GUI perfectly.
Green - video play fails. "Playback Error. No compatible streams are currently available. Please try again later or contact your system administrator for details."

Version Number.
White - 4.6.7.0, a url in the dashboard, linking to 'version 4.1.0.26' in it's release notes.
Green - as with White.

DLNA wifi visibility
White - Samsung TV cannot see it. Android app cannot see it.
Green - Samsung TV CAN SEE IT!. Android app can see it too.

DLNA Play
White - not visible so play not an option.
Green - TV reports 'no media present'. Android app CAN and DOES play it.
.

So in summary, Green seems the better bet because a) it's at least visible to the TV, and b) while the video doesn't show up on the TV (yet?), the video plays over wifi to the Android app. So it seems like just one problem to solve there - that of getting the video data to be visible to a Samsung Smart TV, model UE46ES8000. I tried adding a profile, including the model number, to no avail. I am guessing that Green's inability to play video over the web GUI (despite showing all the artwork) might somehow be related to it's inability to present any video streams to the TV either?

I attach the log file (from the Green version) that I hope will help you diagnose this peculiar situation Luke. Thank you in advance!

Emby Icons.jpg

embyserver.txt

Link to comment
Share on other sites

Hi, if you follow the install steps on our website then that should lead to a setup where this will work.

Link to comment
Share on other sites

Frankie3142

I found a solution to this item but the Forum won't let me delete this entry. Please ignore.

Edited by Frankie3142
Asked the wrong question here.
Link to comment
Share on other sites

Frankie3142

Hi!
I successfully installed from your website as suggested. Everything looked fine on the web GUI. Then I went to the TV. It saw Emby over DLNA/WiFi. When I selected it, it even reported the folder title at the top level ("Films", I'd called it, rather than 'Movies'). However, inside Films there were NO films. Nothing. Empty folder. This despite everything showing up 9and playing) via the local web GUI.

Please help. It feels so close now yet remains infuriating out of reach!

Thank you.

Edited by Frankie3142
Link to comment
Share on other sites

OK there is a chance this will be improved in the upcoming Emby Server 4.7 release. Thanks.

Link to comment
Share on other sites

Frankie3142

Is there nothing I can do now? Clearly the DLNA beacon is seen and linked to, but Emby isn't communicating in a, what? - 'basic enough' variant of the DLNA protocol for the Samsung TV to read -  so it thinks Emby has no content.

Are there no DNLA headers I can to apply or profile I can define or other endeavours I can try that might help it make the last hurdle in becoming a perfect player?

Thank you.

Link to comment
Share on other sites

The 4.7 release will be available in the coming days so I would suggest re-evaluating with that once you have it. Thanks.

Link to comment
Share on other sites

  • 1 month later...
Bikerchris

Less than helpful I appreciate, but I have the same config as you (TrueNAS) and found that my Nvidia Shield works without issue. I do have a Samsung TV I think, so I might see if that'll do what yours doesn't, in case that helps you.

Link to comment
Share on other sites

Bikerchris

I thought I'd try on the Samsung TV and it appeared to work fine, though I only tried a few films.

TrueNAS, as you'll know, is funny with permissions, I had to fiddle a little while to get it working reliably.

image.thumb.jpeg.1acf22822a3f8ab5e85cdfd16a5479d6.jpeg

  • Thanks 1
Link to comment
Share on other sites

Frankie3142

Hi

Thanks for that, but can you say what changes you made to TrueNAS'permissions? And this is running Emby in a Jail, right? And which version of Emby please? And which version of the logo (see my illustrated posting earlier in this thread)? Thanks Bikerchris! !

Link to comment
Share on other sites

Bikerchris

Hi Frankie, I'll certainly get you that info soon, unfortunately I had to do a long Mem test, get back to you when done!

Link to comment
Share on other sites

FreeBSD_Lover
On 08/04/2022 at 16:45, Bikerchris said:

Less than helpful I appreciate, but I have the same config as you (TrueNAS) and found that my Nvidia Shield works without issue. I do have a Samsung TV I think, so I might see if that'll do what yours doesn't, in case that helps you.

My Samsung TVs used to work pretty darn good with Emby providing DLNA; but after a TV update one day, bye bye Emby DLNA.  Although I seldom use it now, due to zero features capabilities (except raw streaming really), miniDLNA on FreeBSD still works flawlessly on those Samsung TVs. Both Emby DLNA and miniDLNA stream to my Onkyo AV receiver, which I currently only use to stream FLACs; and after I buy a new device (looks like NVIDIA Shield at the moment) I'm guessing/hoping the Shield will be the only playback device,.

FreeBSD Freshports - miniDLNA page

Thanks,

FreeBSD_Lover

Link to comment
Share on other sites

7 hours ago, FreeBSD_Lover said:

My Samsung TVs used to work pretty darn good with Emby providing DLNA; but after a TV update one day, bye bye Emby DLNA.  Although I seldom use it now, due to zero features capabilities (except raw streaming really), miniDLNA on FreeBSD still works flawlessly on those Samsung TVs. Both Emby DLNA and miniDLNA stream to my Onkyo AV receiver, which I currently only use to stream FLACs; and after I buy a new device (looks like NVIDIA Shield at the moment) I'm guessing/hoping the Shield will be the only playback device,.

FreeBSD Freshports - miniDLNA page

Thanks,

FreeBSD_Lover

What tv?

Link to comment
Share on other sites

  • 2 weeks later...
Bikerchris
On 09/04/2022 at 01:02, Frankie3142 said:

Hi

Thanks for that, but can you say what changes you made to TrueNAS'permissions? And this is running Emby in a Jail, right? And which version of Emby please? And which version of the logo (see my illustrated posting earlier in this thread)? Thanks Bikerchris! !

Hi again Frankie,

So here's my TrueNAS version:

image.png.f0afb9766c24da6974d4ecaffdd9b9d6.png

and here's my Plugin version (white background one):

image.png.55b392d6c728be532780a374177df0ef.png

Here's my dataset perms (not including myself, so I can move files to it)

image.png.439d5c5686c8c4c3e7da845a52788bf3.png

and here's my emby user account:

image.png.dbd7f8f09925466c87cfc6766a4a68a3.png

Hope that helps somehow!

Link to comment
Share on other sites

Frankie3142

Hi Bikerchris!

Thank you so much for your diligent, thorough and consistent help in this. It, and you, are so much appreciated. Thank you!

I am away from home this week, but next week I'll be able to compare our setti gs. All I know from memory is you have the very latest release of Truenas, while I am 2 behind you - out of timidity! The last update broke more than it fixed for me, so I will be more cautious this time :)

Thanks again. -  for now!

Link to comment
Share on other sites

Bikerchris

Hi @Frankie3142, you're very welcome, I know the frustrations with doing these things so I'll always try to help when able!

I can't imagine a TrueNAS version could be an issue - don't forget, you can always go back to a previous version pretty easily:

image.thumb.png.2917d181d88ce4b759ab85faea0be882.png

I have to say, whenever I've found something that's broken, it's normally fixed by the last time. TrueNAS does depend on valid issue tickets though...not that I've ever done one, as I don't know enough!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...