Jump to content

Kodi 19 freezes on resume, poor buffering


ChessHere1
 Share

Recommended Posts

ChessHere1

Hi all. Posting this cuz I literally spent days on this issue and thought I might be able to help others with this miserable issue. Kodi freezes with blue buffer circle at 100 - sometime with regular playback but almost always with resume or fast forward or backward. Tried umpteen fixes - advancedsettings parameters, cache settings, buffer modes, reading modes, switching between full screen and windowing. adjusting win10 parameters, nvidia graphics card parameters - nothing worked. Finally I found an advancedsettings.xml parameter that fixed the freezing 99% of the time. Turns out this network parameter "<nfstimeout>30</nfstimeout>" did the trick (Kodi 19 defaults to only 5 seconds - not sure if higher than 30 works but I only needed 30). I have 16 gb so I set cache to highest limit acceptable not sure I needed to but didn't hurt. Here is the full script I used for the AdvancedSettings.xml file - hope it helps you:

<advancedsettings>
<cache>
<buffermode>1</buffermode>
<memorysize>314572800</memorysize>
<readfactor>15</readfactor>
</cache>
<nfstimeout>30</nfstimeout>
</advancedsettings>
 

Good Luck...

  • Like 1
Link to comment
Share on other sites

Just for clarification, I assume you are using NFS shares to host your media?

Link to comment
Share on other sites

ChessHere1

I only use Kodi on win 10. I don't store media on my computer. But from what I observed, the links that gave me the most trouble all seemed to be from heavily accessed hosts using NFS. So.... this fixed my problem (significant fix too as I rarely if ever experience any lag now). Hope it helps you too.

Link to comment
Share on other sites

  • 1 month later...
ChessHere1

updaye:

 

fixed coding errors and changed vales. here is the new AdvancedSettings.xml I now use:

<advancedsettings>
<cache>
<buffermode>1</buffermode>
<memorysize>314572800</memorysize>
<readfactor>1999</readfactor>
</cache>
<network>
<nfstimeout>100</nfstimeout>
</network>
</advancedsettings>

I have 2gigs video mem and 16 gigs pc mem so i set memorysize as high as recommended (higher is supposed to cause kodi crashing issues)

set nfstimeout to 100 - this fixes buffering for links such as mixdrop, dood, and embitso. still takes time to fill buffer and you can't really jump past the grey buffer line but at least almost all freezing issues are gone.

set readfactor ridiculously high (won't cause kodi issues this high) but almost instantly buffers full movies on sites such as videoembed. because all the data downloads instantly you can jump back and forth to any spot in the movie without freezing, even the end.

I also tried a ton of different commands and values but the above ones made the difference.

 

 

 

Link to comment
Share on other sites

11 hours ago, ChessHere1 said:

updaye:

 

fixed coding errors and changed vales. here is the new AdvancedSettings.xml I now use:

<advancedsettings>
<cache>
<buffermode>1</buffermode>
<memorysize>314572800</memorysize>
<readfactor>1999</readfactor>
</cache>
<network>
<nfstimeout>100</nfstimeout>
</network>
</advancedsettings>

I have 2gigs video mem and 16 gigs pc mem so i set memorysize as high as recommended (higher is supposed to cause kodi crashing issues)

set nfstimeout to 100 - this fixes buffering for links such as mixdrop, dood, and embitso. still takes time to fill buffer and you can't really jump past the grey buffer line but at least almost all freezing issues are gone.

set readfactor ridiculously high (won't cause kodi issues this high) but almost instantly buffers full movies on sites such as videoembed. because all the data downloads instantly you can jump back and forth to any spot in the movie without freezing, even the end.

I also tried a ton of different commands and values but the above ones made the difference.

 

 

 

You could also try <memorysize>0</memorysize>

This would buffer the complete content to the local drive.

https://kodi.wiki/view/HOW-TO:Modify_the_video_cache

Seems to be odd you need the increase the NFS timeout by that much. In Linux (and I assume in Kodi too) you could try to adjust the mount parameters for nfs. There are lot's of options including r/w  sizes etc.

https://www.thegeekdiary.com/common-nfs-mount-options-in-linux/

 

btw, I assume you have a NAS as NFS fileserver? Is the NAs going into hibernate or does the disks spin down? This could explain the timeouts.

Edited by quickmic
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...