Jump to content

Pi3: The Do's and Dont's!


ScottBouch
 Share

Go to solution Solved by ScottBouch,

Recommended Posts

  • Solution
ScottBouch
Posted (edited)

So, I had a bit of a trial... My wife has friends coming over, and had promised a "Cinema Night", however I have recently been trying to improve my client attached to the projector. It's a Raspberry Pi 3.

I managed to get it working 1 hour before they arrived after spending all day trying to find a solution that worked.

Fail 1: OSMC with EmbyCon addon - Would only play the first 7 ot 8 seconds of any video then grind to a halt. OK for 7 second movies, useless for anything else. Details here

Fail 2: Emby Theatre - No matter what settings I tried (I systematically tried everything) the frame rate was just too slow, and lip sync miles out - unwatchable. Details here

Success! Libreelec (9.2.8) with EmbyCon addon (1.0.6) - bit of a faff to get the system clock set up (as could not add remote directory to download the add-on until the clock was working) but it now plays lovely! Hooray!!! Wish I'd tried this first......

Hope this helps others save to a day of ball-ache.

Cheers, Scott.

Edited by ScottBouch
Link to comment
Share on other sites

ScottBouch

Bit of further info regarding setting up the system clock with Libreelec on the Raspberry PI3. I have had this issue countless times with various flavours of Kodi install for Raspberry Pi (OSMC and Libreelec [and also the old Plex client in those pre-Emby days]) over the years.

First clue is not being able to make network connections - take a glance at the system clock, if it's out, you won't be able to make a network connection. There are many websites that list common issues with regarding Kodi, but none of them relate to getting the system clock right first.

Solution:

  • Set the correct region
  • Add three timeservers, the below works for me in the UK:
    • 0.pool.ntp.org
    • 1.pool.ntp.org
    • 2.pool.ntp.org
  • Select the "don't start Kodi until a network connection is established", and I set the timeout to 60 seconds to allow it plenty long enough to pick up.
  • Reboot

This then gives me flawless operation after subsequent reboots.

Cheers, Scott

Edited by ScottBouch
Link to comment
Share on other sites

TeamB

In all my years of playing with R Pi devices and having 4 in my home acting as media players and another 3 running as data loggers for things like temperature, power usage and environmental monitoring etc i have never seen this issue. I am using a mixture of wired and wifi and have never had to set the region before the network would connect.

It might not be a pi issue but something related to your network, as you said there does not appear to be anyone else having this issue.

Anyway glad you got it working.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...