Jump to content

Web player bug.


Bagul
 Share

Recommended Posts

pir8radio
8 hours ago, Bagul said:

Hello,
I have already compared. The proxy_send_timeout and proxy_read_timeout options are not specified and according to the nginx documentation the default values are 60 seconds.
I will try to remove the options to leave the default one but otherwise the rest is the same.

did you compare?   because i'm pretty sure I set mine high lol..  🙂    you don't want to go too high, maybe look a little closer at my example config... 😄     I thought @Luke we talked about this, nginx is happy as long as data is flowing, so a simple  transaction over websocket once a min is good enough.. like a ping..    just send anything.. lol    but i have not seen issues with it set to 1 hour..    that's high, I wouldn't do that on a busy commercial nginx server, but for your home should be just fine. 

    proxy_connect_timeout 1h;
    proxy_send_timeout 1h;
    proxy_read_timeout 1h;
    tcp_nodelay on;  ## Sends data as fast as it can not buffering large chunks, saves about 200ms per request.

 

Edited by pir8radio
Link to comment
Share on other sites

Posted (edited)

Hello, indeed I saw plenty, too many, tutorials on the forum including yours and it was indeed specified.
Sorry for my mistake.
I put it on an hour as you did and I will see if my problem disappears.

Sorry again for the mistake.

 

I will also try with traefik (https://hub.docker.com/_/traefik) to see if the problem is the same.

Edited by Bagul
  • Thanks 1
Link to comment
Share on other sites

pir8radio
On 1/7/2022 at 6:06 PM, Bagul said:

Hello, indeed I saw plenty, too many, tutorials on the forum including yours and it was indeed specified.
Sorry for my mistake.
I put it on an hour as you did and I will see if my problem disappears.

Sorry again for the mistake.

 

I will also try with traefik (https://hub.docker.com/_/traefik) to see if the problem is the same.

you are fine, i was joking around..  my humor is not always understood..  🙂  

Link to comment
Share on other sites

55 minutes ago, pir8radio said:

you are fine, i was joking around..  my humor is not always understood..  🙂  

No, It's ok it's ok. I just recognize my mistake. 🙂

I tried Traefik. I spent one night reading the documentation and I made my little settings and for the moment the problem is not present anymore while leaving the timeout settings as originally.

By doing benchmarks nginx is not necessarily better so the configuration with traefik suits me perfectly.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...