Jump to content

Emby 1.5.6 on Apple tvOS 15.1.1 multiple problems


ckhan
 Share

Recommended Posts

ckhan

tvOS: 15.1.1

Emby TV app: 1.5.6

Emby server: 4.4.3 on Synology NAS
 

Suddenly noticed multiple problems -- they must have started in the last few days because things were fine last weekend:

- Can't connect to server. See my server listed, but I just get a spinner

- Can't delete my server from the connection list -- it's listed but when I click to delete (I thought I'd delete/re-add) nothing happens

- Can't go to the app settings page from inside tvOS: Home -> Settings -> Apps -> Emby --> crash (back to home screen)

- After crashing the app from settings, I can't even start the Emby app -- get stuck on the splash screen.

- If I delete the Emby app and re-install it -- I can then launch the app, still get stuck connecting after I select my server

- In the emby logs, I only see:

2021-11-21 22:14:31.031 Info HttpServer: HTTP GET http://192.168.1.3:8096/emby/system/info/public. UserAgent: Emby/5 CFNetwork/1325.0.1 Darwin/21.1.0
2021-11-21 22:14:31.032 Info HttpServer: HTTP Response 200 to 192.168.1.26. Time: 1ms. http://192.168.1.3:8096/emby/system/info/public
2021-11-21 22:14:31.038 Info App: Udp message sent to 192.168.1.26:64181
 

Server itself is totally fine -- other clients play just fine (including browser, ios)

Any suggestions appreciated.

thanks, 

-ck 

 

 

Link to comment
Share on other sites

bitterrotten

My TV app started doing the same (but I didn't try to delete the server or have any problems with the settings). Not sure what the tipping point was. 

If you're unaware, we haven't been able to update the emby app via synology in a long time. It's part of their bait and switch business plan to sell you a versatile NAS that can do everything and then deliver an operating system that throws errors because you didn't buy their branded, marked up hard drives.

Griping aside, I've found that moving my config folder & media to an up to date docker container install worked immediately. I had to run the command via ssh but you could probably use portainer too.

Link to comment
Share on other sites

Didn't realize couldn't update the server through the Synology package manager. Manually updated to latest version, had to reconfigure everything from scratch (I'm sure if I knew what I was doing I could have preserved the original metadata database/config/etc.). Either way : it still didn't work from AppleTV, until I removed/updated AppleTV app again (now on 1.5.7) -- and now back to normal. Thanks for the suggestion.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...