Jump to content

Trouble Logging In from iOS Ap - all other clients OK


Tremas
 Share

Go to solution Solved by Luke,

Recommended Posts

Tremas

I am having the strangest issue trying connect to my server from the iOS ap. Everything was working well for several months and then boom, the ap kicked me back to the login screen and now I can't connect to the server (on the local network or from the internet). I can connect to the server using a web browser on the phone and I can log in from any other ap on my network (browser, Android and Roku). I've uninstalled/reinstalled the AP, restarted my iphone, router, emby server, etc. and no joy.

The server is running on a Synology box behind a reverse proxy. I thought maybe it was being blocked at the router or the Synology firewall, but I can't find anything in those logs to indicate that. The emby "system internal user" on the Synology box still has the correct permissions and the server seems to work with every other client. 

Basically, I start the iOS ap and get the "select server" screen. If I am on my local network, my server shows up as an option to select. If choose it, I get a spinning blue circle and then it just hangs. If I click "Ad Server," and enter the host information it just hangs. Below is the relevant section of the emby server log (I think) when attempting to log in on my local network.

I get the same "Error Server: Error processing request" if I try to log in from the internet.

Anyone have any suggestions on what this could be and what I can try next?

2021-10-09 14:25:12.299 Info Server: http/1.1 Response 500 to 192.168.50.114. Time: 2ms. http://192.168.50.196:8096/emby/users/public?X-Emby-Client=Emby%20for%20iOS&X-Emby-Device-Name=iPhone-Temposonics&X-Emby-Device-Id=0541F61B-27E1-47C3-90B5-97E88FB16BA1&X-Emby-Client-Version=2.0.10
2021-10-09 14:28:19.085 Info Server: http/1.1 GET http://192.168.50.196:8096/emby/system/info/public. UserAgent: Mozilla/5.0 (iPhone; CPU iPhone OS 15_0_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Mobile/15E148
2021-10-09 14:28:19.086 Info Server: http/1.1 Response 200 to 192.168.50.114. Time: 1ms. http://192.168.50.196:8096/emby/system/info/public
2021-10-09 14:28:19.102 Info Server: http/1.1 GET http://192.168.50.196:8096/emby/web/manifest.json. UserAgent: Mozilla/5.0 (iPhone; CPU iPhone OS 15_0_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Mobile/15E148
2021-10-09 14:28:19.102 Info Server: http/1.1 GET http://192.168.50.196:8096/emby/web/strings/en-US.json. UserAgent: Mozilla/5.0 (iPhone; CPU iPhone OS 15_0_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Mobile/15E148
2021-10-09 14:28:19.102 Info Server: http/1.1 Response 304 to 192.168.50.114. Time: 1ms. http://192.168.50.196:8096/emby/web/manifest.json
2021-10-09 14:28:19.102 Info Server: http/1.1 Response 304 to 192.168.50.114. Time: 0ms. http://192.168.50.196:8096/emby/web/strings/en-US.json
2021-10-09 14:28:19.112 Info Server: http/1.1 GET http://192.168.50.196:8096/emby/users/public?X-Emby-Client=Emby%20for%20iOS&X-Emby-Device-Name=iPhone-Temposonics&X-Emby-Device-Id=0541F61B-27E1-47C3-90B5-97E88FB16BA1&X-Emby-Client-Version=2.0.10. UserAgent: Mozilla/5.0 (iPhone; CPU iPhone OS 15_0_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Mobile/15E148
2021-10-09 14:28:19.114 Error Server: Error processing request
    *** Error Report ***
    Version: 4.6.4.0
    Command line: /volume2/@appstore/EmbyServer/system/EmbyServer.dll -programdata /var/packages/EmbyServer/var -ffdetect /var/packages/EmbyServer/target/bin/ffdetect -ffmpeg /var/packages/EmbyServer/target/bin/ffmpeg -ffprobe /var/packages/EmbyServer/target/bin/ffprobe -nolocalportconfig -ignore_vaapi_enabled_flag -pidfile /var/packages/EmbyServer/var/EmbyServer.pid -updatepackage emby-server-synology7_{version}_x86_64.spk -noautorunwebapp
    Operating system: Linux version 4.4.180+ (root@build13) (gcc version 7.5.0 (GCC) ) #41890 SMP Fri Jun 25 02:37:14 CST 2021
    Framework: .NET Core 3.1.13
    OS/Process: x64/x64
    Runtime: volume2/@appstore/EmbyServer/system/System.Private.CoreLib.dll
    Processor count: 4
    Data path: /var/packages/EmbyServer/var
    Application path: /volume2/@appstore/EmbyServer/system
    System.NullReferenceException: System.NullReferenceException: Object reference not set to an instance of an object.
       at Emby.Server.Implementations.Library.UserManager.GetInternalId(Guid id)
       at Emby.Server.Implementations.Security.AuthenticationRepository.<GetUserHistory>b__10_0(Guid i)
       at System.Linq.Enumerable.SelectListIterator`2.MoveNext()
       at System.Linq.Set`1.UnionWith(IEnumerable`1 other)
       at System.Linq.Enumerable.DistinctIterator`1.FillSet()
       at System.Linq.Enumerable.DistinctIterator`1.ToArray()
       at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)
       at Emby.Server.Implementations.Security.AuthenticationRepository.GetUserHistory(String deviceId)
       at Emby.Server.Implementations.Devices.DeviceManager.GetUserHistory(String deviceId)
       at MediaBrowser.Api.UserService.QueryUsers(BaseUserRequest request, Boolean filterByDevice, Boolean filterByNetwork, Boolean isAuthenticated, Boolean isInLocalNetwork, CancellationToken cancellationToken)
       at MediaBrowser.Api.UserService.GetUsers(GetUsersResult request, Boolean filterByDevice, Boolean filterByNetwork, Boolean isAuthenticated, CancellationToken cancellationToken)
       at MediaBrowser.Api.UserService.Get(GetPublicUsers request)
       at Emby.Server.Implementations.Services.ServiceController.GetTaskResult(Task task)
       at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, RestPath restPath, String responseContentType, CancellationToken cancellationToken)
       at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IRequest httpReq, ReadOnlyMemory`1 urlString, ReadOnlyMemory`1 localPath, CancellationToken cancellationToken)
    Source: Emby.Server.Implementations
    TargetSite: Int64 GetInternalId(System.Guid) 

Link to comment
Share on other sites

  • Solution

Hi, please see my response here:

Thanks.

  • Thanks 1
Link to comment
Share on other sites

Tremas

Thanks, @Luke. Looks like this is an issue that will be corrected in the next server release. Unfortunately, the work around will work when I am on the local network, but not if I try to connect from outside of the house (which is the primary use of emby for my phone). When I am outside of my network, I can get to the login screen and after I put in my information I get a "connection failure" message immediately - as if the request never got sent.

Any ideas, or am I out of luck until the next release?

Link to comment
Share on other sites

Tremas

Yes, I tried hiding all of my users from the login screen as noted in the the other post. That allowed me to log in as my main user when I am on the same local network as the server. That part of the workaround is successful. But if I disable wifi on my phone and try to run emby off of the cellular network it won't connect to the server. If i enter my user credentials again on the cell network, it gives me the "connection failed" error.

I haven't looked at the logs yet - I was just wondering if that was expected behavior.

Link to comment
Share on other sites

Quote

I was just wondering if that was expected behavior.

Not enough information to answer that. It could be the same issue, or it's possible you may have configured something to cause that. The server log would be the first step. Thanks.

Link to comment
Share on other sites

Tremas

...and I figured it out. I was right, the sign-in request from outside the network never hit the server. Nothing in the logs. It turns out that since I have uninstalled/re-installed the emby AP on my phone several dozen times trying to get this to work that the AP didn't have permission for cell data from the OS. I enabled that and it's working again. Thanks!

Edited by Tremas
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...