Jump to content

[DOCKER] HTTPS is not working


MrLinford
 Share

Go to solution Solved by Q-Droid,

Recommended Posts

MrLinford

Been a while since I have had to post so just a quick thank you.

I am running EmbyServer in a docker on my unRAID server (emby/embyserver:latest) and I'm trying to get HTTPS to work through my Nginx Proxy. HTTP works no problem.

Client: Docker Engine - Community
 Version:           20.10.5
 API version:       1.41
 Go version:        go1.13.15
 Git commit:        55c4c88
 Built:             Tue Mar  2 20:14:11 2021
 OS/Arch:           linux/amd64
 Context:           default
 Experimental:      true

Server: Docker Engine - Community
 Engine:
  Version:          20.10.5
  API version:      1.41 (minimum version 1.12)
  Go version:       go1.13.15
  Git commit:       363e9a8
  Built:            Tue Mar  2 20:18:31 2021
  OS/Arch:          linux/amd64
  Experimental:     false
 containerd:
  Version:          v1.4.3
  GitCommit:        269548fa27e0089a8b8278fc4fc781d7f65a939b
 runc:
  Version:          1.0.0-rc93
  GitCommit:        12644e614e25b05da6fd08a38ffa0cfe1903fdec
 docker-init:
  Version:          0.19.0
  GitCommit:        de40ad0

 

Client:
 Context:    default
 Debug Mode: false

Server:
 Containers: 12
  Running: 10
  Paused: 0
  Stopped: 2
 Images: 12
 Server Version: 20.10.5
 Storage Driver: btrfs
  Build Version: Btrfs v4.20.1 
  Library Version: 102
 Logging Driver: json-file
 Cgroup Driver: cgroupfs
 Cgroup Version: 1
 Plugins:
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: io.containerd.runc.v2 io.containerd.runtime.v1.linux runc
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: 269548fa27e0089a8b8278fc4fc781d7f65a939b
 runc version: 12644e614e25b05da6fd08a38ffa0cfe1903fdec
 init version: de40ad0
 Security Options:
  seccomp
   Profile: default
 Kernel Version: 5.10.28-Unraid
 Operating System: Slackware 14.2 x86_64 (post 14.2 -current)
 OSType: linux
 Architecture: x86_64
 CPUs: 8
 Total Memory: 15.34GiB
 Name: NEO
 ID: Y3GH:2DQQ:RWFG:TAIJ:3NPK:QLXK:M5QV:F22B:HCUV:QH5I:VBER:5M6B
 Docker Root Dir: /var/lib/docker
 Debug Mode: false
 Registry: https://index.docker.io/v1/
 Labels:
 Experimental: false
 Insecure Registries:
  127.0.0.0/8
 Live Restore Enabled: false
 Product License: Community Engine

 

docker run -d --name='Emby' --net='bridge' -e TZ="Europe/London" -e HOST_OS="Unraid" -e 'UID'='2' -e 'GID'='2' -e 'GIDLIST'='2,18' -p '8096:8096/tcp' -p '8920:8920/tcp' -v '/mnt/user/nas/':'/mnt':'rw' -v '/mnt/cache/appdata/EmbyServer/':'/config':'rw' --device=/dev/dri 'emby/embyserver:latest'

When going to my https address I get 502. Looking in the container logs I noticed I only see `Info App: Adding HttpListener prefix http://+:8096/` I can not see HttpListener for 8920.

image.png.bcc5cb3901f2a92a6e874e4b2ca6dde0.png  
image.png.599323702320776b0ea298a14a7e6474.png
  

image.png.12ad1018fe284d133b0788be5c4be6c8.png

 

Any thoughts why the container isn't starting HttpListener for 8920.

 

Thank you,

MrLinford

Link to comment
Share on other sites

  • Solution
Q-Droid

Your configuration for Secure connection mode "Handled by reverse proxy" and no certificate store means that Emby itself will not listen on 8920. It's up to you to configure your reverse proxy to handle the secure connections and rewrites from SSL client connections to non-SSL Emby connections on 8096.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...