Jump to content

Music Libary after Emby Update


Skyobliwind
 Share

Recommended Posts

Skyobliwind

Hi,

 

after Updating my Emby from a Version 4.5.x.x to 4.6.4.0 my Music libary is broken.

YES, I read something about a rescan of the music libary etc, but the rescan doesn't seem to change anything. Even setting the kind of structure from "different" to one of the "perfectly structured" options doesn't change anything.

I have a few Thousand Song all structured in

A -> Musicans -> Albums -> Tracks

B -> Musicans -> Albums -> Tracks

and so on.

What is very strange is, it shows exactly 4 Musicans in the libary and exactly 1 Album of each of these musicans....

I don't really get how that could happen.

Ideas how to fix this? What of the 3 structure options should I choose for my structure or do I have to restructure it and put all musicans in the root folder?

Link to comment
Share on other sites

Skyobliwind

Hm switching my structure to just

Musicans -> Albums -> Tracks doesn't even change anything.

The libary scan takes online lik 5 seconds that doesn't seem to fit the amount of music I have.

Link to comment
Share on other sites

mbarylski

Is your example above (A and B) the filename or the folder structure. Ideally the folders are set up like that: Musician\Album\Track Name. If it's perfectly organized in that folder structure then yes, that's the option you should pick. 

That said, I found at least that everything still needed to be tagged using a tool like Mp3tag. I've been making sure all my album artists have the MusicBrainzID included, which seems to have made a world of difference. When the tags weren't there, even though I had the correct structure, there were too many mismatches. It did take a fair amount of work to clean it up, but I believe I have about 20,000 songs so a few thousand probably won't be too bad.

Link to comment
Share on other sites

Skyobliwind

All my Songs are Tagged, ofc not with a MusicBrainz ID, but everything worked fine before the emby update and everything except my music libary still works fine. Nothing changed in the folder structure and even now when I switched to the "perfect structure"

Artist -> Albums -> Tracks

and set the libary to the "perfectly structured" option it's still not adding the other stuff only those 4 totally random picked artists with 1 album each. It's not the first or last artists or anything it just shows Avantasia, Kreator, Metallica, Slipknot while I have many Artists from A-Z.....

Maybe I can remove the whole libary and readd it or something. Don't rly have an idea what may be the problem. Structure is the same on all Songs, also those 4 artists, everything is tagged the same way using mp3tag it's all mp3 files, I don't understand why it's those 4 artists and nothing more 😅

Link to comment
Share on other sites

mbarylski

It could just be taking awhile to scan. It does take a long time. Think 5 - 10 hours for a few thousand songs. If you didnt add a MusicBrainzID though, it might not match correctly. I fought with it a long time trying to avoid MusicBrainzIDs but I eventually just gave up and tagged everything with MusicBrainzIDs.

Link to comment
Share on other sites

Skyobliwind

If I trigger a manual libary scan it's just 25% then 70% then 92% then 100% and finished within 5-10 seconds... I'm not sure if it still scans in the background or not...

Link to comment
Share on other sites

Happy2Play

Structure option only applies to use folder base images, all tabbed information comes from embedded tags except the Folder tab as of 4.6.

But real examples of the issue would be better to understand as right now I can not picture a issue.

MBZ is not needed, but Album/Artist and in some cases Album Artists is required.

Link to comment
Share on other sites

mbarylski
28 minutes ago, Happy2Play said:

MBZ is not needed, but Album/Artist and in some cases Album Artists is required.

People keep saying that, but I wasn't able to get it to work until I added MBZ tags 

Link to comment
Share on other sites

Skyobliwind

Ok, I found out if I just go on the "Directories" tab everything is there, only the "Artists", "Albumartists", "Albums" and "Componists" tabs are broken.

Attached pictures should explain what I mean. Also the songs don't show the covers, the albums when using the "directories" tab DO show the covers...

Artists.PNG

Songs.PNG

Folder Structure.PNG

Tagged.PNG

Link to comment
Share on other sites

Skyobliwind

Again everything worked fine before the update, I never even used music brainz because all my files are perfectly tagged and I don't need that.

Does emby read the tags differently now or anything?

Link to comment
Share on other sites

Happy2Play

Emby is dependent on tags now, where before structure has a factor.  Only factor structure has now is image saving/using.

With it set to perfect is should be seeing your folder based images like the folder tab.  But can you show your library options.

Link to comment
Share on other sites

Skyobliwind

Sry, was absent a few days.

No that didn't change anything.

Structure AND Tags should be good.

What kind of Tags do I need to use for emby? Every songs has an ID3 Tag created with MP3Tag including Title, Artist, Album, Year, Track, Genre, Album Artist and Componist and a Picture in 800x800 px. Some even have CD Numbers.

I don't really get how emby searches now. There is no difference within my files. Still emby finds only the 4 Artists in the Screenshot above and doesn't show the Pictures for the Songs (only for the album folder).

After all these days it definitly can't be a running libary scan in the background or anything.

Maybe I should delete the music libary and recreate it?

Link to comment
Share on other sites

mbarylski
3 minutes ago, Skyobliwind said:

Sry, was absent a few days.

No that didn't change anything.

Structure AND Tags should be good.

What kind of Tags do I need to use for emby? Every songs has an ID3 Tag created with MP3Tag including Title, Artist, Album, Year, Track, Genre, Album Artist and Componist and a Picture in 800x800 px. Some even have CD Numbers.

I don't really get how emby searches now. There is no difference within my files. Still emby finds only the 4 Artists in the Screenshot above and doesn't show the Pictures for the Songs (only for the album folder).

After all these days it definitly can't be a running libary scan in the background or anything.

Maybe I should delete the music libary and recreate it?

From my experience I needed to add the MusicBrainzID and make sure everything was perfectly organized in artist\album\track. I also needed to make sure albums were named EXACTLY the same as the folder names or it wouldn't match.

Link to comment
Share on other sites

Skyobliwind

Did you add the MusicBrainzID directly into the tag? If so under which tag? Or did you manually edit the metadata of every single album within emby? @mbarylski

I'll try the delete and recreate the emby music libary option first. This seems to be less work.

Link to comment
Share on other sites

mbarylski
2 minutes ago, Skyobliwind said:

Did you add the MusicBrainzID directly into the tag? If so under which tag? Or did you manually edit the metadata of every single album within emby? @mbarylski

Here's an example. Basically in mp3tag I set the MusicBrainz_AlbumArtistID, genre, Album Name, Album Artist, and Year at a minimum. There have been times that I've also needed to set the MusicBrainzAlbumID as well, but it's not always necessary. The MusicBrainz_AlbumArtistID isn't ALWAYS necessary either, but it does help. I believe I had 100 mismatches when I first set this up in preparation for the release and at the time I only added the MusicBrainz_AlbumArtistID for those 100. Over time though, I found more, so I kept adding them when I found issues, and now I just add it when new music is added just to make sure. The other thing I did was save artist and album art to my music folders. That way even if there is something not being picked up correctly, it should still grab the image from the folder. You can tell Emby to save the art automatically, but there will inevitably be art that Emby doesn't know about so those need to be added manually, and frankly, are more important than the art that Emby can detect.    

image.png.18cf68b625bbabeffc5e9d582128f535.png

 

2 minutes ago, Skyobliwind said:

I'll try the delete and recreate the emby music libary option first. This seems to be less work.

Yes, agreed, I did this too, because for whatever reason a fresh re-scan always does better than a scan after an update. It's irritating, and I've told Luke that it seemed necessary for me, but I don't think he believes me. 😅 It's also really easy, and hopefully you'll have less issues to clean up afterwards. I will say that I still had a considerable amount of cleaning up to do even after I deleted and re-created my music library, but it was a good amount less than if I hadn't started fresh.

Link to comment
Share on other sites

Quote

 and I've told Luke that it seemed necessary for me, but I don't think he believes me

Because it's not necessary. You've tinkered more than most users, and at times, this has required cleaning up and undoing, and somewhere along this process I think you came away with the perception that tagging with musicbrainz id's is required, but it is not. It certainly doesn't hurt though and will help with metadata lookups.

@Skyobliwind I wouldn't focus on the musicbrainz id's but rather the general embedded information within your files. I understand you think it's all correct, however you'll find other topics where users swore the same thing, and only after taking a closer look was it discovered not to be the case. 

A very common cause of this is that audio files can contain multiple versions of id3 tags embedded.  It's possible that your tagging software is writing one version, and Emby Server (via ffprobe) is reading another. That's why you want to make sure the tagging software is configured to write all versions of id3 tags.

Link to comment
Share on other sites

mbarylski
6 hours ago, Luke said:

Because it's not necessary. You've tinkered more than most users, and at times, this has required cleaning up and undoing, and somewhere along this process I think you came away with the perception that tagging with musicbrainz id's is required, but it is not. It certainly doesn't hurt though and will help with metadata lookups.

LOL, I had a feeling you'd say that. I don't think that's true, but I've given up trying to convince you. Agree to disagree I suppose. 😁

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...