Jump to content

Chrome 94 - cannot find local servers


notzippy
 Share

Recommended Posts

notzippy

Chrome (Version 94.0.4606.54 (Official Build) ) has implemented this https://wicg.github.io/private-network-access/ rule and enabled it by default in . This breaks emby web app on chrome when trying to read from local networks. in theory if "Access-Control-Allow-Private-Network: true" is set in the headers the headers this could be made to work. 

More info (https://stackoverflow.com/questions/66534759/chrome-cors-error-on-request-to-localhost-dev-server-from-remote-site) 

You can directly turn off this flag by going into the chrome settings and disable it (chrome://flags/#block-insecure-private-network-requests). Hopefully there will be a better solution in the future...

 

Nz

Edited by notzippy
Link to comment
Share on other sites

This does allow it again, but only when you are using the web app over https.

Link to comment
Share on other sites

Happy2Play

So the time has come and we should be seeing a lot more topics about http access failing showing invalid username/password on online web client.

 

Link to comment
Share on other sites

1 hour ago, Happy2Play said:

So the time has come and we should be seeing a lot more topics about http access failing showing invalid username/password on online web client.

 

Not username/password. It will just fail to connect.

Link to comment
Share on other sites

3 minutes ago, Happy2Play said:

I must be doing something wrong as mine currently gives me invalid username/password on http://app.emby.meda and logs me in on https://app.emby.media.

It will try the wan address, which might be able to connect but if you've got remote access disabled then you'll get that message.

Link to comment
Share on other sites

Happy2Play

And this time it let me log in, so I have not idea then

image.thumb.png.f55bd503a08149f416bf97e36e0950d3.png

 

Link to comment
Share on other sites

26 minutes ago, Happy2Play said:

And this time it let me log in, so I have not idea then

image.thumb.png.f55bd503a08149f416bf97e36e0950d3.png

 

Most likely using your remote access url.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...