Jump to content

Search the Community

Showing results for tags 'zap2epg'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 1 result

  1. Hi, I use XML files (xmltv.xml) generated using the zap2epg python script to map my channels. It works great for all channels except I'm running into an issue with ABC EPG data. It seemed to be working fine, but it appears that something in the XML file for ABC, maybe it's a special character that is causing a problem with SQ lite and the library.db file, I don't know. I have attached the xmltv.xml and embyserver.txt files. I pulled out just what I believe should be needed. When looking at the guide through the Emby client, doesn't matter if I'm using the Fire Stick TV, my phone app, or doing it on the server, for ABC it shows guide data properly all the way up to and including Jimmy Kimmel Live that starts at 11:35PM on 11/1/18 and ends at 12:37AM on 11/2/18, but then it shows nothing after that. It just shows <No Program Data Available> or blank depending on the client being used. All my other channels, and I have 45 Channels from HDHomerun Premium, and 30 OTA channels, guide data works fine. The EPG data after Jimmy Kimmel Live clearly exists in the xmltv.xml file, and I can't figure out what's wrong with it. The only thing I can think of is that there is something in it that SQ lite does not like, so when it imports that data into the library.db file, it messes up the EPG feed for ABC, and once it happens it is broke for good for that channel. I thought I could just shutdown the Emby server and rename the library.db file, and that would fix it, but I tried that once and it didn't, so I ended up completely uninstalling/reinstalling the Ember server to fix it... but at that time I had no data at all showing up for ABC, so I didn't really have any information to go on for root cause. I just did the uninstall/reinstall last night, and it looked like it fixed the problem because EPG data for ABC was showing up just fine, or so I thought. I realized earlier today that it was only showing guide data up to and including Jimmy Kimmel Live tonight, and that was it... the problem has returned after that. I appreciate you looking at this data below, and log file, and any insight you can provide to the root cause and permanent fix. Thanks in advanced. Brady embyserver.txt Sample_xmltv.xml
×
×
  • Create New...