Jump to content

Search the Community

Showing results for tags 'movflags'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 1 result

  1. lills

    Option to override ffmpeg command

    Hi, I cannot get Emby (Windows or Synology versions) to transcode mkvs (h265) to mp4 (h264) my Humax set top box connected to my TV. I believe my dlna profile is configured correctly as the Humax box see's the emby server and attempts to start transcoding the mkv to mp4. It tries for about 15 seconds and I can see that transcoded file building in the transcoding-temp folder. But I get the error 'unsupported format'. After looking at the ffmpeg log I could see it was trying to run this command: /var/packages/EmbyServer/target/ffmpeg/bin/ffmpeg -f matroska -i file:"/volume1/TV Series/Episode1.mkv" -map 0:0 -map 0:1 -sn -c:v:0 libx264 -force_key_frames "expr:gte(t,n_forced*5)" -pix_fmt yuv420p -maxrate 2797563 -bufsize 5595126 -preset veryfast -profile:v:0 high -level:v:0 4.1 -crf 50 -x264opts:0 subme=0:me_range=4:rc_lookahead=10:me=dia:no_chroma_me:8x8dct=0:partitions=none -vsync -1 -map_metadata -1 -map_chapters -1 -threads 0 -codec:a:0 copy -metadata:s:a:0 language=eng -disposition:a:0 default -f mp4 -movflags frag_keyframe+empty_moov -y "/var/packages/EmbyServer/target/var/transcoding-temp/0f3c8cf01426f08cce293ae4187ac740.mp4" I then decided to run this command manually and then stream the resulting mp4 file to my box and it would not play (unsupported format). After a lot of trial and error, I modified the command above (replacing -movflags frag_keyframe+empty_moov with -movflags faststart and then the mp4 file would stream to the Humax box no problem. So I was wondering, is it possible to override the built in ffmpeg command so that I can specify -movflags faststart. Log file attached Many thanks Lills
×
×
  • Create New...