Jump to content

Search the Community

Showing results for tags 'elementary'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 1 result

  1. I'm not sure if this is a known issue. I am running elementary OS, which is based on Ubuntu 14.04. After installing, attempting to play transcoded streams gave me: The logs told me FFmpeg had exited with error code 1. When I attempted to run the ffmpeg command myself, it turned out to be a symlink to avconv, which gave me: I found the solution on this forum. Apparently Ubuntu 14.04 includes libav instead of the original ffmpeg, and they are not 100% compatible. I had to install the original ffmpeg from a PPA to fix the issue. I am posting it here because this likely affects all Ubuntu 14.04 installs. For reference, this was the log output: 2016-07-03 16:26:58.1187 Info App: /usr/bin/ffmpeg -fflags +genpts -i file:"/media/data/somefile.mkv" -map 0:0 -map 0:1 -codec:v:0 libx264 -force_key_frames expr:gte(t,n_forced*5) -copyts -avoid_negative_ts disabled -start_at_zero -pix_fmt yuv420p -preset superfast -crf 23 -b:v 7026752 -maxrate 7026752 -bufsize 14053504 -vsync vfr -profile:v high -level 51 -filter_complex "[0:3]format=yuva444p,scale=1920:1080,lut=u=128:v=128:y=gammaval(.3)[sub] ; [0:0] [sub] overlay" -map_metadata -1 -threads 0 -codec:a:0 libmp3lame -ac 2 -ab 128000 -af "aresample=async=1" -y "/var/lib/emby-server/transcoding-temp/42e6e4097c3e1841e03b65e72f16bab9.mkv" 2016-07-03 16:26:58.1895 Info App: FFMpeg exited with code 1 2016-07-03 16:26:59.2427 Error App: Error streaming media. The client has most likely disconnected or transcoding has failed. *** Error Report *** Version: 3.0.5973.0 Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -ffmpeg /usr/bin/ffmpeg -restartpath /usr/lib/emby-server/restart.sh Operating system: Unix 3.16.0.38 Processor count: 4 64-Bit OS: True 64-Bit Process: True Program data path: /var/lib/emby-server Mono: 4.2.1 (Stable 4.2.1.102/6dd2d0d Thu Dec 3 04:04:55 UTC 2015) Application Path: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe One or more errors occurred. System.AggregateException at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks, Int32 millisecondsTimeout, CancellationToken cancellationToken) <0x7f7c4df83110 + 0x005a9> in <filename unknown>:0 at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks, Int32 millisecondsTimeout) <0x7f7c4df830b0 + 0x00028> in <filename unknown>:0 at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks) <0x7f7c4df83020 + 0x00016> in <filename unknown>:0 at MediaBrowser.Api.Playback.Progressive.ProgressiveStreamWriter.WriteToInternal (System.IO.Stream responseStream) <0x4189b910 + 0x000e4> in <filename unknown>:0 InnerException: System.IO.FileNotFoundException Could not find file "/var/lib/emby-server/transcoding-temp/42e6e4097c3e1841e03b65e72f16bab9.mkv". at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean anonymous, FileOptions options) <0x7f7c4e03f060 + 0x005cd> in <filename unknown>:0 at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize) <0x7f7c4e03ed20 + 0x0004d> in <filename unknown>:0 at (wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare,int) at CommonIO.ManagedFileSystem.GetFileStream (System.String path, FileMode mode, FileAccess access, FileShare share, Boolean isAsync) <0x414a90c0 + 0x000bd> in <filename unknown>:0 at MediaBrowser.Api.Playback.Progressive.ProgressiveFileCopier+<StreamFile>c__async0.MoveNext () <0x4189bfe0 + 0x000d6> in <filename unknown>:0
×
×
  • Create New...