Jump to content

Installation Problems on Windows Server 2025


Recommended Posts

MartinCheetham
Posted

I have a problem.  I have been forced to move off of Ubuntu on my EMBY installation as my graphics card is no longer supported under Linux.  Tried Windows but the NIC card is not supported (it's an enterprise class so Windows 11 doesn't have the drivers) so I finally ended up with Windows Server 2025 which supports all of the hardware perfectly.   EMBY Server installs and runs perfectly  but I am struggling to get EMBY Theater running.  This might sound like an odd setup but the server is connected to a video switch which distributes video to multiple TVs throughout my home so it is ideal for me.  Windows Server doesn't support the GUI for Microsoft store but it does support installation using winget (earlier versions of Windows Server didn't).  So the command (elevated powershell) "Winget install 9NBLGGH4T70L --source msstore".  Works perfectly.  The problem is that when I start EMBY Theater I get the splash screen and the moving lines then it freezes to a blank white rectangle and a message is displayed that either i don't have permission to access or a file is missing.  Unfortunately the file name is truncated after the path (C:\Program Files\WindowsApps\) the name starts with EmbyMedia.EmbyTheater_2.317.2.0_neural-~-svmepx4c03f7m....... I've checked and there are several files in the folder with names which start like this.  Any Ideas?

Plan B was to use the portable version of EMBY Theater.  Sadly this is no longer supported.  I did sort of get it to run but key features such as being able to access the setup screens don't work.

So could someone help to get the MS store version working on Windows Server 2025 or could you reinstate the .exe which i can install on my platform?  Thanks.

Posted

Hi, can you please show a screenshot of the message? Thanks.

MartinCheetham
Posted

Perhaps I don't I understand exactly how your fix works I entered  "wsreset -i" in an elevated powershell before installing EMBY Theater (using the Winget command) and afterwards but  I get the same error.  I have posted a screen shot.  Please explain if I have installed incorrectly or used the wsrest command wrongly.  Thanks.

Screen Shot 1.jpg

Mahinepua
Posted

Install the ms store first don’t use winget. 

Once the store is installed install emby from there.

MartinCheetham
Posted

Hi Mahinepua, Thank you for the clarity and guidance.  I got MS store installed and used it to install EMBY.  Unfortunately I got the same error so I decided to start digging a bit deeper.  It turns out that MS Store really messes with permissions on the installation folders.  For some reason the ADMINISTRATOR group only get assigned "READ CONTENTS".  I tried to take ownership and change but no luck.  I did notice that USERS had READ, EXECUTE etc.  So I created a new user installed EMBY again and it works!  The lesson then is install EMBY on Windows Server 2025 as a USER not as ADMINISTRATOR. 

  • Thanks 1
MartinCheetham
Posted

I have an update to this.  Perhaps it should be a new thread but it is probably related to the Windows Server 2025 installation.  EMBY Server is running on this server as a service.  Remote machines can access it and playback media so everything is defined correctly and working.  When running locally neither EMBY Theater or the Web interface can replay media.  The  error is that the directory could not be found.  The drive V: is mapped to the location of the films.  I tried to add a new directory to the library, mapped drives (V:, U:, Z:) are not seen.  I tried the "Network" option.  It returns blank.  I also tried manually typing the UNC.  This also comes back as not found.  So in short EMBY Server running as a service has a problem with networked media on Windows Server 2025.  Running EMBY Server "normally" it runs correctly. 

Playback Error 1.jpg

Playback Error 2.jpg

Playback Error 3.jpg

Neminem
Posted (edited)

I think running Emby Server as a service, the service user needs access to files to.

This link might help you.

Running as Windows Service | Emby Documentation

Disclaimer : I have not used windows for Emby Server i years.

Edited by Neminem
MartinCheetham
Posted

Yes thank you for this but that was the guide that I followed when I installed EMBY Server as a service.  Runs this way on Windows 11 perfectly.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...