Jump to content

Messed up libraries after upgrade to 4.6.2


flirble
 Share

Recommended Posts

I upgraded to 4.6.2 this week and all my metadata is broken, my albums are now all split out (mainly ones where I had updated album artist to Various Artists so it would sort and display properly instead of an entry per track), artwork that was present is now 'missing', albums I had updated sort titles and stuff on are now where they used to be as if I'd never sorted them out - total mess in my libraries post upgrade.

We followed the instructions to download and drag into applications folder, no deleting or anything else just followed the steps...

Very disappointed with how my entire library is now NOT how it was pre upgrade and now I have to go fix it all again 😞

Link to comment
Share on other sites

Upgraded to 4.6.2 this week and discovered all my libraries are messed up, all my 'sort order' tags seem to be 'gone' so my movies are out of sequence, my music is a mess and albums that were displaying as a single albums are now all broken down and displaing in the library as individual tracks - looks like some metadata isn't being read in or if it is it's being ignored as part of the display/sorting process...

but my libraries are now a mess 😞 bad upgrade experience.

Link to comment
Share on other sites

Yes for my music they were 'arranged' as per the article, I use album/artist setup - I did fix it all by updating tags the odd thing was BEFORE the update everything displayed correctly but then all went wrong :( additionally I've identified a Sort Order problem in that in metadata manager I have completed the Sort Order tag for a set of albums so they should display in the right sequence, however in the library they do not display in the right sequence and when I view the metadata for an album the Sort Order tag is empty, but if I go view same item in metadata manager the Sort Order tag is completed as I did it... not sure what's happening but my library looks ugly right now and my OCD is going haywire!

Link to comment
Share on other sites

8 hours ago, flirble said:

the odd thing was BEFORE the update everything displayed correctly but then all went wrong

Yes as Emby went from a structure and tag requirement to Tag only requirement (structure is irrelevant).

Yes there is a order issue in the Metadata Manager as tracks are sorted alphabetically vs by track number.  Discussed here

Link to comment
Share on other sites

3 hours ago, Luke said:

hi @flirble has this answered your questions?

no not totally, I see the topic on the sort order issue, but my point was that I have filled in the ''Sort Order' attribute, in metadata manager it shows populated, however in library it is blank/empty - I'm working with a specific set of music and the sequence it is displayed in in my library is important but it won't display correctly - even with the tags populated in metadata manager....

Link to comment
Share on other sites

4 minutes ago, flirble said:

no not totally, I see the topic on the sort order issue, but my point was that I have filled in the ''Sort Order' attribute, in metadata manager it shows populated, however in library it is blank/empty - I'm working with a specific set of music and the sequence it is displayed in in my library is important but it won't display correctly - even with the tags populated in metadata manager....

There is an issue in the metadata manager relating to this sorting, yes, but in all other places it should be fine and is sorted by track numbers. Does that help?

Link to comment
Share on other sites

5 minutes ago, Luke said:

There is an issue in the metadata manager relating to this sorting, yes, but in all other places it should be fine and is sorted by track numbers. Does that help?

Luke, you are missing my point I think.

In Metadata Manager I have diligently gone into each album and set the 'Sort Title' attribute, this is being IGNORED by the library, so the albums themselves appear out of order based on the Sort Title I have populated, and when I drill in to view the metadata the attribute is empty, whereas in Metadata Manager the attribute IS populated correctly.... so in MM it's present as I completed it, in the Library it is empty and album is not displayed in the right sequence.

Would a screenshot help illustrate.... now98.png is metadata manager, now98_broken.png is library

now98.png

now98_broken.png

Link to comment
Share on other sites

11 minutes ago, flirble said:

Luke, you are missing my point I think.

In Metadata Manager I have diligently gone into each album and set the 'Sort Title' attribute, this is being IGNORED by the library, so the albums themselves appear out of order based on the Sort Title I have populated, and when I drill in to view the metadata the attribute is empty, whereas in Metadata Manager the attribute IS populated correctly.... so in MM it's present as I completed it, in the Library it is empty and album is not displayed in the right sequence.

Would a screenshot help illustrate.... now98.png is metadata manager, now98_broken.png is library

now98.png

now98_broken.png

Hi, they appear out of order where? In the metadata manager? If that's what you're referring to, then I've already acknowledged the issue.

If you're referring to other areas, they don't sort by title, they sort by track numbers. The sort title field is only used when sorting by title.

Link to comment
Share on other sites

no they are out of order in the Library - and I can't see any reason why... it's not the tracks that are out of order but the Albums

Link to comment
Share on other sites

2 hours ago, flirble said:

Luke, you are missing my point I think.

In Metadata Manager I have diligently gone into each album and set the 'Sort Title' attribute, this is being IGNORED by the library, so the albums themselves appear out of order based on the Sort Title I have populated, and when I drill in to view the metadata the attribute is empty, whereas in Metadata Manager the attribute IS populated correctly.... so in MM it's present as I completed it, in the Library it is empty and album is not displayed in the right sequence.

Would a screenshot help illustrate.... now98.png is metadata manager, now98_broken.png is library

now98.png

now98_broken.png

Because Metadata Manager is presenting FOLDER not ALBUM.  So library Folder tab will show the same (using Sort by Title) as Metadata Manager for album order, but Albums tab or Artist view will not. @Luke But this is a change in 4.6.

foldername.thumb.jpg.dcd73d4fa1139a7cee9fa264e98c62ef.jpg

Edited by Happy2Play
Link to comment
Share on other sites

Yes happy2play is right. The albums and the folders are two separate things. Try editing the sort title of the albums when browsing album view and see if that helps.

Link to comment
Share on other sites

12 minutes ago, Luke said:

Yes happy2play is right. The albums and the folders are two separate things. Try editing the sort title of the albums when browsing album view and see if that helps.

But previous versions this view was not the case as MM showed the Album not the folder.  Is this do to Albums being created from embedded metadata?

@flirbleyou can also tell by scrolling down in the metadata and see all information missing on Folder vs Album.

Edited by Happy2Play
Link to comment
Share on other sites

57 minutes ago, Happy2Play said:

But previous versions this view was not the case as MM showed the Album not the folder.  Is this do to Albums being created from embedded metadata?

@flirbleyou can also tell by scrolling down in the metadata and see all information missing on Folder vs Album.

We're going to have to remove the ambiguity by having the metadata manager show the same sub-categories that the UI does.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...