Jump to content

3D Discussions


chessdragon136
 Share

Recommended Posts

chessdragon136

Hi All,

 

Firstly, 3D playback is not implemented in the app, however, some files (FSBS) seem to auto switch as part of the Samsung inbuilt player that is used in the app. I plan to add support to switch to the correct 3d mode based on the metadata held on the server..

 

Just hang on :D

 

Feel free to discuss this here 

Edited by chessdragon136
Link to comment
Share on other sites

chessdragon136

Ahh I wish you didn't - its not a MBS issue. If you want to test copy your files to a usb stick and plug it in the side of the tv and play them... See what switches automatically then. 

 

Different tv manufacturers will support auto switching of different formats of 3d formats. How they determine the files are 3d is either a flag embedded in the file (MKV I think has a stereo_mode that will state) or the tv does some analysis of the files (or it may use filename) 

Link to comment
Share on other sites

chessdragon136

Back to Samsung then -> How do you switch the tv to 3D mode - all i can see is switching on 2D -> 3D and it doesn't seem to do much.

Link to comment
Share on other sites

Glyde62

I just tried a heap of my 3DMovies and only found one that auto switched on my Samsung The Amazing Spiderman and no others with [sBS3D] in folder name switched.

The file name of the movie is The Amazing Spiderman 3D.mkv Tried renaming a few other movie to similar but no luck getting them to switch automatic.

Link to comment
Share on other sites

For FSBS content the TV does it, but for HSBS I press the 3D button.

That's because fsbs is twice the horizontal resolution. Easy to detect. Hsbs is the same resolution as a normal video so it can't detect it.

 

The way Plex requires the files for 3d is you need to have fsbs or hsbs in the filename.

 

Sent from my Nexus 7 using Tapatalk

Edited by Jasin
Link to comment
Share on other sites

chessdragon136

Ok I've been playing around with 3D early this morning as I couldn't sleep and I can now turn it on via a button in my app but cannot do it automatically atm - It seems to be a known issue : http://www.samsungdforum.com/SamsungDForum/ForumView/f0cd8ea6961d50c3?forumID=9fa5738f200cd0b0

 

I also came across this link that may explain the auto switching

http://support-us.samsung.com/cyber/popup/iframe/pop_troubleshooting_fr.jsp?modelname=UN46C9000ZF&idx=390919&modelcode=&

Link to comment
Share on other sites

chessdragon136

Ok I'm getting somewhere - I can auto switch some HSBS content on my tv :D 

Win

  • Like 3
Link to comment
Share on other sites

crashkelly

Hi,

 

Okay, I am running tests on my Samsung PN51F5500 and I finally got a hsbs file to direct play to the tv, but it did not auto switch into 3D. Once I manually selected the 3D mode it was all good.

 

File was created with DVDFab and is named HANSEL_AND_GRETEL_WITCH_HUNTERS_3D_[hsbs].mkv and is in a folder called Hansel & Gretel Witch Hunters [hsbs] (2013)

 

I first tried a fsbs file but DVDFab ramped it up to h264 profile 5 which will not direct play, still trying to figure out why it did that.

 

Have also been trying to research whether or not my TV will auto switch for 3D or not. Nothing in the documentation and nothing on the TV settings.

 

Short of tearing apart a media setup in another room to move the 3D BD player there I have no way of testing if the TV will auto-switch to 3D.

 

Anyone have experience with this tv or might have an idea if I am doing something wrong

 

Thanks

CrashKelly

 

BTW: I did post about some file stuff in the DNLA thread and I am not trying to double post. Thought I would bring it in here as it is now about the Samsung TV and the app

Link to comment
Share on other sites

chessdragon136

If the tv has a usb socket plug in a flash drive with the film on it and play in the inbuilt player and see if it switches..

 

My first check however would be to see if the server sees the file as 3D- My guess is that it doesnt, and if MBS doesnt see the file as 3D the app won't switch. 

Beyond that I'll need to know the file info taken from the web interface. 

 

Thanks

  • Like 1
Link to comment
Share on other sites

crashkelly

If the tv has a usb socket plug in a flash drive with the film on it and play in the inbuilt player and see if it switches..

 

My first check however would be to see if the server sees the file as 3D- My guess is that it doesnt, and if MBS doesnt see the file as 3D the app won't switch. 

Beyond that I'll need to know the file info taken from the web interface. 

 

Thanks

 

I believe the TV has a usb port and if it does I will try it as soon as I go buy a flash drive as I do not own one :o

 

MBS sees the file as 3D but that is only due to the [hsbs] or [fsbs] in the file\folder name

 

Here is the media info from the hsbs file that I got to direct play

53fcd121bc4b9_MediaInfo4.jpg

 

I will post regarding the USB drive test

 

Cheers

CrashKelly

Link to comment
Share on other sites

CBers

Is the filename correctly tagged??

 

Shouldn't it be file (year) [hsbs].mkv?

 

Ignore me if I'm wrong.

  • Like 1
Link to comment
Share on other sites

crashkelly

Is the filename correctly tagged??

 

Shouldn't it be file (year) [hsbs].mkv?

 

Ignore me if I'm wrong.

 

Really not sure, but I will give it a go

 

Cheers

CrashKelly

 

EDIT: Does the folder name matter?

Edited by crashkelly
Link to comment
Share on other sites

CBers

Really not sure, but I will give it a go

 

Cheers

CrashKelly

 

EDIT: Does the folder name matter?

I don't believe so, as I have my 3D versions in with my 2D versions and the folder doesn't include the tag.

Link to comment
Share on other sites

crashkelly

Tried it again with the file name change and no difference

 

53fcdac1cec47_MediaInfo5.jpg

 

Will try the USB stick next

 

Cheers

CrashKelly

Link to comment
Share on other sites

crashkelly

If it says 3D like it does in this one then it's detected correctly:

 

53fcd9582dba8_Capture55555.png

 

It does say 3D and Covert Art automatically loads my 3D logo onto the cover

 

Still have to test USB

 

Thanks

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...